none
Install an application Only if .NET Framework 4.5.1 or higher is installed? RRS feed

  • Question

  • Hey could someone guide me here? Here is my situation:

    I have a piece of software that requires .Net 4.5.1 or Higher to be installed.  I want to put some sort of logic into the script that checks the workstation.  If 4.5 or less is installed it will install 4.6.1 but if the workstation has 4.5.1 or higher  it will just install the application.  

    I know what everyone is saying, why not just install 4.6.1 and be done with it?  Don't want to take a chance on breaking something!

    any advice would be greatly appreciated.

    thanks.

    Friday, March 25, 2016 8:00 PM

Answers

  • Create two deployment types and a custom global condition for checking the .net version, one dt will install with .net 4.6.1 as a dependency and the another one doesn't have any dependencies. For creating the global condition, check this post for checking the .net version http://woshub.com/how-to-check-net-framework-version/
    Saturday, March 26, 2016 8:07 AM

All replies

  • Hi,

    I suppose the easiest way is that you let the software have prerequisites of .Net 4.5.1.
    The below is a screenshot of Project Properties.

    Regards.
    Saturday, March 26, 2016 7:59 AM
  • Create two deployment types and a custom global condition for checking the .net version, one dt will install with .net 4.6.1 as a dependency and the another one doesn't have any dependencies. For creating the global condition, check this post for checking the .net version http://woshub.com/how-to-check-net-framework-version/
    Saturday, March 26, 2016 8:07 AM
  • Very easy if you Go with dependency mechanism that will fit to your requirement. 

    Please click answer If it works Thanks KMI

    Sunday, March 27, 2016 6:33 PM
  • This worked for me thanks.

    Wednesday, April 6, 2016 11:45 AM