none
Term Store Management Tool not working

    Question

  • Hello All Gurus - The Managed Metadata Web Service shows "Started" and Managed Metadata Service Application is Started. I checked IIS the application pool is fine. I checked the Permission on  MMS Application which is set correctly. The issue is When browse the "Term Store Management Tool", it is showing "The Managed Metadata Service or Connection is currently not available. The Application Pool or Managed Metadata Web Service may not have been started." I checked the event log, It shows  Warning 8088 (The Managed Metadata Service 'WK_Managed_Metadata_Service' is inaccessible.) and in fraction of a second gives 8090 (The Managed Metadata Service 'WK_Managed_Metadata_Service' has connected successfully.) This issue started after Windows Update on the Server. 

    Could anyone please throw some light what is happening and what could do to fix it?

    Thanks & Regards,


    Khushi

    Monday, April 17, 2017 7:25 PM

Answers

  • Update: I was able to solve it following this article. I did changed the name of the Managed Metadata Database and then set it back to old database

    https://blog.areflyen.no/2014/08/21/the-managed-metadata-service-or-connection-is-currently-not-available-in-sharepoint-2013/

    Thank you Linda and Lakshamanan.


    Khushi

    • Marked as answer by KhushiSShaikh Thursday, April 20, 2017 9:26 PM
    Thursday, April 20, 2017 9:25 PM

All replies

  • Hi Khushi

    Please check this below

    https://social.technet.microsoft.com/Forums/office/en-US/5d343f3f-2da8-4a31-ad17-e393340d64c9/the-managed-metadata-service-managed-metadata-service-is-inaccessible?forum=sharepointadminprevious


    Please remember to click Mark as Answer on the answer if it helps you

    Monday, April 17, 2017 9:11 PM
  • Hi Khushi,

    Please also check if the IUSR is added in Anonymous Authentication in IIS.

    1. Open the IIS and click on the server.

    2. Click on “Authentication” in right pane.

    3. Right click on “Anonymous Authentication” and edit it.

    4. Check if the specific user is IUSR.

    Here is a similar issue for your reference:

    https://blogs.msdn.microsoft.com/guruketepalli/2013/08/09/sharepoint-error-the-managed-metadata-service-or-connection-is-currently-not-available-the-application-pool-or-managed-metadata-web-service-may-not-have-been-started/

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, April 18, 2017 9:45 AM
    Moderator
  • Thanks Linda for your reply. I checked IUSR is set. I checked all the 5 solutions from the link you provided, everything is properly set still the term store is simply not opening. In ULS Log I see Managed Metadata Service is accessible. It also shows below error

    Failed to get term store for proxy '<MDSName>'. Exception: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary. at Microsoft.SharePoint.Taxonomy.Internal.XmlDataReader.GetDateTime(String name) at Microsoft.SharePoint.Taxonomy.Internal.SharedTermStore.Initialize(IDataReader dataReader, Guid termStoreIdValue, Boolean fromPersistedData) at Microsoft.SharePoint.Taxonomy.Internal.SharedTermStore..ctor(IDataReader dataReader, Guid termStoreId, Boolean fromPersistedData) at Microsoft.SharePoint.Taxonomy.Internal.DataAccessManager.GetTermStoreData(MetadataWebServiceApplicationProxy sharedServiceProxy, Boolean& partitionCreated)

    The Corporate Curated Gallery Settings feature is not activated on current web application .


    Khushi

    Thursday, April 20, 2017 8:46 PM
  • Update: I was able to solve it following this article. I did changed the name of the Managed Metadata Database and then set it back to old database

    https://blog.areflyen.no/2014/08/21/the-managed-metadata-service-or-connection-is-currently-not-available-in-sharepoint-2013/

    Thank you Linda and Lakshamanan.


    Khushi

    • Marked as answer by KhushiSShaikh Thursday, April 20, 2017 9:26 PM
    Thursday, April 20, 2017 9:25 PM