none
Microsoft Office Accounting 2007 - Cannot open company!

    Question

  •  

    Hi guys,

    I recently installed Office Accounting 2007 Professional on a Windows Server 2003 machine with SQL Server 2005 (installed on an existing instance) and updated Office Accounting with service pack 1. However, after I have created the company file, other users were unable to open it. The error message was "The company could not be opened. Please ensure the SQL Server exists, the service is running and access has been granted."

    Below are some of the stuff I had done, but still cannot solve the problem:

    - Under "Manage users and roles", I granted full control to all users in the AD.
    - Made the company.sbc as well as the multiuser.sbc file available to everyone on the server's shared drive.
    - Granted full control to all users in the AD for the above mentioned shared drive.
    - Copied the company.sbc and multiuser.sbc files onto all client computers.
    - Ensured that SQL Server is running.
    - Checked the security options for the linked database to ensure all users have the necessary rights.
    - Enabled TCP/IP and named pipes as well as the port 5356 and have restarted the services.
    - Added port 5356 as an exception in Windows firewall on all client computers.
    - I even switched off Windows Firewall on the server just to eliminate this possibility!
    - Tried everything listed in
    http://support.microsoft.com/kb/910012

    I still get that error message on all client computers!!! What else have I left out???
    Tuesday, March 25, 2008 4:18 AM

All replies

  •  

    If you're using a remote SQL server, make sure that the text in the .sbc file has:

    database="database name"

    server=MachineName\InstanceName,Port

     

     

    I had to manually modify this file for my configuration and it worked like a champ.

     

    Good Luck!

     

    Mark Wilson

    President

    BooSnap Computer Services

     

    Tuesday, March 25, 2008 10:58 PM
  • Hi Mark,

     

    My .sbc file has the following:

     

    database=company1

    server=COMPANYSERVER,5356

     

    It didn't work for me. None of the client PCs can access it. So I changed the second line to server=COMPANYSERVER\MSSQLSERVER,5356

     

    Still, it does not work, but the error message is different this time.

     

    "General network error encountered. Connection to DB has been either turned off or server is not reachable. Please shut down application and try to log on again."

     

    Any idea what is going on?

    Wednesday, March 26, 2008 6:05 AM
  • Hi Mark

    My .sbc file has the datase and server name as well.

    My it does not work, it seems that there is no SA account with password can be setup in .sbc file for SQL DB connection. How can we set up the SQL sa account and password to get the remote SQL DB connection. Thanks.


    Regards,
    Winsee

    Monday, May 19, 2008 11:32 AM
  • changed to "DatabaseSERVER\MSSQLSERVER" fixed this problem.... just....

    remember when install MOA.....
    you must set local instance... (by Default MSSQLSERVER)
    ...
    restart your server... then try again


    Thursday, October 30, 2008 2:05 PM
  • Old thread I know but thought I'd ad this for completeness....

    If you installed the SBA database to the root (First) SQL instance then use '\.' as the instance name.

    i.e.

    database=MyCompanyDatabase
    server=MachineName\.,1433
    Monday, April 20, 2009 4:04 PM
  • Just wanted to confirm that last post by EricTViking worked for me. Originally my multiuser .sbc file was using port 5356 and did not have the \. appended to the server name; after making the changes in the post above Accounting 2009 Pro SP1 connected immediately to my SQL 2005 SP3 server.
    Tuesday, October 06, 2009 7:08 PM