none
MDT 2012 U1 infinite reboot --> No networking adapters found. RRS feed

  • Question

  • Hi,

    I am Running a Windows Server 2012R2 Guest (hostname MDT2012 192.168.3.105) on a Windows 8 Hyper-V. I installed MDT 2012 U1 on the 2012 R2 Machine. I created a deploymentshare on drive E: 

    My goal is to migrate some XP 32bit machines to Windows 7 32bit

    One part of my windows Xp clients are running on the same Windows 8 Hyper-v

    The other test client is a fujitsu Lifebook 761 with XP 32 bit.

    I imported some drivers for the Lifebook 761 to the Out-Of-Box drivers folder. I added a windows pro 32 bit image (an original one without any changes) to the operating systems folder and created a "standard task sequence" ID = 005 without any changes.

    Then I modified the bootstrap.ini

     [Settings]

    Priority=Default

    Properties=MyCustomProperty

     

    [Default]

    OSInstall=Y

    SkipAppsOnUpgrade=YES

    SkipCapture=YES

    SkipAdminPassword=YES

    AdminPassword=blabla

    SkipProductKey=YES

    SkipDeploymentType=YES

     

    SkipUserData=yes

    UserDataLocation=AUTO

    UDShare=\\192.168.3.105\Backup\USMT

    UDDir=%ComputerName%

     

    SkipComputerBackup=YES

    ComputerBackuplocation=AUTO

    BackupShare=\\192.168.3.105\Backup\

    BackupDir=%ComputerName%

     

    SkipTaskSequence=YES

    TaskSequenceID=005

     

    SkipComputerName=Yes

    ComputerName=%ComputerName%

     

    SkipPackageDisplay=Yes

     

    SkipLocaleSelection=YES

    UILanguage=de-DE

    UserLocale=de-DE

    KeyboardLocale=0407:00000407

    InputLocale=0407:00000407

     

    SkipFinalSummary=YES

     

    SkipDomainMembership=YES

    JoinDomain=blabla.me

    DomainAdmin=administrator

    DomainAdminDomain=blabla.me

    DomainAdminPassword=blabla

    MachineObjectOU=OU=testou,DC=blabla,DC=me

     

    SkipTimeZone=YES

    TimeZone=110

    TimeZoneName=W. Europe Standard Time

     

    HIDESHELL=NO

     

    WSUSServer=http://192.168.3.133

     

    SkipBitLocker=YES

     

    ;Logging

    SLShare=\\192.168.3.105\Logs

    SLShareDynamicLogging=\\192.168.3.105\Logs\%computername%

    EventShare=\\192.168.3.105\Logs\Events

    EventService=http://192.168.3.105:9800

     

    After that I configured the bootstrap.ini

     

    [Settings]

    Priority=Default

     

    [Default]

    DeployRoot=\\192.168.3.105\DeploymentShare$

    UserID=administrator

    UserPassword=blabla

    UserDomain=blabla.me

    KeyboardLocale=0407:00000407

    InputLocale=0407:00000407

    SkipBDDWelcome=YES

    After that I completely regenerated the boot images to update the deployment share. Now it was time to create an image. I choose the everything profile and updated the media contend to get my LiteTouchMedia.iso.

    I inserted the iso into my Windows XP 32 bit on my hyper-v. The XP has one legacy nic installed and is in the same subnet of the MDT server.  I ran the litetouch.vbs /debug:true command and checked the logging on the MDT server. Everything was fine. The client reported into the deployment workbench and I was able to see capture bdd.log file on the MDT server on \\192.168.3.105\Logs\%computername%. The reporting in the \\192.168.3.105\Logs\Events worked fine too.

    After reboot the system booted into Windows PE automatically. After a few seconds to system reboots automatically in an infinite loop. Nothing is reported the MDT server. Not to the deployment workbench and not to the log folder. After 3 reboots I aborted the process by pressing f8 and copied all the log files from the C:\minint\smsosd\osdlogs\ over to the MDT server for an analysis.

    Windows PE had some problems with my nic drivers. "No networking adapters found. The network drivers for your device are not present."

     

    This is really strange. Because after pressing f8 I could see my IP from DHCP with ipconfig. Could ping the MDT and was able to map the deploymentshare folder to copy to logs over. So I really do not understand why there could any driver issues.

     

    I tried the same procedure with the Lifebook s761 with the same result. I started the litetouch from the deploymentshare without using the media on the VM and the Lifebook. Same result. Something has to be wrong in general but I have no clue where to search. I will uploads the logs when I am verified.


    • Edited by s66_ Sunday, March 30, 2014 7:35 PM
    Sunday, March 30, 2014 7:34 PM

Answers

  • Typically (95% of the time) if you get an error just after GetAllFixedDrives() it suggests that this deployment share was *upgraded* from an older version of MDT and some of the library files did not get updated properly.

    Open up a cmd.exe window in winPE (F8), and check the litetouch.wsf, ztiutility.vbs and ztidiskUtility.vbs scripts. They should all be the same version. If not, then you have a messed up deployment share.


    Keith Garner - keithga.wordpress.com

    Tuesday, April 1, 2014 1:20 AM
    Moderator

All replies

  • Sunday, March 30, 2014 8:40 PM
  • A screen shot is not very helpful. I can't tell what the time stamps are, so I can't tell where the reboots are.

    I also never recommend SLShareDynamic Logging, and I *never* use it, it introduces too many *other* complications into a debugging problem. Since you may be experiencing network problems, then writing the bdd.log file to a network share is not going to work.

    My Theory: You are running off of Wi-Fi and not a wired connection, which is not supported. You can check by running the command: wmic path Win32_NetworkAdapter get AdapterTypeID,Name,Installed

    Can you post the full BDD.log file to a public share like SkyDrive and copy the link here.


    Keith Garner - keithga.wordpress.com

    Monday, March 31, 2014 5:09 PM
    Moderator
  • Hi Keith,

    thx for your answer. Here is the full log.

    https://dl.dropboxusercontent.com/u/18263619/BDD.log

    I do not think it is a a wifi problem, because it happens to a Hyper-V VM with legacy adapter too. Are there any other logfiles I can provide? The BDD file is copied from the client not from the  SLShareDynamic Logfile path.


    Monday, March 31, 2014 5:44 PM
  • Did you verify that the WinPE OS has networking drivers?

    My next debugging step would be to remove your SLSHareDynamicLOgging entry and rerun the test.


    Keith Garner - keithga.wordpress.com

    Monday, March 31, 2014 5:51 PM
    Moderator
  • This is the result of the WMIC Path WIN_32_NetworkAdapter Get command from the stuck in loop Hyper-V VM

    https://dl.dropboxusercontent.com/u/18263619/wmic.txt

    Monday, March 31, 2014 5:55 PM
  • Here is my new BDD.log

    https://dl.dropboxusercontent.com/u/18263619/BDD2.log

    I commented out the SLSHareDynamicLOgging entry. There are no network related errors anymore. 

    It seems that ZTIUtility seems to get stuck at this point.

    <![LOG[ZTIUtility!GetAllFixedDrives (False)]LOG]!><time="00:04:56.000+000" date="04-01-2014" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">

    This time again the issue occures on the VM and the Lifebook...

    How can I verify the installed drivers on the WinPE?


    Monday, March 31, 2014 10:38 PM
  • Typically (95% of the time) if you get an error just after GetAllFixedDrives() it suggests that this deployment share was *upgraded* from an older version of MDT and some of the library files did not get updated properly.

    Open up a cmd.exe window in winPE (F8), and check the litetouch.wsf, ztiutility.vbs and ztidiskUtility.vbs scripts. They should all be the same version. If not, then you have a messed up deployment share.


    Keith Garner - keithga.wordpress.com

    Tuesday, April 1, 2014 1:20 AM
    Moderator
  • It was a fresh installation no update involved...

    I checked the Versions in WinPE:

    Litetouch.wsf Version 6.1.2373.0

    ZTIUtility.vbs Version 6.1.2373.0

    ZTIDiskUtility.vbs Version 6.1.2373.0

    So I guess I am the 5% case. If you don't have any other Idea (logfile, debugging step, checks) I would start from scratch.

    Tuesday, April 1, 2014 6:09 PM
  • My recommendation then is to break into the WinPE image (Press F8)

    While the window is open, kill all remaining cscript/wscript processes using TaskMgr.exe

    Then run the following command:

    cscript.exe x:\deploy\scripts\litetouch.wsf /debug:true /debugcapture

    That should run the litetouch.wsf script *and* hope fully it will also display any scripting error, that scripting error is very important and will explain what the problem is.


    Keith Garner - keithga.wordpress.com

    Tuesday, April 1, 2014 6:13 PM
    Moderator
  • On both clients...

    Tuesday, April 1, 2014 6:22 PM
  • I asked if you could run "cscript" not "wscript" :^/

    Anyways the error is right at the start of the loop in ZTIUtility.vbs:

    for each oWMIDiskPart in AllDiskPart
    

    Meaning that it's crashing while trying to enumerate through all local Disk Partitions. This is relatively a "Safe" operation and should not crash.

    A quick check of the error codes reveal:

    D:\>err 80041006
    # for hex 0x80041006 / decimal -2147217402 :
      WBEM_E_OUT_OF_MEMORY                                          wbemcli.h
    # 1 matches found for "80041006"

    My psychic powers suggest that you are running Virutal Machines with only 512MB of ram. Can you up the RAM to 768MB?


    Keith Garner - keithga.wordpress.com

    Tuesday, April 1, 2014 6:30 PM
    Moderator
  • Tuesday, April 1, 2014 7:22 PM
  • The VM has now 4GB of RAM just to be sure. The hardware host has 4GB too. Both show to same error...
    Tuesday, April 1, 2014 7:23 PM
  • So the question remains, is this a scripting problem, or is the WMI provider failing:

    Personally, I would just rebuild from scratch (then again I can do that easily) :^(

    However it might be interesting to see what the WMI provider says without the MDT scripts:

    boot to WinPE, Press F8, run wbemtest.exe, connect to the default "root\cimv2" namespace, Enumerate all "Win32_DiskPartition" entries. If you can't get it to enumerate they there is something wrong with the OS, perhaps a bad component, or a driver.

    Perhaps you are using a 3rd party disk encryption software program that does not play well with others.

    ANother test would be to snapshot your existing configuration, and remove all existing partitions. Press F8, Diskpart.exe, sel disk 0, clean, exit, wpeutil reboot. THen check to see if litetouch continues with the installation. If it passes, then I blame the configuration and/or drivers.


    Keith Garner - keithga.wordpress.com

    Tuesday, April 1, 2014 8:37 PM
    Moderator
  • Tuesday, April 1, 2014 9:49 PM
  • Tuesday, April 1, 2014 9:50 PM
  • Slowly things are getting strange. The screenshots (the shots are in german. in english:the procedure entry point could not be located in the dynamic link library) are from  the clients, fresh installed from the new build  MDT 2012 U1 after running the wbemtest.exe. Again same picture in VM and in Lifebook 761. I even changed the Server OS to Server 2008 R2. I think I should try another Win 7 Image or change my customsettings.ini. I imported no drivers at all this time... I will try to reduce the custiomsettings.ini to the bare minimum...
    MDT 2012 U1 does not seem to like my. But I will not give up: 

    Per aspera ad astra


    • Edited by S66 Tuesday, April 1, 2014 10:00 PM
    Tuesday, April 1, 2014 9:53 PM
  • Using a new Winodws Image and striping down the bootstrap.ini worked. The VM is working now. Now I can test the lifebook (after importing the drivers).

    Any idea how to escape the booting loop and go back to the old windows xp. I want to go to production sometime and it would be fatal to be stuck in a booting loop without a possibility for a way back to the good old xp before the USMT and the backup started...

    Wednesday, April 2, 2014 9:28 PM