none
Project closes automatically when opening in Project Professional RRS feed

  • Question

  • I have an issue using Project Professional 2010,  I can open all projects from Project Server normally, except one.

    When I try to open this especific project using MS project (2010), the schedule get check-out without opening, only small indication refers to "Auto Close".

    I tried many solutions like Administrative Restore and also tried to open the Published version but it didn't solve my problem, the project keep getting close every time I try to open it.

    In PWA it shows a message that the View Failed to Load and I can edit and publish too.

    Thanks in advance

    __________________________

    Thiago Andrade


    Wednesday, October 16, 2013 9:02 PM

All replies

  • Looks like project plan has been corrupted. You could try opening the project plan after disabling Auto calculation option from Project Pro Schedule section

    Or else you may have to restore the working project plan from SQL DB backup.


    Hrishi Deshpande Senior Consultant

    Thursday, October 17, 2013 12:38 AM
    Moderator
  • Thank you a lot Hrishi,

    I tried to disable the auto calculation but it didn't solve the problem

    How can I restore the working project plan form SQL DB Backup? Can you please explain the steps I have to follow?

    Thursday, October 17, 2013 2:13 PM
  • Thiago,

    You should have multiple versions available from Administrative Restore.  Keep going backwards until you find one that works correctly.

    Also, there is an "Auto Close" parameter in SQL Server.  It should be "off" by default, but you might have the DBA check this setting.

    AUTO_CLOSE

    By default, this option is set to ON for all databases when you are using SQL Server Desktop Engine (also known as MSDE 2000), and OFF for all other editions, regardless of operating system. The AUTO_CLOSE option should not be used for databases accessed by an application that repeatedly makes and breaks connections to SQL Server, such as Project Server. For this reason, we recommend that you set AUTO_CLOSE to OFF for the Project Server databases.






    • Edited by Edward Hanna Thursday, October 17, 2013 5:16 PM Add more info
    Thursday, October 17, 2013 4:27 PM
  • Hi

    The issue happens when there is a duplicate RES_OPTINDX value present. Please check the below article.

    http://support.microsoft.com/kb/2687386

     Below content is mentioned in the above article.

    “Assume that you add a resource to the plan of a project in Project Professional 2010 and then save the plan. After you publish the project to a Project server, you cannot open the plan from the server. This issue occurs because there are duplicate RES_OPTINDX values in the MSP_PROJECT_RESOURCES table.”

    You can run the below 2 queries against draft database to identify if there are any duplicate RES_OPTINDX values present.

    Select * from MSP_PROJECTS where Proj_name like 'name of the project'      – Get the project GUID

     

    Use the Project GUID in the below query.

    select res_type, RES_OPTINDX, RES_UID, RES_name from MSP_PROJECT_RESOURCES where PROJ_UID= '20C3CEC7-72D0-40C0-BCC3-0E7972CCE9CB' order by RES_OPTINDX


    Wednesday, October 23, 2013 5:47 AM