locked
SRS RRS feed

  • Question

  • I have enabled the SRS role on an existing SRS server, reports are available and they are working fine.
    I only have annoying status messages telling that the “SMS SRS Web Service is not running on the SRS Reporting point”.

     

    Apparently this was a kind of bug that was solved with SP2. But SP2 is installed and the error still remains.

    I encounter this for several days now... so please don't answer that they will dissapear as I have read already on other places on the net.. :-)

    Anyone ever seen this?

    Tnx!

     

    Tuesday, July 27, 2010 8:13 AM

Answers

  • I don't have a pointer to an official quote, but if your goal is to have green checkmarks in Status summarizer, here is what we did.  Because it's a false positive (SRS reporting is working just fine), under Site Settings, Status Filter Rules, add in a custom rule of your own.  Name doesn't matter, but ours is called "Discard 7403 - SRS error.  Check on Component, and choose "SMS_SRS_REPORTING_POINT", Check on Message ID, and type in 7403.  On the Actions tab, check on the two options of "Do not forward to status summarizers" and "Do not process lower-priority status filter rules".

    What that does is basically tell your Status summarizer to no longer treat error 7403 as a real error; so your status summary is green instead of warning or red.


    Standardize. Simplify. Automate.
    • Marked as answer by NicoSienaert Tuesday, July 27, 2010 11:31 AM
    Tuesday, July 27, 2010 11:22 AM
  • You basically just wait until the "threshold" default period has passed.  Which, I think... (we may have changed ours, but I think this is the default) is midnight, daily.  That's the default shown in the status summarizer. 

    To check, in Site Settings, Status Summary, Component Status Summarizer, properties, check the Threshold period.


    Standardize. Simplify. Automate.
    • Marked as answer by Yog Li Monday, August 2, 2010 10:56 AM
    Sunday, August 1, 2010 2:25 PM

All replies

  • Hi,

    Are you talking about error 7403? It's a known error I know that it has been reported to Microsoft.  


    Kent Agerlund | http://scug.dk/members/Agerlund/default.aspx | The Danish community for System Center products
    Tuesday, July 27, 2010 8:51 AM
  • YES - indeed

    So I leave this for the moment?

     

    Is there an official quote available that they are working on it?

    Tuesday, July 27, 2010 9:06 AM
  • I don't have a pointer to an official quote, but if your goal is to have green checkmarks in Status summarizer, here is what we did.  Because it's a false positive (SRS reporting is working just fine), under Site Settings, Status Filter Rules, add in a custom rule of your own.  Name doesn't matter, but ours is called "Discard 7403 - SRS error.  Check on Component, and choose "SMS_SRS_REPORTING_POINT", Check on Message ID, and type in 7403.  On the Actions tab, check on the two options of "Do not forward to status summarizers" and "Do not process lower-priority status filter rules".

    What that does is basically tell your Status summarizer to no longer treat error 7403 as a real error; so your status summary is green instead of warning or red.


    Standardize. Simplify. Automate.
    • Marked as answer by NicoSienaert Tuesday, July 27, 2010 11:31 AM
    Tuesday, July 27, 2010 11:22 AM
  • Thanks for the great solution, Sherry.  I have one question though:

    I set up the 7403 status rule per your instructions, but I just cannot seem to make the red X go away from the site system status.  I have stopped and restarted the services, and rebooted both the SCCM site server and the SQL server (separate VMs)

    Any idea how I could tell the status monitor to switch the reporting point back to green?

    Sunday, August 1, 2010 12:03 AM
  • You basically just wait until the "threshold" default period has passed.  Which, I think... (we may have changed ours, but I think this is the default) is midnight, daily.  That's the default shown in the status summarizer. 

    To check, in Site Settings, Status Summary, Component Status Summarizer, properties, check the Threshold period.


    Standardize. Simplify. Automate.
    • Marked as answer by Yog Li Monday, August 2, 2010 10:56 AM
    Sunday, August 1, 2010 2:25 PM
  • I have configured the custom role as sherry suggest (the error message disappear).
    The red x does not go away from the site status even after restart .

    where do i place the new rule in the Status Filter Rule ?
    Do i have to change the order it listed ?

    Sunday, September 19, 2010 9:47 AM
  • SAme problem, I follow your indication but the red cross still here after several days and I can see that 7403 errors still coming.

     

    Monday, September 27, 2010 11:56 AM
  • Wednesday, October 20, 2010 3:43 PM
  • Yes Ryan the CU4 for SQL Server 2008 R2 fix the error 7403 http://support.microsoft.com/kb/2345451/en-us
    Wednesday, October 20, 2010 9:24 PM
  • Thanks For This, Rayn And Bechir .
    Did anyone Check THis CU4 ?  I am in Progress at test environment, before production.

    Thursday, October 21, 2010 7:32 AM
  • Yesterday I installed the CU4 on my SQL 2008 R2 server and the error disappeared.
    Thursday, October 21, 2010 7:46 AM
  • YES YES .....
    This CU4 solved this issue.

    • Proposed as answer by Garth JonesMVP Thursday, July 28, 2011 2:31 AM
    Thursday, October 21, 2010 3:03 PM
  • I'm also experiencing the same issue as described.

    I'm running SQL Server 2008 R2 64-bit - All of the hotfixes in http://support.microsoft.com/kb/2345451/en-us are for x86 only.

    Is there a reason this "CU4" fix isn't available in 64-bit?

    Monday, November 15, 2010 3:47 AM
  • Hi,

    No, all hotfixes are available for SQL x64. Try to access to the website throught a x64 operationg system and you will see all that you need. 


    Bechir Gharbi | http://myitforum.com/cs2/blogs/bgharbi/default.aspx
    Monday, November 15, 2010 7:07 AM