none
Windows 7 Clients screensaver not working when enabled via GPO

    Question

  • I have a Windows server 2008 R2 server running as a single domain controller in a small school environment with maybe 20 computers are so. The majority of these computers are lab machines for the students, so they're heavily locked down with GPO settings. Everything has been working fine except for one issue.

    The screensaver is not activating like we have set in the GPO. The issue is not on all the lab machines but it is on most of them. I have double and triple checked my GPO settings and i do not see an issue. I ran a gpresult /X to output a file to see active GPO settings and my screen saver settings on indeed activated and running according to the outputted file! I tried unplugging the mouse and keyboard but that did not work either. I also logged into the admin account and set the screen saver to a short period of time and it activates without an issue. So it doenst seem to be a hardware issue.

    My diagnosing abilities with these computers is limited from my test student accounts because they're so heavily locked down so take that into account, but i have enabled CMD for my own sanity!


    This is a picture of the GPO settings that should be applied to the computer, this report was generated by running a Group Policy Results wizard from the DC.

     This is the report that was generated on the computer using the same test account. Only way i could get it off the computer was to take a photo with my phone so sorry about the quality.

    What could be causing this issue? We have been having this issue for some time now and im even having this issue on two computers that i just re-imaged as well.

    Any help is appreciated!


    • Edited by Ian Saucy Thursday, January 15, 2015 7:04 PM
    Thursday, January 15, 2015 6:53 PM

Answers

  • The issue has been resolved, i called Microsoft and got on with a support tech from the screen saver department...turns out it was fairly basic problem. I missed the % in the end of %systemroot% in the GPO that tells the computer where to find the screen saver, so it couldnt find the path for the screensaver. Once that was fixed everything worked!

    I also found and resolved another issue.

    If you have a screen saver setup to lock the computer after a certain amount of time through the 

    User Policies > Policies > Administrative Template > Control Panel > Personalization > Password Protect Screen Saver

    But also have the below option enabled

    User Configuration > Polices > Administrative Template > System > Ctrl + Alt + Del options > Remove Lock Computer "Enabled" 

    Then when the screen saver triggers, and then is interrupted by someone waking the computer again it wont go to the lock screen!


    • Marked as answer by Ian Saucy Sunday, February 1, 2015 4:33 AM
    • Edited by Ian Saucy Sunday, February 1, 2015 4:34 AM Words
    Sunday, February 1, 2015 4:33 AM

All replies

  • Hi ,

    Do you see the .scr file is present in the problematic computers?

    Ensure there is not network connectivity problem which causes failure while new group policy tires to apply on


    Regards, Prabhu

    Friday, January 16, 2015 5:42 AM
  • > This is a picture of the GPO settings that should be applied to the
    > computer, this report was generated by running a Group Policy Results
    > wizard from the DC.
     
    You should run this report on one of the affected computers/users instead...
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Friday, January 16, 2015 10:56 AM
  • Yes screen saver file is on the computer!
    Friday, January 16, 2015 6:12 PM
  • i did, the 2nd report shown was run on the client and user that was having the issue.
    Friday, January 16, 2015 6:13 PM
  • Hi Ian,

    Before going further, sorry for the delayed response.

    How is it going? From the group policy result report you posted, I found that we didn't configure the policy setting Screen saver timeout, which may cause the screensaver not kicking in. As a result, we can try to enable the policy setting and set a timeout value to see if the issue persists.

    Besides, regarding this point, the following article can be referred to for more information.

    Win7/W2k8 R2 Group POlicy Screensaver setting is not working

    http://support.microsoft.com/kb/2616727

    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Best regards,
    Frank Shen

    Wednesday, January 21, 2015 2:30 AM
    Moderator
  • Hi Ian,

    How is it going? If the issue persists or you need further help, please don't hesitate to let us know.

    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Best regards,
    Frank Shen

    Monday, January 26, 2015 1:50 PM
    Moderator
  • Still not resolved.

    You're saying you dont see "Screen saver timeout" in the report, but i see something in the report with those exact words and a time set of 30 seconds....? Am i doing something wrong?

    Thanks

    Tuesday, January 27, 2015 2:36 AM
  • where are the SLA's for these forums we are volunteers who help and do this of our own free will, we offer our own free time.
    Friday, January 30, 2015 6:25 PM
  • The issue has been resolved, i called Microsoft and got on with a support tech from the screen saver department...turns out it was fairly basic problem. I missed the % in the end of %systemroot% in the GPO that tells the computer where to find the screen saver, so it couldnt find the path for the screensaver. Once that was fixed everything worked!

    I also found and resolved another issue.

    If you have a screen saver setup to lock the computer after a certain amount of time through the 

    User Policies > Policies > Administrative Template > Control Panel > Personalization > Password Protect Screen Saver

    But also have the below option enabled

    User Configuration > Polices > Administrative Template > System > Ctrl + Alt + Del options > Remove Lock Computer "Enabled" 

    Then when the screen saver triggers, and then is interrupted by someone waking the computer again it wont go to the lock screen!


    • Marked as answer by Ian Saucy Sunday, February 1, 2015 4:33 AM
    • Edited by Ian Saucy Sunday, February 1, 2015 4:34 AM Words
    Sunday, February 1, 2015 4:33 AM