locked
x64 Windows and Exchange 2007- No VSS Writers RRS feed

  • Question

  • I am trying to use BES 11d to take VSS backups of E2K7, which fail for all E2K7 servers.

     

    When I check the vss writers on each exchange 2007 box I get the below, on exchange 2003 servers, backups work fine and there are plenty of writers listed, anybody else come across this??

     

    Microsoft Windows [Version 5.2.3790]
    (C) Copyright 1985-2003 Microsoft Corp.

    C:\Documents and Settings\exchm>vssadmin list writers
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001 Microsoft Corp.


    C:\Documents and Settings\exchm>

     


     

    Friday, August 3, 2007 1:19 AM

All replies

  • I had the same error on some Exchange servers I had worked on recently. In the end we worked out that it was due to using the NewSid utility on a VMWare environment to build servers fast. Try the following steps:

     

                1. Stop the Microsoft Shadow Copy Provider & Volume Shadow Copy Service

     

    2. Export the contents of the HKLM\Software\Microsoft\EventSystem key to a .reg file (as a backup).

    3. Delete the HKLM\Software\Microsoft\EventSystem\{26c409cc-ae86-11d1-b616-00805fc79216}\Subscriptions key. (Just delete the Subscriptions subkey; leave the EventClasses key.)

    4. Restart the server.

    5. Run the "VSSADMIN LIST WRITERS" command.

    This causes the VSS entries in the HKLM\Software\Microsoft\EventSystem\{26c409cc-ae86-11d1-b616-00805fc79216}\Subscriptions key to be rebuilt when the writers initialize.

     

    If that does not resolve it try this:

     

    Check the Registry - HKEY_CLASSES_ROOT\CLSID\{FAF53CC4-BD73-4E36-83F1-2B23F46E513E}\InProcServer32
    - check right pane for (Default)
    - ensure this is pointing to the correct location
    à %systemroot%\system32\ES.DLL

     

    Try launching each of these consoles:

     

    - perfmon /wmi
    - msinfo32
    - wmimgmt.msc

     

    If the above works out without any issues, please run these commands on the server:

     

    Net stop vss

    Net stop swprv

    regsvr32.exe /i %windir%\system32\eventcls.dll

    regsvr32.exe /i %windir%\system32\swprv.dll

    regsvr32.exe %windir%\system32\vssui.dll

    regsvr32.exe %windir%\system32\vss_ps.dll

    regsvr32.exe %windir%\system32\msxml.dll

    regsvr32.exe %windir%\system32\msxml2.dll

    regsvr32.exe %windir%\system32\msxml3.dll

    regsvr32.exe %windir%\system32\msxml4.dll

    regsvr32.exe %windir%\system32\ole32.dll

    regsvr32.exe %windir%\system32\oleaut32.dll

    regsvr32.exe %windir%\system32\es.dll

    regsvr32.exe %windir%\system32\comsvcs.dll

    vssvc /register

    net start swprv

    net start vss

     

    Cheers,

    Rhys

     

    • Proposed as answer by Bhag Tuesday, October 27, 2009 8:25 PM
    Saturday, August 4, 2007 4:13 AM
  •  

    Brilliant, thanks Rhys, that worked a treat! Yes, the servers were provisioned for esx also..
    Monday, August 6, 2007 10:20 PM
  •  

    Rhys,

     

    Excellent solution. Worked like a charm. We have been strugeling with this issue for ages.

    Anyone know if newsid has any other issues we should consider when using it ?

    Too bad microsoft does not have a general tool (for all types of OS)... like newsid. Sysprep is different for every OS and even service pack

     

    Gr,

    EJ

    Tuesday, February 19, 2008 3:10 PM
  • Exellent!!!!!!!!!! Thanks a LOT!!!!!

    I had this trouble on the real servers, which were cloned using NewSID. It was my mistake =(

     

    Wednesday, October 15, 2008 8:34 AM
  • This did *not* work for me.  Now nothing displays when I type 'vssadmin list writers.'
    Thursday, August 27, 2009 2:24 PM
  • This did *not* work for me.  Now nothing displays when I type 'vssadmin list writers.'

    I had to use regsvr32 from %SYSTEMROOT%\system32 since I have a 64 bit system.  This restored all my writers -- all but 'Exchange Writer' which I'm having a problem with.
    Thursday, August 27, 2009 2:56 PM
  • Thanks a ton Ryhs Winter.  Your solution worked like a charm.  Althouth i only had to use the 5 steps mentioned above and i did not register any dll's. 

    Thanks Again,
    Bhag
    Tuesday, October 27, 2009 8:27 PM
  • Thanks to Ryhs Winter too.
    I had the same problem with Windows 2003-SP2 64-bit and Exchange SP1.
     
    I hate NewSID.

    Klaus
    Wednesday, January 20, 2010 12:10 PM
  • Thanks a lot...
    Tuesday, November 29, 2011 7:01 AM