locked
SharePoint Error 2436 & 2424 RRS feed

  • Question

  • SBS 2008 x64 all pacthes and updates in place. Server not yet in service
    I keep getting the following event log errors, errors repeat constantly.
    Please advise, thank you!

    Log Name:      Application
    Source:        Windows SharePoint Services 3 Search
    Date:          12/13/2010 8:05:49 AM
    Event ID:      2424
    Task Category: Gatherer
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      SERVER1.efsph.local
    Description:
    The update cannot be started because the content sources cannot be accessed. Fix the errors and try the update again.

    Context: Application 'Search', Catalog 'index file on the search server Search'
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Windows SharePoint Services 3 Search" />
        <EventID Qualifiers="32768">2424</EventID>
        <Level>2</Level>
        <Task>3</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-12-13T13:05:49.000Z" />
        <EventRecordID>170873</EventRecordID>
        <Channel>Application</Channel>
        <Computer>SERVER1.efsph.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>

    Context: Application 'Search', Catalog 'index file on the search server Search'</Data>
      </EventData>
    </Event>

    Log Name:      Application
    Source:        Windows SharePoint Services 3 Search
    Date:          12/13/2010 8:10:52 AM
    Event ID:      2436
    Task Category: Gatherer
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      SERVER1.efsph.local
    Description:
    The start address <sts3s://remote.efrypeelhalton.ca:987/contentdbid={c4047ad0-52d9-4919-aea7-5fc2f155bf23}> cannot be crawled.

    Context: Application 'Search index file on the search server', Catalog 'Search'

    Details:
     Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled.   (0x80041205)
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Windows SharePoint Services 3 Search" />
        <EventID Qualifiers="32768">2436</EventID>
        <Level>3</Level>
        <Task>3</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-12-13T13:10:52.000Z" />
        <EventRecordID>170874</EventRecordID>
        <Channel>Application</Channel>
        <Computer>SERVER1.efsph.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>

    Context: Application 'Search index file on the search server', Catalog 'Search'

    Details:
     Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled.   (0x80041205)</Data>
        <Data>sts3s://remote.efrypeelhalton.ca:987/contentdbid={c4047ad0-52d9-4919-aea7-5fc2f155bf23}</Data>
      </EventData>
    </Event>


    Thanks!
    Monday, December 13, 2010 1:49 PM

Answers

  • Hi,

    I've seen this behavior multiple times, It has something to do with enabling ssl and the default service account rights

    I put togheter here http://blog.ronnypot.nl/?p=288 how to solve it.


    Regards Ronny
    • Marked as answer by joecallus Monday, December 13, 2010 10:33 PM
    Monday, December 13, 2010 2:02 PM
  • The post above gives the steps to put it back to local service.

    Run the www.sbsbpa.com on the box and see if you have update rollup 4 on there.  The patch is in Microsoft update, not Windows update, you have to flip the server over to MU not WU.

    • Marked as answer by joecallus Friday, December 17, 2010 12:35 PM
    Tuesday, December 14, 2010 3:12 PM

All replies

  • Hi,

    I've seen this behavior multiple times, It has something to do with enabling ssl and the default service account rights

    I put togheter here http://blog.ronnypot.nl/?p=288 how to solve it.


    Regards Ronny
    • Marked as answer by joecallus Monday, December 13, 2010 10:33 PM
    Monday, December 13, 2010 2:02 PM
  • Thanks Ronny, applied the fix and all seems well so far.

    BTW very nice job on your Blog post. Detailed easy to follow, very grateful.

     

     

    joe...

     


    Thanks!
    Monday, December 13, 2010 10:33 PM
  • Ronny Still getting Event ID 2424

    I am sure everything was done corectly. Perhaps regestry entry was a problem?

    DisableLoopbackCheck
    DWord
    Value Data 1
    Hexadecimal

     

    Any other thoughts?

     

    joe...

     


    Thanks!
    Monday, December 13, 2010 11:14 PM
  • SharePoint Services 3 Search event errors after applying certificate on a SBS2008 server:
     
    Ronny -- I'm concerned about the changing of the Search accounts.  You can get into a world of hurt with future SharePoint updates by changing the login of the search.  They should be set to use local accounts.
     
    [HKLM\System\CurrentControlSet\Control\Lsa] "DisableLoopbackCheck"=dword:00000001
     
    Should be all you need for this.
     
     
    Tuesday, December 14, 2010 12:23 AM
  • Did you apply update SBS update rollup 4 on this server?
     
    Tuesday, December 14, 2010 12:24 AM
  • Companyweb and SharePoint Central Admin not accessible after installing
    KB983444 or KB2345304 - The Official SBS Blog - Site Home - TechNet Blogs:
     
    The previous steps take care of most of the issues, on a few others
    we’ve seen issues with abnormally configured custom accounts for the
    Search Service causing problems. Here is a quick workaround to get you
    through the issue back to a working CompanyWeb if you are indeed hitting
    this issue.
       1. To verify that the Local Service account is being used for
         SharePoint Search, do the following:
            1. Click on *Start > Run* and type *services.msc*
            2. Right-click on the *Windows SharePoint Services Search*
               service and choose *Properties*
            3. Click on the *Log On* tab.  If the account is anything other
               than *Local Service*, proceed with the following steps.
      2. To fix this, use stsadm to unprovision the search service so you
         can finish psconfig.  After that, you should be able to access
         Sharepoint Central Administration to fix the login account and
         restore the functionality of SPSearch:
            1. Open an elevated cmd prompt and run the following command:
               *C:\Program Files\Common Files\Microsoft Shared\Web Server
               Extensions\12\BIN>STSADM.EXE -o provisionservice -action
               stop -servicetype
               "Microsoft.SharePoint.Search.Administration.SPSearchService,
               Microsoft.SharePoint.Search,Version=12.0.0.0,Culture=neutral, PublicKeyToken=71e9bce111e9429c"
               -servicename spsearch*
            2. Complete Steps *1-3* from the previous section. Once they
               complete and you have a working SharePoint Central
               Administrator and CompanyWeb sites, proceed to the next set
               of steps.
      3. Change the login account for SPsearch to Local Service.
            1. Open Sharepoint Central Administration > *Operations* >
               *Services on Server*
            2. Click on *Windows SharePoint Services Search*
            3. Select *Local Service* under predefined for service account
               and content access account, then click *OK*
      4. Use stsadmin to reprovision the spsearch service:
            1.  From an elevated cmd prompt, run the following command:
               *C:\Program Files\Common Files\Microsoft Shared\Web Server
               Extensions\12\BIN>STSADM.EXE -o provisionservice -action
               start -servicetype
               "Microsoft.SharePoint.Search.Administration.SPSearchService,
               Microsoft.SharePoint.Search,Version=12.0.0.0,Culture=neutral, PublicKeyToken=71e9bce111e9429c"
               -servicename spsearch*
      5. You will not see any search results in SharePoint until a full
         crawl has been initiated and is successfully indexing the
         content.  To trigger this, use stsadm:
            1.  From an elevated cmd prompt, run the following command:
               *C:\Program Files\Common Files\Microsoft Shared\Web Server
               Extensions\12\BIN>STSADM.EXE -o spsearch –action
               fullcrawlstart*
     
    Tuesday, December 14, 2010 12:34 AM
  • SharePoint Services 3 Search event errors after applying certificate on a SBS2008 server:
     
    Ronny -- I'm concerned about the changing of the Search accounts.  You can get into a world of hurt with future SharePoint updates by changing the login of the search.  They should be set to use local accounts.
     
    [HKLM\System\CurrentControlSet\Control\Lsa] "DisableLoopbackCheck"=dword:00000001
     
    Should be all you need for this.
     
     


    Hi Susan,

    I have never seen a problem after doing this. Have you got any information about what kind of errors could occur?

     


    Regards Ronny
    Tuesday, December 14, 2010 7:05 AM
  • Susan, thank you for the assistance, so what should I do now?
    I have applied all patches that Windows Update suggests, not at the server so I cannot confirm Patch 4.

    How would you suggest I undo the changes that Ronny suggested, once I get tis undone I can follow yor post to apply those settings.

    Thank you!

    joe..

     


    Thanks!
    Tuesday, December 14, 2010 11:24 AM
  • If you install SharePoint updates they will fail as they can't patch the search instance.
    Tuesday, December 14, 2010 3:02 PM
  • The post above gives the steps to put it back to local service.

    Run the www.sbsbpa.com on the box and see if you have update rollup 4 on there.  The patch is in Microsoft update, not Windows update, you have to flip the server over to MU not WU.

    • Marked as answer by joecallus Friday, December 17, 2010 12:35 PM
    Tuesday, December 14, 2010 3:12 PM
  • Thank you Susan I have followed your instructions and have run the SBSBPA tool and found quite a number of problems.

    I have 1 critical DNS error and a number of Warnings, some related to SharePoint, and only 1 Update is displayed as missing Exchange SP3, I am currently SP1.

    I assume that I can safely go ahead and make all the indicated changes safely?

     

    thanks!

     

    joe...

     


    Thanks!
    Tuesday, December 14, 2010 4:12 PM
  • Yup
     
    Wednesday, December 15, 2010 11:49 PM
  • Everythig seems good Susan, thank you for your assisatnace.

     

    joe...

     


    Thanks!
    Friday, December 17, 2010 12:35 PM
  • Hi Susan,

    I'm having a similar issue, I get 2424 and 2436 events every 5 minutes in my SBS 2008 Server. This is a fresh install I'm testing before setting to production.

    I installed the server following SBS 2008 Build document, applied all updates. SBSBPA warned me about event 2436 and I followed the instructions setting the registry key for BackConnectionHostNames and included the 2 entries SBSBPA suggested, still getting 2424 and 2436.

    Sharepoint Services SP2 installed and also rollup 4.

    What should I follow?

    http://blogs.technet.com/b/sbs/archive/2010/06/18/companyweb-and-sharepoint-central-admin-not-accessible-after-installing-kb983444.aspx

    (companyweb an central admin have always worked)

    OR disable LoopBack

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;896861

     

    Thanks!

     

    Thursday, January 6, 2011 12:29 AM
  • Solved!!

    Problem was THAT when runing the internet names wizard, I selected not to add the REMOTE subdomain as this domain is only used for RWW. So when I ran the SBSBPA it said to add the value .DOMAIN.COM instead of just DOMAIN.COM (I think its programed to display SUBDOMAIN (DOT) DOMAIN and in my case SUBDOMAIN doesn't exist so it still displayed the DOT).

    So to recap;

    Problem in my case gets fixed by adding the BackConnectionHostNames entry, just had to check domains and remove the dot at the beginning.

    THANK YOU ALL

    Thursday, January 6, 2011 4:44 AM