none
Workstations show "No internet access" but internet is working RRS feed

  • Question

  • We've recently done a server migration from SBS 2011 to 2012 R2 Standard which was a success. The SBS server is no longer on the domain and everything has been moved to the 2012 R2 server (AD, DHCP, DNS) etc.. I made sure that I set the scope options 003 and 006 correctly in DHCP so client PC's would get the proper DNS and Gateway values but most of the workstations here show the error in the bottom right that there's no internet access when it's working fine. The windows 10 computers here are not having this problem but a majority are still 7

    If I run and IPCONFIG /ALL from a workstation it returns the correct DNS and gateway IP's and I can ping out, web browsing is ok, nslookup goes to the right DNS server, on the DNS server itself running DCDIAG /test:dns comes back with everything passing. Not sure what else to check. On thew Windows clients, DNS is set to auto but even statically assigning it does not get rid of the error. Any ideas?



    • Edited by GlenTech83 Thursday, February 23, 2017 8:13 PM
    Thursday, February 23, 2017 8:12 PM

All replies

  • Do your clients use a proxy server to access the Internet?

    From a Windows 7 computer showing this symptom, can you please enter this URL in a browser NCSI Test Text File

    Does the client get to this one-line file?

    MJ


    MJ

    Friday, February 24, 2017 7:39 AM
  • Hi Pstoric,

    Please click Troubleshoot problem and check if result is correct.

    Have you tried to reboot adapter to check if issue still occurred?

    The link below is information about connection status for your reference:

    The Network Connection Status Icon

    https://blogs.technet.microsoft.com/networking/2012/12/20/the-network-connection-status-icon/

    Best Regards

    John


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, February 24, 2017 8:54 AM
  • Yes Mike that resolves just fine on the Windows clients. I have already mad sure that works as I came across a post suggesting to test that.


    Friday, February 24, 2017 2:32 PM
  • Hey John. The troubleshooting does not fix the icon. Rebooting does not clear the error. To clarify the internet is working, Windows just says it's not.
    Friday, February 24, 2017 2:35 PM
  • Posted on the MS Partner forums as well and and engineer mentioned to update the NIC driver. Seems to haveworked. Thanks for the help.
    • Marked as answer by GlenTech83 Friday, February 24, 2017 8:04 PM
    • Unmarked as answer by GlenTech83 Monday, February 27, 2017 1:43 PM
    Friday, February 24, 2017 8:04 PM
  • Hi Pstoric,

    Glad to hear that your issue is resolved successfully, and thanks for your sharing.

    Best Regards

    John


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 27, 2017 2:14 AM
  • I posted too soon. That machine started showing the error again. Seems like some of the machines display it and others do not. Still trying to figure out why.
    Monday, February 27, 2017 1:43 PM
  • Hi Pstoric,

    And then please ensure you have not configured GPO to disable NCSI.

    You could check link above that I provided to check if NCSI is disabled.

    Please run netsh int ip reset command and netsh winsock reset command and check again.

    Best Regards

    John


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.




    • Edited by John Lii Wednesday, March 1, 2017 2:57 AM
    Wednesday, March 1, 2017 2:42 AM
  • There is no GPO in place to disable NCSI currently. I've been troubleshooting remotely via logmein so I'll need to be there in person to run the netsh int ip reset and netsh winsock reset commands. I'll try to stop in there tomorrow.

    Wednesday, March 1, 2017 9:52 PM
  • Hi Pstoric,

    Thanks for your effort, and if there is anything we can do for you, please feel free to post in the forum.

    Best Regards

    John


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 2, 2017 2:07 AM