locked
incoming e-mail from workflow RRS feed

  • Question

  • Hi,

    I need to use incoming e-mail on a list. The problem is that this is not working if the e-mail is send by a workflow. If I send a mail from outlook it works.

    If I look in the log file I see this:

    The Incoming E-Mail service has completed a batch.  The elapsed time was 00:00:00.0673785.  The service processed 1 message(s) in total.  Errors occurred processing 1 message(s): Message ID: <f267a475-afb9-6fc5-caa4-484ea665916d@...>

    The mail stays in the drop-folder. 

    What could be the problem?

    Monday, May 13, 2013 11:29 AM

All replies

  • Can you try this??

    restart the Sharepoint Timer service and it is on proper account access

    also check on the doc lib setting, under comm, incoming email settings settings.

    in the settng of in save original email Check Yes property 



    http://www.sharepointlovers.com

    Monday, May 13, 2013 6:28 PM
  • Hi Endeka,

    I think I have a fix for you, you can either update to the Latest CU or at least June CU 2012. Or you can go entral Administration > Application Management > Configure quotas and locks > on the Site Quota Information section >  set a limit (i.e: 5000 MB) on this setting:  “Limit site storage to a maximum of:”  > and then press “OK”.

    Now this should work.

    Regards, Pieter
    MCPD | MCITP

    My Blog

    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Monday, May 13, 2013 6:34 PM
  • Tnx Jayaraja and PieterJvr for the reply.

    I tried both, but with no result.

    As I said, incoming mail is working, but not if I do it with a workflow. With outlook it's working and the items are created on my list.

    In my workflow I send a mail and I added my e-mail in cc. I receive the mail and the mail is in "inetpub\mailroot\Drop" but then he stays in the folder.
    If I do this with outlook, i see the mail in the folder but after the job runs the mail is gone and it's created in my list.

    Tuesday, May 14, 2013 6:18 AM
  • Did you try to send email using Email Activity?

    Maybe you can try using SPUtility

    SPUtility.SendEmail(workflowProperties.Web, true, true, email, subject, message);

    Tuesday, May 14, 2013 7:30 AM
  • It's a workflow created in SharePoint Designer. I just created this WF to try this function, so it's not complicated:

    Tuesday, May 14, 2013 8:10 AM
  • Hi Endeka,

    In your drop folder, could you open the mails sent via the workflow and see if there is a valid sender in the mail.

    Next what you can try is to execute the Send Mail action in the workflow within an impersonation step, this will cause the mail to be sent from the user who published the workflow, maybe this is your issue?

    Regards, Pieter
    MCPD | MCITP

    My Blog

    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Tuesday, May 14, 2013 8:20 AM
  • Indeed, I saw that too that the sender could not be valid.

    The sender is somthing like this:

    From: =?utf-6?B?GVZvdU6UEb==?= <admin@sharepoint.com>

    The email address is correct, but not the name of the sender.

    But we use the same user/email for the alerts. In central admin and the settings for outgoing mails we have admin@sharepoint.com and in outlook we see the correct name of the sender.

    If I look to the properties, admin@sharepoint.com has an display name and an alias.

    So what could be the problem that I see =?utf-6?B?GVZvdU6UEb==?= in the mail?

    Thursday, May 16, 2013 6:12 AM