none
Why are schedules not running? RRS feed

  • Question

  • I'm evaluating DPM System Center 2012R2 and have two simple protection groups, both include only local disks (volumes), one goes to a (local) disk repository, the other to a VTL.

    Both are "full + incremental", with fulls on saturday and incrementals daily, sync (for the disk respository) 3 times per day.

    Both protection groups run successfully when I manually create a recovery point.

    There are scheduled jobs displayed for both, but neither run.  I've tried "resume backups" for both disk, tape, at all level, but the scheduled jobs never run.  I've rebooted, restarted DPM services - same thing.  This has been going on for at least a week, over a weekend.

    What am I doing wrong?  Running scheduled backup jobs is so basic - but there's no errors, nothing in event log - I cannot find any clues. 

    Thanks for any suggestions or pointers since I'm new to DPM.

    Friday, November 22, 2013 2:02 PM

All replies

  • Well, what are you 'resuming' backups on? Just the area in the protection group area, or on a warning from the monitoring area?

    Are you getting any warnings, or critical errors at all in the monitoring area? If you are not getting any warnings, or critical errors on the jobs -- 

    What is your SQL server configuration? Local, or remote?

    If it is a remote SQL server, did you run the remote sql prep from your installation media?

    If you can manually run a job, but scheduled jobs are not running - it sounds like you have a SQL issue.

    Either the job scheduler is failing, or the triggerjob.exe doesn't have access to the resources it needs.

    Can you verify that jobs are listed under the SQL Server Agent, and view a few job history to see what is going on. Also, those jobs are not friendly at all, and will see them all listed as 1c0cdc51-8321-4bf7-a5e5-f451b68233a7 etc --

    • Proposed as answer by Gabriel Roa Tuesday, January 26, 2016 10:46 PM
    Friday, November 22, 2013 4:28 PM
  • I'm having this same issue on DPM 2012 R2

    DPM backup server:

    2012 R2 Standard
    System Center R2
    SQL Server SP1 (local instance)

    I went and looked at the SQL Server Agent, it was on, but all my jobs were disabled, so I enabled them, still didn't run, so I started looking at logs, the SQL log showed that all my jobs were trying to use my network credentials to log on and run the jobs, it shouldn't be doing that and that is why the system auto-disabled them, so I know I need to change the network account that is being used to run these jobs but i'm not an SQL guy and don't have a clue as to how to do that.


    Stacey P. Shoemaker

    Friday, November 22, 2013 10:59 PM
  • Hey Shoey,

    I'm not positive about R2, but previous versions of DPM use a locally generated MICROSOFT$DPM user to run the sql service. This gets created when installing SQL locally as part of the default installation.

    I apologize for making assumptions, because I have not started using R2 yet; and only use remote SQL servers with AD service accounts. If you are using a different service account to run SQL, and are basically getting a permission issue - check in the security area, properties of the login, and if it has the SysAdmin SQL server role checked.

    My suggestion would be to see what your SQL service is running as, if DPM generated the local service account, and to then set the SQL service to run as that user if it indeed did make one.

    Hope this leads you in the right direction.

    Regards,

    Kyle

    Friday, November 22, 2013 11:41 PM
  • it does, thank you, when I upgraded to R2 the install failed so I found somewhere on a Microsoft forum that you had to change the account name from MICROSOFT$DPM$ to Local, run the install (it worked) and then change the account name back to MICROSOFT$DPM$ which I did but obviously didn't do something right, the trouble I'm having is figuring out how to get back to the place where I can check or change that again.

    Stacey P. Shoemaker

    Friday, November 22, 2013 11:51 PM
  • I didn't fully RTFM.  SQL server and DPM must be in same domain, mine weren't.  Opened a MSDN ticket and MS reports there is a "hard block" with the SQL agent scheduler running DPM jobs in a different domain.  I'm redoing the setup and will report back.  Its clear that the SQL agent scheduler must be in really solid shape for DPM scheduled jobs to run, and if the jobs don't run, look for SQL server agent scheduler errors or messages.
    Monday, November 25, 2013 7:26 PM