locked
The service account cannot access SQL server. Ensure that the server is accesible, the service account is not a local account being used with a remote SQL server, and that the account doesn't already have a SQL login RRS feed

  • Question

  • Hi ,

    I am installing ILM 2007.

    We are implementing high DR solution the following error has occurred
    "The service account cannot access SQL server. Ensure that the server is accessible, the service account is not a local account being used with a remote SQL server, and that the account doesn't already have a SQL login"

    1) i have added ilm service account as sys admin in sql server.

    2) i have added the service account in local administrator group in sql server.

    3) i have given domain admin right's to ilm server.

    I have tried

    http://support.microsoft.com/kb/970305


    Please help me solving this issue.

     
    Tuesday, February 2, 2010 11:19 AM

Answers

  • First of all: your really should provide some more background information as Paul requested.
    It's like shooting in the dark without some background info.
    If you need some help with that, check this article.

    You mention an SQL 2005 cluster, which means SQL is not on the ILM server?
    What OS'es are you running on ILM and the SQL cluster?
    Can you connect with another SQL client or SQL management interface, using th ILM Service credentials?

    Are you running a fresh install or do you reconnect to an existing MIIS Database?

    Secondly, carefully read the KB article 970305.
    It's not only about the ILM service account.
    Of course, you must check the permissions of the service account. But also the account running the installation.

    "In some cases this error is caused by one of the situations explained in the error message, but it can also occur when the account running setup does not have sysadmin permissions in SQL. "
    and also
    "1. Grant the account running setup sysadmin permissions in SQL. This can be revoked after the setup is complete.

    2. Run setup as a SQL sysadmin account. In this case the SQL account will need to be a local administrator on the computer on which ILM is being installed but as in the previous solution, this can be revoked after setup is complete. "


    Just a sanity check: the account you use to run the installation, is it member of the MIISAdmins group?

    And another hint might be to check the domain name you use when entering the service account credentials.

    Is the ILM services account listed as dbo.owner of the MIIS database (see here)?

    Kind regards,
    Peter


    Peter Geelen - Sr. Consultant IDA (http://www.traxion.com)
    Wednesday, February 3, 2010 3:56 PM

All replies

  • make sure SQL accepts remote connections from SQL server surface area configuration
    www.rafieblog.com
    Tuesday, February 2, 2010 11:44 AM
  • Could you tell a bit more on your SQL configuration? Are you using clustering, transaction log shipping, mirroring, backup/restore, ... ?
    Paul Loonen (Avanade) | MCM: Directory 2008 | MVP: ILM
    Tuesday, February 2, 2010 1:23 PM
  • Is it a domain account?  It won't work if the service account is only on the local machine SAM.
    AhmadAW
    Tuesday, February 2, 2010 6:15 PM
  • Hi,

    yes i am using Cluster SQL 2005.


    Thanks, 
    Wednesday, February 3, 2010 1:41 PM
  • Hi,

    It is Domain Acccount.

    Thanks,
    Wednesday, February 3, 2010 1:42 PM
  • Hi ,

    The i have enabled to accept remote connections from SQL server surface area configuration,
    but no luck.

    Thanks,
    Wednesday, February 3, 2010 1:43 PM
  • First of all: your really should provide some more background information as Paul requested.
    It's like shooting in the dark without some background info.
    If you need some help with that, check this article.

    You mention an SQL 2005 cluster, which means SQL is not on the ILM server?
    What OS'es are you running on ILM and the SQL cluster?
    Can you connect with another SQL client or SQL management interface, using th ILM Service credentials?

    Are you running a fresh install or do you reconnect to an existing MIIS Database?

    Secondly, carefully read the KB article 970305.
    It's not only about the ILM service account.
    Of course, you must check the permissions of the service account. But also the account running the installation.

    "In some cases this error is caused by one of the situations explained in the error message, but it can also occur when the account running setup does not have sysadmin permissions in SQL. "
    and also
    "1. Grant the account running setup sysadmin permissions in SQL. This can be revoked after the setup is complete.

    2. Run setup as a SQL sysadmin account. In this case the SQL account will need to be a local administrator on the computer on which ILM is being installed but as in the previous solution, this can be revoked after setup is complete. "


    Just a sanity check: the account you use to run the installation, is it member of the MIISAdmins group?

    And another hint might be to check the domain name you use when entering the service account credentials.

    Is the ILM services account listed as dbo.owner of the MIIS database (see here)?

    Kind regards,
    Peter


    Peter Geelen - Sr. Consultant IDA (http://www.traxion.com)
    Wednesday, February 3, 2010 3:56 PM
  • I had similar issue and I granted account running setup sysadmin permissions in SQL.  

    That was the thing that worked for me.


    Tuesday, July 10, 2012 3:24 PM