locked
Outlook 2007 and higher keeps prompting for password RRS feed

  • Question

  • Hello All:

    Hope everyone is having good day, because I am not. Currently some random users are repeatedly getting prompted for password using Outlook 2007 and later. I went through quite a few suggestions through this forum and they all mention to make quite a few changes, but without knowing true I afraid to make changes which might break something else.

    I have been working at this place for almost one year, and this is what I have found in our environment. We were running Exchange 2003 on windows 2003 server, webmail portion is currently running on different windows 2003 server. Then they migrated to Exchange 2007 running on windows 2008.

    But Exchange 2003 was never removed, even though all services are disabled. On exchange 2007 server we are getting event 5006 warning for routing.

    On Exchange 2007 console I noticed that under OAB it has two address books listed first (not default) pointing to old exchange 2003 server which is also DC and second point to itself (exchange 2007).

    Under client access server which is our webmail server (separate server running W2003) OWA have multiple sites pointing to exchange 2003 and 2007

    Below is the servers details

    1. Exchange 2003 on windows 2003 (DHCP, DC not primary)

    2. Web Mail running IIS6 on windows 2003

    3. Exchange 2007 running on windows 2008

    4. we have three DC's 1. W2008 all the roles

    I would like to completely remove Exchange 2003 and all the entries from sites and services (first administrative group) run web mail on exchange 2007 mail server and remove webmail running 2003.

    Also I believe prompting for password has something to do with OAB because when I click cancel on login prompt and click on send receive with OAB checked then login prompt will go away and will come back after while.

    Sorry for long question. Please help.

    Some screenshots attached.
    • Edited by nsheth Friday, December 14, 2012 9:30 PM
    Friday, December 14, 2012 9:25 PM

Answers

  • Yes, it does.  Did you configure web distribution of the OAB and remove public folder distribution, if that's what you want?  Myself, I usually enable both.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    • Edited by Ed CrowleyMVP Monday, December 17, 2012 2:18 PM
    • Marked as answer by nsheth Wednesday, January 2, 2013 2:31 PM
    Monday, December 17, 2012 2:17 PM

All replies

  • If you start the Exchange 2003 services and the prompts go away, then you'll know that something hasn't been moved over right yet.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Monday, December 17, 2012 2:31 AM
  • Hi Ed,

    I ran test email configuration from outlook and I noticed that OAB is pointing to Public folder, because when I get login prompt in outlook after cancelling few time it goes aways but status shows need password, when I click on send and receive all groups then status bar changes back to connected. It must have something to with OAB, can you please check.

               ASUrl>https://mail.company.com/ews/exchange.asmx</ASUrl>
            <EwsUrl>https://mail.company.com/ews/exchange.asmx</EwsUrl>
            <OOFUrl>https://mail.company.com/ews/exchange.asmx</OOFUrl>
            <UMUrl>https://mail.company.com/unifiedmessaging/service.asmx</UMUrl>
            <OABUrl>Public Folder</OABUrl>

    Monday, December 17, 2012 1:41 PM
  • Yes, it does.  Did you configure web distribution of the OAB and remove public folder distribution, if that's what you want?  Myself, I usually enable both.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    • Edited by Ed CrowleyMVP Monday, December 17, 2012 2:18 PM
    • Marked as answer by nsheth Wednesday, January 2, 2013 2:31 PM
    Monday, December 17, 2012 2:17 PM
  • Can you please provide some instructions if you do not mind, thanks
    • Edited by nsheth Monday, December 17, 2012 10:28 PM
    Monday, December 17, 2012 6:31 PM
  • http://www.lmgtfy.com/?q=exchange+2007+oab+web+distribution+public+folder#

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    Monday, December 17, 2012 10:39 PM
  • Hi Ed:

    I have enabled both web and public and restarted system attendant service, but it is still prompting for login for outlook 2010 and 2007 users

    Thursday, December 20, 2012 3:49 PM
  • Since I am having this problem only for internal users, so I checked few more things and looks like URL for internal and external are set same under client access - OAB distribution 

     https://mail.companyname.com/oab

    and the certificate does not have local FQDN for mail server mail.companyname.local and outlook is configured to connect exchange using HTTP

    Any ideas?

    Should I configure exchange to use internal url as http://mail.mailservername.local/oab will that help?

    Thursday, December 20, 2012 4:01 PM
  • In general it's a lot easier to configure split-brain DNS and use the same external URL for both the InternalURL and ExternalURL on all virtual directories.  You can't get a public certificate issuer to put internal-only SANs (e.g. company.local) in a certificate.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Monday, December 24, 2012 2:35 AM
  • Ed, so far no continious password prompts, thank you for your help.
    Wednesday, January 2, 2013 2:32 PM