locked
Managed Folder Mailbox Policy - "A positional parameter cannot be found that accepts argument '-ManagedFolderMailboxPolicyAllowed'" RRS feed

  • Question

  • Hello,

    I'm using Shell to setup managed folder mailbox policy on a large number of mailboxes.

    When i specify something on the lines of below for a single user i get an error:

    Set-mailbox user@domain.com -managedFolderMailboxPolicy "My policy" -ManagedFolderMailboxPolicyAllowed

    A positional parameter cannot be found that accepts argument '-ManagedFolderMailboxPolicyAllowed' .

    + CategoryInfo            :  InvalidArgument: (:) [Set-Mailbox], ParameterBindingException

    + FullyQualifiedErrorId :  PositionalParameterNotFound,Set-Mailbox

    Specifying the above switch as -ManagedFolderMailboxPolicyAllowed:$True does not help either.

    I'm sure there is somethign very basic i may be missing, any help is greatly appreciated.

    Thanks!

    

    Tuesday, September 4, 2012 2:35 AM

Answers

  • Set-mailbox user@domain.com -managedFolderMailboxPolicy "My policy" -ManagedFolderMailboxPolicyAllowed

    Hi Shaak1.

    Which version of Exchange do you use? Exchange 2007 or Exchange 2010?

    I can run the above cmdlet in Exchange 2007 & Exchange 2010 and it works.

    Please also run the cmdlet on another Exchange server to test.


    Frank Wang

    TechNet Community Support


    • Edited by emma.yoyo Monday, September 10, 2012 4:04 AM
    • Marked as answer by emma.yoyo Tuesday, September 11, 2012 1:51 AM
    Wednesday, September 5, 2012 6:37 AM

All replies

  • Make sure you are adding the user name correctly. Or use Set-Mailbox -Identity.
    Tuesday, September 4, 2012 11:16 AM
  • Thank you for your reply.

    I have verified user name and have tried Set-Mailbox -identity as well. If i remove "-ManagedFolderMailboxPolicyAllowed" switch, it works however of course throws the confirmation dialog which i wanna avoid. That however proves that the username or identity parameter i'm passing is accurate.

    Thanks

    Tuesday, September 4, 2012 1:42 PM
  • Set-mailbox user@domain.com -managedFolderMailboxPolicy "My policy" -ManagedFolderMailboxPolicyAllowed

    Hi Shaak1.

    Which version of Exchange do you use? Exchange 2007 or Exchange 2010?

    I can run the above cmdlet in Exchange 2007 & Exchange 2010 and it works.

    Please also run the cmdlet on another Exchange server to test.


    Frank Wang

    TechNet Community Support


    • Edited by emma.yoyo Monday, September 10, 2012 4:04 AM
    • Marked as answer by emma.yoyo Tuesday, September 11, 2012 1:51 AM
    Wednesday, September 5, 2012 6:37 AM
  • Hi Shaak1,

    Any updates?


    Frank Wang

    TechNet Community Support

    Monday, September 10, 2012 4:04 AM