locked
Exchange services restart manually RRS feed

  • Question

  • Good Morning, 

    I had a power outage, my exchange 2013 servers went down unexpectedly. 
    When turned on again, the messages came out, but after restarting the services: transport, delivery and submission began to work, but I have to do this every time you reboot the server. 

    Please your help to solve this 

    Thanks in advanced

    Friday, August 15, 2014 9:19 PM

Answers

  • Usually this happens when the AD topology service either fails to start or doesn't start in a reasonable amount of time, since all Exchange services rely on it.  This can be caused by performance issues, network issues, hardware issues, etc. You'll have to scan through event logs to determine the actual cause.  As a work around you can set the services to delayed automatic start, that way the rest of the system finishes starting up, then Exchange starts.
    • Proposed as answer by Amit Tank Saturday, August 16, 2014 2:30 AM
    • Marked as answer by Belinda Ma Monday, August 25, 2014 2:01 AM
    Friday, August 15, 2014 9:47 PM

All replies

  • Usually this happens when the AD topology service either fails to start or doesn't start in a reasonable amount of time, since all Exchange services rely on it.  This can be caused by performance issues, network issues, hardware issues, etc. You'll have to scan through event logs to determine the actual cause.  As a work around you can set the services to delayed automatic start, that way the rest of the system finishes starting up, then Exchange starts.
    • Proposed as answer by Amit Tank Saturday, August 16, 2014 2:30 AM
    • Marked as answer by Belinda Ma Monday, August 25, 2014 2:01 AM
    Friday, August 15, 2014 9:47 PM
  • It will be good to configure Group Policy setting on Exchange servers that say "wait for network before logon" this way services that are dependent on Active Directory would not fail to start.


    - Sarvesh Goel - Enterprise Messaging Administrator

    Saturday, August 16, 2014 4:43 AM