locked
How to Show Documents on the Desktop in Vista RRS feed

  • General discussion

  • Not having the option of showing Documents on the Desktop has been driving me nuts since Vista was released and today I finally figured out how to fix it.

    I run a huge domain where users don't have write access to their profiles folder (mandatory profiles). If they save there the files are lost. Therefore I need to stick to the XP way of just showing the Documents Folder which is redirected.  With Folder Redirection the Pictures and Music follow the Documents folder anyway.

    Basically this is a registry hack so it should be applied ONLY by those comfortable with editing the registry. I also recommend backing up the current settings by exporting the key before making changes.

    From what I have found the three keys that affect this are.

    [HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}]

    This is the "Documents" key that handles everything including the Context Menu. To Fix it I exported the working one from Windows XP and merged it with the Vista one.  I then DELETED the cmd key which was under the shell subkey.

    The important parts that were added to the key are the Property Handlers and the Context menus.

    If you want the Vista Icon you can change the icon path back to  %SystemRoot%\system32\imageres.dll,-112

    The Second Location is the Explorer Key which hides or shows the Desktop Icons. I put in the Local Machine to affect all users.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\HideDesktopIcons]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\HideDesktopIcons\ClassicStartMenu]
    "{450D8FBA-AD25-11D0-98A8-0800361B1103}"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\HideDesktopIcons\NewStartPanel]
    "{450D8FBA-AD25-11D0-98A8-0800361B1103}"=dword:00000000


    The Third place which I am not sure if it has any affect or not but I added it anyway was:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Desktop\NameSpace\{450D8FBA-AD25-11D0-98A8-0800361B1103}]
    @="Documents"

    I DELETED the key "Removal Message"="@mydocs.dll,-900"

    Cheers,
    Lara


    lforbes
    Sunday, May 17, 2009 7:12 AM