none
GPO AutoUserLogIn does not work

    Question

  • Hi all

    I have a server 2012 r2 as a domain controller and windows 7x46 as a kiosk pc.

    I created a GPO:

    Computer->preference->Windows settings->Regedit:

    Tyep Reg_SZ

    AutoAdminlogon = 1
    DefaultDomainName = DOM01
    DefaultUserName = MESAutoStart
    DefaultPassword = MES1Password

    ForceAutoLogon = 1


    Key location: HKLM\SOFTWARE\Microsoft\Windows NT\Current Config\WinLogon as my client is windows 7x46...

    After running gpupdate /force i can see all the keyes in the Regedit in my client pc, but when i restart the client pc. It does not log in automaticaly....

    I googled alote, som people sayes the key location should be "HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\WinLogon", som people because of x64 version of the client.

    I tried creating the same keys under User Configuration->preference->Windows settings->Regedit:

    But noting helped... I hope anyone here can se what i did wrong.

    regards

    Saturday, May 14, 2016 7:04 PM

Answers

  • Hi all thanks for all reply...

    In some reason a new GPO from skratch creating the keyes to the location: HKLM\SOFTWARE\Microsoft\Windows NT\Current Config\WinLogon works now.

    And the GPO setup is Computer Configuration->Preferences->Windows Settings->Registery...

    They keyes are just 4:

    AutoAdminLogon->update

    DefaultDomainName->Update

    DefaultPassword->Update

    DefaultUserName->Update

    And that is all working fine....


    Friday, May 20, 2016 8:20 AM

All replies

  • Hi,
    What action did you use while configuring GPO? This type of preference item provides a choice of actions: Create, Replace, Update. I would suggest you use Update option and test again.
    Besides, please have a try again following the article as below exactly. Based on my test in lab, it is successfully like a charm.
    How to use Group Policy Preference enable auto-logon
    http://www.grouppolicy.biz/2010/10/how-to-use-group-policy-preference-enable-auto-logon/
    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,
    Wendy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 16, 2016 6:34 AM
    Moderator
  • Hi Wendy Jiang

    Thanks for reply.

    I did use update action.. 

    When i log in to the client machin with admin user to check the regedit. I can see that all the keys are created by the gpo correct. I runned gpupdate /force several time and restart the client machine but it does not start with the auto-log-in user.

    I do followed the link and still have the issue.
    • Edited by MAyubi Monday, May 16, 2016 8:21 AM
    Monday, May 16, 2016 8:20 AM
  • You need to create the reg value (DWORD) for DisableCAD and set to 1.


    https://technet.microsoft.com/en-us/library/cc978776.aspx
    • Edited by zxxzxx Wednesday, May 18, 2016 6:55 PM
    Monday, May 16, 2016 2:53 PM
  • Hi all thanks for all reply...

    In some reason a new GPO from skratch creating the keyes to the location: HKLM\SOFTWARE\Microsoft\Windows NT\Current Config\WinLogon works now.

    And the GPO setup is Computer Configuration->Preferences->Windows Settings->Registery...

    They keyes are just 4:

    AutoAdminLogon->update

    DefaultDomainName->Update

    DefaultPassword->Update

    DefaultUserName->Update

    And that is all working fine....


    Friday, May 20, 2016 8:20 AM