Uninstall Hyper-V Integration Services RRS feed

  • Question

  • Hello, I have a question about Hyper-V integration services.  I cannot figure out how to uninstall them in a Windows 2008 guest (it is easy in Windows Server 2003, its in Add/Remove Programs).  However, it does not appear in the uninstall Programs list (via Control Panel).  I have read online to simply run setup.exe /uninstall from the Integration Services setup files, but that isn't working either (referenced at: http://capitalhead.com/articles/uninstall-integration-services-from-hyper-v-windows-guest-virtual-machine.aspx).  Does anyone know how to uninstall these services?  (I have confirmed that the tools are indeed installed, all the features work and the services are listed in services.msc).  Thanks!

    Wednesday, March 17, 2010 8:37 PM

All replies

  • It doesn't appear in the list of programs in later operating systems because it is part of the operating system.

    • Marked as answer by Vincent Hu Thursday, March 18, 2010 7:36 AM
    • Unmarked as answer by bcehr Thursday, March 18, 2010 7:01 PM
    Wednesday, March 17, 2010 11:35 PM
  • How do I turn it back off after it gets "activated" in the operating system?  Before I installed Hyper-V integration services, the Hyper-V services were not present in services.msc.  As soon as I installed the integration services via setup.exe on the integration services setup disk, the services appeared in services.msc.  I need to get these removed/uninstalled.  Do you know how I can do this?  (I am referring to the tools installed in a VM guest, not the host Hyper-V server role.)

    Thursday, March 18, 2010 7:07 PM
  • This is just a guess. Go to Services and select the properties for the services you want removed. Disable them. Reboot your vm. See if that does what you want.

    • Proposed as answer by Mark Stutzbach Monday, February 21, 2011 4:17 PM
    Thursday, March 18, 2010 10:33 PM
  • Hi,


    I would like to know why you want to uninstall the Integration Services.



    Best Regards,

    Vincent Hu


    Friday, March 19, 2010 3:51 AM
  • Hey!  I have a server (that cannot easily be rebuilt) that needs to go back to being a physical machine.  I have a tool that will preform this conversion, but I need to get the Hyper-V services removed first, which I can't figure out how to do (I wouldn't think uninstalling a program would be this hard ;)).   Thoughts on how I can do this?  Thanks!
    • Proposed as answer by Jens Heidling Saturday, March 5, 2016 6:29 PM
    • Unproposed as answer by Jens Heidling Saturday, March 5, 2016 6:30 PM
    Sunday, March 21, 2010 5:41 PM
  • Anyone have any idea how I can remove the Hyper-V tools/features so I can get this box back to physical (I need to get rid of all the Hyper-V services that run)?  Thanks!

    Thursday, April 1, 2010 8:41 PM
  • Hi,


    As John mentioned, the Integration Services is a part of the operating system, so you can’t remove it, and you don’t need to remove it, the files are there no matter your system installed on a physical computer or virtual machine.


    By the way, I only heard of P2V, never V2P. You need to notice that the migration from virtual machine to physical may not work.



    Best Regards,

    Vincent Hu


    Friday, April 2, 2010 7:58 AM
  • I have done V2P, but it often doesn't go well. There are commercial products that may be of value, although I've have discouraging results with some.
    Friday, April 2, 2010 3:56 PM
  • Thanks for the replies!  Vincent, since the files are there regardless what makes the Hyper-V services appear in services.msc after telling Virtual Machine manager to install Integration services?  Is it a flag that is flipped?  Is there a way to stop and hide these extra running processes that get activated when I tell Virtual Machine Manager to install integration services?  The main thing is, server admins will  not want to see hyper-v services running in services.msc on a phsyical server (the rest of our physical services do not have these services running).  Thanks!
    Friday, April 2, 2010 9:08 PM
  • hello...just wanna know what happened with you...did u manage to remove or uninstall the integration services??? did the migration work?I also need to migrate from v2p using Acronis but it says that i have to remove the integration services before...
    Monday, April 26, 2010 9:16 AM
  • hey, I have not fully been successful yet.  I did a test migration and it worked just fine except that all the Hyper-V services are still running in services.msc and they are throwing a lot of errors in the event log (since I can't find anyway to remove them without hacking the registry, which I don't want to do), and they all have issues when they try to startup.  For now, I can't convert the final version to physical until I get these hyper-v  service issues resolved.  If you find a better solution, let me know!
    Monday, April 26, 2010 3:10 PM
  • Disable the services that are causing problems.
    • Proposed as answer by mozilla001 Tuesday, April 27, 2010 8:41 AM
    Monday, April 26, 2010 10:03 PM
  • Integration services can be installed from the disk itself..
    1. Start the Hyper-V management console
    2. Start and Connect to your Virtual Machine
    3. Click on Action > Insert Integration Services Setup Disk
    4. Log onto your virtual machine and open the command prompt
    5. At the command prompt browse to the Integration Services Setup Disk(D:\ in most cases)
    6. At the command prompt browse to D:\support\amd64 or D:\support\x86 depending on the arch of the vm
    7. To Uninstall the Integration Services, just type in the command prompt >Setup.exe /uninstall
    8. Restart the VM to make sure that the uninstallation process worked
    • Proposed as answer by mozilla001 Tuesday, April 27, 2010 8:45 AM
    Tuesday, April 27, 2010 8:45 AM
  • I have tried to use the /uninstall switch before, but it doesn't work.  It just gives me the message "A previous version of Hyper-V Integration services has been detected.  Click OK to upgrade or repair this installation."  If I press OK, it simply repairs, can't uninstall.  I have also tried unchecking the options in the VM settings, regardless the services continue to run in services.msc.  Thanks.
    Tuesday, April 27, 2010 12:58 PM
  • check that turned off hyper-v role in guest system
    • Proposed as answer by Belalov Yuriy Friday, June 11, 2010 6:51 AM
    Friday, June 11, 2010 5:24 AM
  • i also want to remove this tool because i want to use native boot from the windows 2008 r2 vhd. The vhd was started in hyper-V before so has the tool installed in it. 

    When i try native boot from vhd, it restarted automatically, seems that there was blue screen for a short period of time, less then 1 seconds. If i try native boot and F8 to boot with safe mode (or something that i don't remember), i found that it restart just after the CLASSPNP.SYS is loaded (or loading).

    i found in this article http://chenyitai.blog.51cto.com/996951/340657 that i should use sysprep for the vhd or remove the hyper-v tool:

    我直接在另外一台Hyper-v服务器上搭建了一个全新的Windows 2008 R2 64位虚拟机(需要执行Sysprep,否则后续引导此VHD时极有可能出现蓝屏——估计直接删除Hyperv的虚拟机附件也可以吧)

    Saturday, July 3, 2010 3:18 PM
  • sysprep did not solve my problem. and since the integration service seems not be able to be removed. My problem might have other reason.

    I have windows 2008 r2 installed, and enabled hyper-v. On the hyper-v, i am running SharePoint 2010 information worker demo vm. it runs fine. However, after i configured native boot from VHD and restart, the blue screen appear and restart automatically.  

    My "outter" windows 2008 r2 boots fine;

    The SharePoint 2010 information worker demo vm boots fine in hyper-v; It just does not work in native boot from VHD.

    Sunday, July 4, 2010 3:56 AM
  • Turned out that my laptop cannot pass Windows extended memory test, stuck at 21%. It can pass standard memory test. I suspect the "cheap" memory i bought has something wrong.

    I don't know if the memory issue has anything to do with the VHD native boot blue screen issue.

    Wednesday, July 28, 2010 5:09 AM
  • sorry for my questation . I want migrate vm w2008r2 from microsfto hyper-v to vmware ... How ? HOw I remove intgration servicies ??? I try run setup /uninstall but not afect . I try uncheck all check box in the setting VM , but not affect .. some solution ?


    Monday, August 16, 2010 9:17 PM
  • any solution

    Thursday, August 19, 2010 9:45 AM
  • Same problem here, some VMs that used to run on Hyper-V are still showing the services. I'll do some more research first, but I think I'll see if I can't get rid of the services using the "sc" command line tool ("Service Control"). "sc delete <nameofservice>" ought to do the trick.

    • Proposed as answer by dbarbed Wednesday, December 4, 2019 8:33 PM
    Tuesday, March 15, 2011 2:29 PM
  • Microsoft are you listening?

    I've recently run into an issue whereby my guest VM's simply ARP each other out of existence on the network - this was only happening on my latest 08-R2-Core+HyperV host and it's 08-R2-GUI guests, until I upgraded the integration services on some 08-GUI guests that were working fine on another 08-R2-GUI host - now for obvious reasons I have a need (or at least a want) to either uninstall and/ or revert.  I've been working with MS Tech Support for 5 hours and they suggested I install KB2264080 (which unfortunately for me is already installed and has NOT resolved the issue).  I'm using Dell Poweredge R610's with the Intel Xeon 5600 series processors.

    I just think that if it's not part of the OS (as in a window option) you should have a way of removing these services.  Virtual environments are often used for testing, which typically involves multiple scenarios (one of which may include running with or without integration services).  If not simply for this and the other reasons people have mentioned below a simple add/ remove entry or at least a working uninstall switch would be greatly appreciated.


    Friday, April 15, 2011 3:18 PM
  • A very very big thanks!

    Removing the Hyper-v role from the guest solve my problem.

    Tuesday, April 15, 2014 8:02 PM
  • I solved the same issue as follows 

    on drive of the integration services i explorered E:\support\x86\ and double clicked Windows5.x-HyperVIntegrationServices-x86.msi   and restart the VM machine.

    Saturday, November 1, 2014 9:23 PM
  • Hi,


    As John mentioned, the Integration Services is a part of the operating system, so you can’t remove it, and you don’t need to remove it, the files are there no matter your system installed on a physical computer or virtual machine.


    By the way, I only heard of P2V, never V2P. You need to notice that the migration from virtual machine to physical may not work.



    Best Regards,

    Vincent Hu


    Incorrect. You DO need to be able to remove them. Consider this.

    1. VM is running the latest version of integration services
    2. VM O/S dies
    3. You restore your server from a backup using HIR restore
    4. HIR restore matches your network card driver and installs an earlier network card driver (in my case 3.2)
    5. Network card fails to start when you boot VM

    There is no possible way to install the latest network card driver because Integration Services says it is up to date, but it is not up to date, it has version 3.2 of the network card drivers installed, not version 5. Uninstalling the network card and reinstalling does not fix the problem.

    There is no solution except to reinstall Windows.

    Monday, June 22, 2015 2:41 AM
  • Hey all,

    Trying to upgrade the virtual machine from Server 2008R2 to Windows 2012 R2 - usually you are suppose to uninstall the integration services on Hyper-V for windows 2003 upgrades, is this not the case with Server 2012R2 ?

    That's how I got to this thread... and attempting the above simply re-installs the integration services. I've run the /uninstall command directly from an admin command line from the Hyper-V console and no luck. I also checked the Roles on the guests OS and found no mention of Hyper-V. Only Role listed was DNS, and nothing under "Features" as well.


    • Edited by TheFreyMan Monday, August 10, 2015 3:23 AM Additional Clarity
    Monday, August 10, 2015 3:22 AM
  • For future googlers, I ran into this issue on a windows server 2008 guest after a p2v conversion.  msconfig trick did not work because I still had the hyper-v role installed.  I removed the role, let it reboot and then did the msconfig - detect hal setting, rebooted and it installed the new hyper-v integration tools.  It required one more reboot after that and voila!

    J. Duke Rogers Communicore Technologies & Triangle Forensics

    Saturday, September 26, 2015 2:35 PM