none
Upgradation/Migration MSPS 2007 to MSPS 2010 RRS feed

  • Question

  • Hi,

    We have migrated MSPS 2007 PWA instance into MSPS 2010 environment, so my question is how to check all data is migrated properly or not?, becuase we have checked in MSPS 2010 migrated PWA all MSPS 2007 data it is showing proper but when i checked through SQL Server 2005 all databases (Archive, Draft, Published and Reporting) then in Reporting database project is available in MSPS 2007 is 181 but in MSPS 2010 reporting database it is showing 182 so one project plan is extra added in MSPS 2010, how this plan is extra added and same thing is happed in other instances also so can you please tell me the way proper way and how this plan is added automatically into database?

    Same thing is happed in resources also.

     

     

    Wednesday, July 20, 2011 2:14 PM

Answers

All replies

  • Hi Amit,

    I take it that the upgrade reported that it had completed successfully? If so, there may be a dummy record in those tables required by the tool.

    To check, I would perform some SQL queries on the old databases and compare it with the new database to confirm where the difference is.

    I have done many of these upgrades and never lost any projects as a result of the upgrade.


    Alex Burton
    www.epmsource.com | Twitter
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Wednesday, July 20, 2011 10:36 PM
    Moderator
  • Yes, it is your "Timesheet Administrative Work Items"

     Ignore It.

    Run the following queries to ensure:

    select projectname from msp_epmproject where projectname='Timesheet Administrative Work Items'


    select count(*) projectname from msp_epmproject where projectname!='Timesheet Administrative Work Items'

     

    Unassigned Resource
    Generic Local Resource
    Unknown Resource

     


    Cheers. Happy troubleshooting !!! Sriram E - MSFT Enterprise Project Management
    Wednesday, July 20, 2011 11:22 PM
    Moderator
  • Hi Alexander,

    If you have any links to follow steps and the SQL Queries to check with old databasesm becuase i have checked in 3,4 PWA instances it's upgraded properly but only 1 instance it is always showing "Failed" message and i am getting this error in event log:

    Provisioning 'CFTest_PWA': Post provisioning setup failed.
    Exception 'Microsoft.Office.Project.Server.Administration.ProvisionException:
    Post provisioning setup failed.    
    at Microsoft.Office.Project.Server.Administration.PsiServiceApplication.CreateSite
    (ProjectProvisionSettings provset)'. 75e56776-ea3b-4a87-b357-adc18018b252

     

     

     


    Amit Vaman Patil
    Wednesday, July 27, 2011 11:54 AM
  • That is an error with the SharePoint configuration wizard so best to review the ULS and upgrade logs.  No database scripts are going to help with that specific error.

    Best regards,

    Brian


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Tuesday, August 9, 2011 3:49 PM
    Owner