locked
5.1 Client with 5.0SP3 Infrastructure RRS feed

  • Question

  • Hello,

    Can anyone confirm if its supported running AppV 5.1 Client with a full 5.0 SP3 Infrastructure?

    Cheers.

    Thursday, July 21, 2016 3:49 AM

Answers

All replies

  • I don't think the Statement is anywhere on TechNet, but I know from a Microsoft Support Engineer, that the Order in which you update your Components (Server / Clients) doesn't matter.

    Basically a 5.1 Client can talk with an App-V 5.0 SP1 / SP3 Server and a 5.1 Server can be used for a 5.0 SP1 / SP2 / SP3 Client.

    You can find a vague Statement "Components to upgrade, in any order" on this TechNet Page: https://technet.microsoft.com/en-us/itpro/mdop/appv-v5/about-app-v-51

    This basically means, that there has to be a cross version support. You can't really upgrade your Servers and all of your Clients at exactly the same time.


    Simon Dettling | msitproblog.com | @SimonDettling

    Thursday, July 21, 2016 6:22 AM
    Moderator
  • Hi Simon,

    I also struggled to find any definitive answer on TechNet, I have done some limited testing and it appears so far to be working fine, I will eventually upgrade my entire infrastructure to 5.1 so it wont be an issue, was more just curious on the official stance.

    Thanks for taking the time to respond.

    Cheers.

    Thursday, July 21, 2016 10:14 AM
  • What doesn't work though is a 5.1 Client on a Windows 10 Device with a 5.0 Server, because the App-V 5.0 Server doesn't know how to handle a Windows 10 Device.

    I blogged about this last year: http://msitproblog.com/2015/10/15/app-v-5-1-publishing-error-windows-10-devices/


    Simon Dettling | msitproblog.com | @SimonDettling


    Thursday, July 21, 2016 12:47 PM
    Moderator
  • handy to know.

    Cheers.

    Thursday, July 21, 2016 11:18 PM