none
Project Server 2013 - Preview Option in Task Update Approval not working RRS feed

  • Question

  • hi,

    We have option to preview tasks before accepting in task update approval page in PWA. This preview option is not working. If we click on Preview, the message showed is 'View Failure'.

    Please provide help on the same.

    Regards, Piyusha

    Tuesday, November 19, 2013 8:05 AM

All replies

  • Hi Piyusha,

    Does this happens with any project/update?

    Sometimes this errors happens when the data from the assignment has been corrupted somehow.

    Check event viewer and SharePoint logs to see if there's more info on this failure.

    Hope it helps,

    René Alvarez


    Rene Alvarez

    Wednesday, November 20, 2013 7:39 AM
  • Yes Rene, it happens with any project.

    -Piyusha

    Monday, November 25, 2013 10:01 AM
  • Piyusha --

    I cannot duplicate your error in Project Server 2013.  When you navigate to the Approval Preview page and see the error, what happens if you click the View pick list and select another view?  Are you able to see any other view on this page?  Let us know and we will try to help.


    Dale A. Howard [MVP]

    Monday, November 25, 2013 2:09 PM
    Moderator
  • Hi Dale,

    When I click the View pick list and select another view same error of "View Failure " is thrown again.

    It happens on any view and any project.

    Thanks for your help in advance.

    Piyusha

    PS:sorry for the late response as i did not receive alert for the messages on this post.

    Friday, December 13, 2013 4:47 AM
  • have you applied Latest CU for Project server 2103.

    April hot fix is having resolution for view load error.

    http://support.microsoft.com/kb/2760261

    Also check in sql 

    If tasks will have the value of ASSN_ACT_WORK = NULL instead of 0.00000.

    This caused the System.InvalidCastException in the ULS log and the user error the view failed to load.



    kirtesh

    Friday, December 13, 2013 5:21 AM
  • Hi,

    I checked in DB. The column ASSN_ACT_WORK = 0.00000 instead of Null.

    For the patch, I will check with my Admin team.

    Regards,

    Piyusha

    Tuesday, December 17, 2013 5:02 AM
  • This can come up if the Task contains one or more missing assignments or the task for that assignment was deleted form the project plan, or possibly the resource was unassigned and then re-assigned causing the assignment_uid to change and it no longer matches the assignment_uid in the timesheet/Task.

    In case the issue is only for one user then you can ask him to recall, delete and recreate his Timesheets but if the issue has spread across multiple users then I would suggest that you raise a support ticket with Microsoft to help identify the list of affected users and fix their Timesheet issue


    kirtesh

    Tuesday, December 17, 2013 5:10 AM
  • It is not related to Timesheet but they are using My task to send update directly without importing Timesheet and this is happening for all projects.

    -Piyusha

    Tuesday, December 17, 2013 5:13 AM
  • Oct 13 CU is applied on our server and still the issue persists.

    -Any other solution/troubleshooting which I can follow?

    Regards,

    Piyusha

    Tuesday, December 17, 2013 8:01 AM
  • Have you added Your PWA site in trusted Zone in IE try to view in compatibility mode in IE

    kirtesh

    Tuesday, December 17, 2013 8:13 AM
  • Change the period and check if it is working. May be it is task specific from any project

    kirtesh

    Tuesday, December 17, 2013 8:14 AM
  • Yes , it is added in Trusted Zone.
    Tuesday, December 17, 2013 8:17 AM
  • Hi Kirtesh,

    As already mentioned , we have tried over many periods and different projects.Issue exists for all.

    -Piyusha

    Tuesday, December 17, 2013 8:18 AM
  • this Is for one user or many users are facing same issue.

    kirtesh

    Tuesday, December 17, 2013 8:26 AM
  • All Users.

    -Piyusha

    Tuesday, December 17, 2013 8:28 AM
  • Have you done any kind of customization for my task page?

    kirtesh

    Tuesday, December 17, 2013 9:24 AM
  • Not Kirtesh....No customizations.

    Dale,any suggestions?

    Tuesday, December 17, 2013 9:26 AM
  • I am trying to reproduce the issue but still not able to do it.

    You check in any other browser.

     Which version of IE your organization is using.

    try to download IE 10 then  and  check it. If still face issue means while create ticket with MS .


    kirtesh

    Tuesday, December 17, 2013 10:09 AM
  • Thanks Kirtesh for involving yourself in the issue.

    I tried on CHROME but results are the same.And when I try to change the view , it throws :Unknown Error has occurred"

    -Piyusha

    Tuesday, December 17, 2013 10:43 AM
  • I think One of your project task is got corrupted i mean to say either assignment_UID or Task_Uid is missing that is why issue is occurring.

    Same kind of issue i have faced in recent time for timehseet issue.

    If any of task is corrupted in task grid it will not allow grid to load. Could you please check in the Database for current period for user who is facing issue. Might be resource has been filled the actual for a specific assignment but that assignment is now got deleted from project

    also tell us if you using SEM.

     

    kirtesh


    • Edited by Kirteshtiw Tuesday, December 17, 2013 10:53 AM
    Tuesday, December 17, 2013 10:52 AM
  • Kirtesh,

    I am trying on a brand new project and error is thrown for me as well.

    I have the script to check for corrupted task in MS 2007 but not for 2013.

    also what  is SEM ?

    Tuesday, December 17, 2013 11:03 AM
  • SEM is single entry mode.

    You mean to say you have created new project  assigned task of that project to you no other task is assigned to you still you are facing the issue.

    Run that script it may work.


    RUN below queries

    Query to identify projects in Publish but not in Draft

    USE ProjectServer_Published 
    SELECT PubProj.PROJ_UID, PubProj.PROJ_NAME AS Published, DrafProj.PROJ_NAME AS Draft 
        FROM ProjectServer_Published.dbo.MSP_PROJECTS AS PubProj 
        LEFT OUTER JOIN ProjectServer_Draft.dbo.MSP_PROJECTS AS DrafProj ON PubProj.PROJ_UID = DrafProj.PROJ_UID 
        WHERE DrafProj.PROJ_NAME IS NULL


    Query to identify timesheets with lines against projects not in draft

    USE ProjectServer_Published

    SELECT MSP_TIMESHEETS.TS_UID, MSP_TIMESHEETS.CREATED_DATE, MSP_TIMESHEETS.TS_CACHED_RES_NAME, MSP_TIMESHEETS.TS_COMMENTS 
        ,RepTSP.PeriodName, RepTSP.StartDate, RepTSP.EndDate 
        ,MSP_TIMESHEET_LINES.PROJ_UID, MSP_TIMESHEET_LINES.TS_LINE_CACHED_PROJ_NAME 
        FROM MSP_TIMESHEETS 
        INNER JOIN MSP_TIMESHEET_LINES ON MSP_TIMESHEETS.TS_UID = MSP_TIMESHEET_LINES.TS_UID 
        INNER JOIN ProjectServer_Reporting.dbo.MSP_TimesheetPeriod AS RepTSP ON MSP_TIMESHEETS.WPRD_UID = RepTSP.PeriodUID 
        WHERE 
        MSP_TIMESHEET_LINES.PROJ_UID IN (SELECT PubProj.PROJ_UID 
            FROM ProjectServer_Published.dbo.MSP_PROJECTS AS PubProj 
            LEFT OUTER JOIN ProjectServer_Draft.dbo.MSP_PROJECTS AS DrafProj ON PubProj.PROJ_UID = DrafProj.PROJ_UID 
            WHERE DrafProj.PROJ_NAME IS NULL) 
        ORDER BY CREATED_DATE

    which version Of internet explorer you are using. try with internet explorer 10.


    kirtesh

    Tuesday, December 17, 2013 11:23 AM
  • Hi,
    First query returned one test project(This test project is NOT the one I am working on) and eglobal.
    second query returned one line for the same project.

    On IE 10, it throws the same error.

    I am using IE 9.

    No, we are not using SEM.


    Wednesday, December 18, 2013 4:23 AM
  • Which currency you are using the project server. Please make it Dollar.

    Check if farm admin or set up admin is facing the same pbm.


    kirtesh

    Wednesday, December 18, 2013 5:37 AM
  • That was the first point I checked , its $

    We dont have farmadmin rights.

    Wednesday, December 18, 2013 5:58 AM
  • Please let us know about your environment ?

    kirtesh

    Wednesday, December 18, 2013 8:12 AM
  • when we click on preview tab then new page come up in url you will see  "StatusApprovalsPreview.aspx" it also append acceptUIDs=GUID.

    URL will look like http://epm/pwa/StatusApprovalsPreview.aspx?acceptUIDs=GUID

    Could you please check in the url whether it is coming or not then try to open this page from 15 hive then check you may get some thing .

    Do you have any load balancer in your environment I have seen some time load balancer is preventing to load some of the page and ribbon.


    kirtesh

    Wednesday, December 18, 2013 10:38 AM
  • Ok will check and let u know;

    We have F5 for load balancing the request.

    Wednesday, December 18, 2013 10:41 AM