none
Unable to drop table RRS feed

  • Question

  • Hi,

    Greetings!

    We are  using Azure sqldw environment, we can able to dml like insert,delete  but where as drop and alter is keep on running and unable to drop table have seen all active transactions and blocking nothing i came across,tried by deleting indexes first but still not working facing the same and tried to drop statistics but that option is faded-out.

    Environment is Azure Sqldw and i am DBA i have full rights on it. 

    Tuesday, June 11, 2019 8:26 AM

All replies

  • Hi,

    Thanks for your feedback. Could you please try to find the processes running. That might give you insight of processing causing this delay.

    You can run below command to give u insight for the same.

    USE MASTER

    GO

    Select * from sysprocesses where dbid in (SELECT dbid from sysdatabases where name='THEDATABASENAME')

    GO

    Hope this will help you in more insight and in resolving the issue of forver running drop command.

    Tuesday, June 11, 2019 9:16 AM
    Moderator
  • Hi,

    I think you have enough privileges like ddladmin.

    Kill the transactions following below steps.

    Get the list of active transactions

    exec sp_who2

    Kill the active transactions

    KILL sessionid;  
    

    Now, try dropping the table. In case of active transactions on the tables - they will be under explicit lock which would not allow drop operations.

    Thanks

    Naveen Thummalapenta

    MCSA | MCP


    Naveen Thummlapenta

    Tuesday, June 11, 2019 10:22 AM
  • Hi

    I am writing to follow up this thread with you. Have you solved your issue? If you have solved your issue, please  mark helpful replies as answers. By doing so, it will benefit all community members who are having this similar issue. 

    Thank you


    If this post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Thursday, September 12, 2019 4:40 AM