none
TLS 1.0, 1.1 and 1.2 disappearing from IE 11 RRS feed

  • Question

  •   I am a non-prolific, retired home windows user.  I have a PC running windows 7 home premium and IE 11.  A few months ago I went to check my email at Yahoo from my home page and the Yahoo page would NOT open.  I went to the advanced properties of IE and discovered that 3 boxes (tls 1.0, 1.1 and 1.2 were NO LONGER checked.  I checked them, hit apply and OK and the Yahoo page worked fine.  Now, every single day when I open IE those same 3 boxes are UNCHECKED.  Once I check them, if I let my PC sit idle for awhile the settings/boxes become UNCHECKED.  I do not have a clue as to what is causing this problem nor how to fix it.  I contacted Microsoft On-line support and the tech took over my PC for awhile to see if she could find the problem.  She never said if she found any problem all she said was that I would HAVE to purchase the YEARLY subscription to their support services.  As I said I am retired and on a fixed income and cannot afford the large fee to solve just ONE SINGLE PROBLEM by them.  
    I posted this problem yesterday and Scott Sander suggested I open a new problem here as the area I originally posted it was already listed as resolved and Scott indicated I probably would not get any help there.  I've read some of the answers there and (like I said) I'm a novice and was lost reading them (EXAMPLE: went into REGEDIT but could NOT find the HKEY that was listed in one of the responses).  Appreciate any and all help I can get.  Thanks all.

    Joe Bosko

    Wednesday, March 4, 2015 12:49 AM

All replies

  • Hi,

    I use a tool and capture the registry changes of the TLS protocols in IE, the associated registry entry is

    HKU\user sid\Software\Microsoft\Windows\CurrentVersion\Internet Settings\SecureProtocals, set its value to AA0, after that press F5 to refresh registry, then reopen IE, check the TLS settings under Advanced tab. This can force the settings via regstry.

    If the options are still changed automatically, then I recommend you run a virus scanm check if the system\IE is infected with some virus to ensure the security.

    Or test IE in no add-ons mode, run iexplore.exe -extoff


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, March 5, 2015 6:14 AM
    Moderator
  • Hi Yolanda,

    Thanks for responding to my forum problem but I am still having problems.  I opened REGEDIT and tried doing a FIND on the HK line you provided as well as Internet Settings but could NOT come up with anything in REGEDIT that finds either of those items.  Do you use REGEDIT to find the string?  Your screen shot appears to be the same program but perhaps I am using the wrong thing to find the AA0 entry you indicated.  Can you advise?

    Joe

    Thursday, March 5, 2015 6:37 PM
  • Hi,

    What do you mean by "FIND on the HK line you provided as well as Internet Settings but could NOT come up with anything in REGEDIT that finds either of those items."? I find the registry entry just by running Regedit.exe, then locate to:

    HKU\user sid\Software\Microsoft\Windows\CurrentVersion\Internet Settings\SecureProtocals

    Can you post a snapshot of yours here so I can know what happened.

    If you're unable to find the registry entry "SecureProtocals" in your regsitry, you can mamually create one, please backup your resgistry first before editing it.

    You can also check this in another user account.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, March 9, 2015 2:32 AM
    Moderator
  • Yolanda,

    this is the closest I could find in my registry when looking for Secure Protocols.  Don't have the same settings as you show in your screen shot.

    Joe

    Computer/HKEY_USERS/S-1-5-21-4026464731-3118496964-270555542-1001/Software/Microsoft/Windows/CurrentVersion/InternetSettings/Protocols

    Mailto

    Monday, March 9, 2015 4:38 PM
  • Hi,

    I recommend you manually create the registry value (DWORD 32-bit Value), then set its value to "aa0".

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, March 11, 2015 1:40 AM
    Moderator
  • Can't find DWORD in registry.  Can you respond direct to acrubray at gvtc dot com ?
    Wednesday, March 11, 2015 4:36 PM
  • Hi,

    When you to navigate to InternetSettings, in the right panel, right click the blank area>New>DWORD(32-bit)value, as snapshot below, the set the name as SecureProtocals, value aa0.

    If you're unabel to find the DWORD in under New, then I'm afraid that you need to create a new user account to test the issue.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, March 12, 2015 1:27 AM
    Moderator
  • Yolanda,

    Found Internet settings and changed secure protocols from aa8 to aa0.  will quit IE and restart my computer to see if that fixes the problem.

    Joe


    Joe Bosko

    Wednesday, March 18, 2015 4:41 PM
  • Made the suggested change to the registry under Internet Options and re-booted PC.  Initially the changes seemed to work but things are back to the same as before.  Those 3 TSL boxes still clear themselves if I leave the computer IE open or just click on a link in an email message.  Any other suggestions, this is very frustrating?  Thought someone (moderator) else would respond with suggestions to fix this problem but was wrong so far.

    Joe


    Joe Bosko

    Wednesday, March 18, 2015 11:59 PM
  • Hi,

    What is the result if you made the changes under registry entry HKCU\Software/Microsoft/Windows/CurrentVersion/InternetSettings/SecureProtocols ?

    And have you tried to scan your system with anti-virus program to eliminate some virus infection?



    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, March 19, 2015 8:47 AM
    Moderator
  • Hi Yolanda

    My registry settings are:

    Computer/HKEY_USERS/S-1-5-21-4026464731-3118496964-270555542-1001/Software/Microsoft/Windows/CurrentVersion/InternetSettings/SecureProtocols/0x00000aa0(2720)

    I just changed it AGAIN to the above as it automatically changed back to aa8

    Joe


    Joe Bosko

    Friday, March 20, 2015 3:29 PM
  • Hi,

    Have you run virus scan to eliminate virus infection? Or just reset IE to default settings and check if it can make any difference (Tools\Internet Options\Advanced\Reset).


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, March 24, 2015 1:41 AM
    Moderator
  • Yolanda,

    Please accept my sincere thanks for all the help you have been offering.  First, today I again ran Microsoft Security Essentials Virus Scan - the full scan this time which ran for over 6 hours and found absolutely nothing.  Second, I have NOT yet reset my IE settings but intend to try that next since nothing else has worked so far.  That SecurityProtocols setting seems to keep changing from aa0 to aa8 no matter how many times I change it.  I will change the IE settings back to default and see if that works.  I will keep in touch.

    Joe


    Joe Bosko

    Tuesday, March 24, 2015 11:55 PM
  • Yesterday I ran a complete (7 hr) virus scan and it found nothing wrong.  I then reset IE to the default settings and shut down the computer.  Today when I connected to IE the same 3 boxes for TLS 1.0, 1.1 and 1.2 were BLANK.  I checked those boxes again, hit the Apply button and then the OK button but the 3 boxes AGAIN cleared themselves later in the day.  Nothing seems to work.

    Joe


    Joe Bosko

    Wednesday, March 25, 2015 11:52 PM
  • PLEASE HELP THIS IS SOOO FRUSTRATING.  Am still having the SAME problems with TLS1.01.1&1.2 no matter what I try.  Those 3 settings keep disappearing.  Have run Virus programs and found NOTHING.  Appears no one else can duplicate this problem and MICROSOFT refuses to help unless I pay their outrageous fees to solve ONE SINGLE PROBLEM.  Again I am an inexperienced, frustrated IE user and about to THROW this PC out the window and get an APPLE.  Would appreciate any and all help that can be provided.  Please view previous threads to see what I tried thanks to Yolanda.

    Joe Bosko

    Thursday, September 3, 2015 12:06 AM