locked
Windows 10 Connector for Windows Storage Server Essentials 2012 R2 missing! RRS feed

Answers

All replies

  • Sunday, August 30, 2015 11:16 AM
  • Earth to Eve......Come in please

    There is no difference between the connector for server 2012R2 Essentials and Server 2012R with the role.  Windows 10 requires a download at this time.  It will install a folder/group of file.  Connect, Launchpad, and Dashboard.  After you install the download run the connector from installed programs to connect


    Grey

    Monday, August 31, 2015 11:32 AM
  • What he said.
    Monday, August 31, 2015 11:18 PM
  • Related question - I have Windows Server 2012 Essentials - not the R2.  I'm having trouble with the Windows 10 Connector but just realized it may because this version is only intended for R2.  Can anyone verify?  And if so, does Microsoft plan to include a fix for regular non-R2 versions?

    Matt M

    Thursday, September 17, 2015 1:03 PM
  • http://server/connect should work on essentials 2012

    what problem are you encountering?


    Grey

    Thursday, September 17, 2015 1:10 PM
  • Grey - thanks for the reply.  The connector doesn't find the server (I have 2 Windows 7 machines that work just fine).  When I search by IP (using the servers IP), I get the following message:  "This Version of the Client Connector software is not compatible with the version of Windows Server you are trying to connect to"

    This link Microsoft Chart that shows client OS compatibility with Server 2012 Essentials sort of addresses my issue as my non R2 version doesn't seem to have a solution:  Microsoft Client Compatibility Chart

    In all the hours I've been researching this, I think most failures are due to this "discovery" - people like me who installed 2012 Essentials early on largely didn't see the need to upgrade to R2 and just forgot they're on an older version

    My story is fairly common I think - I'm just a home user who was on Windows Home Server and implemented Server 2012 Essentials as a home backup solution - and just never worried about R2 because it didn't really do anything for my simple needs.

    Thoughts?


    Matt M

    Thursday, September 17, 2015 1:18 PM
  • The chart you link to says working no problems

    Did you install the R2 version from the download link by mistake?


    Grey

    Thursday, September 17, 2015 1:28 PM
  • To be honest, it never occurred to me that I wasn't running R2 (an upgrade decision I decided not to pursue over 2 years ago) and I forgot.  So yes - I did install.  But with hindsight, I probably would have tried it anyway just to see if it would work.  After reading the differences between "normal" 2012 Essentials and the R2 new features, it didn't seem different enough to make something as simple as a connector tool not work.  But, I guess I was wrong.

    Any ideas?


    Matt M

    Thursday, September 17, 2015 2:04 PM
  • Look in installed updates and see if you can find it to remove it

    Then delete/rename the hidden folder C:\ProgramData\Microsoft\Windows Server

    same for C:\Program Files\Windows Server

    Delete reg key hklm\software\software\Microsoft\windows server

    Set DNS to the ip of the server

    reboot

    surf to servername/connect and try again


    Grey

    Thursday, September 17, 2015 2:12 PM
  • Grey - I'll try that this evening.  But once I remove it / fix the key, what Windows 10 program do I use to find the server?  Or, do I just do the http://myhomeserver/connect from a browser?

    Matt M

    Thursday, September 17, 2015 6:27 PM
  • yes,  just do the http://myhomeserver/connect from a browser

    setting DNS on the client to the server helps it join/find the server/domain.  I f you do not want to join the domain.  I guess that works for non R2

    https://tinkertry.com/how-to-make-windows-server-2012-r2-essentials-client-connector-install-behave-just-like-windows-home-server


    Grey

    Thursday, September 17, 2015 6:43 PM
  • Grey - that's not working either.  There are also files in c:\windows\system32\Essentials and I couldn't delete all the keys either.

    I think there must be something to this R2 thing - if it was designed to work this way I can't imagine I'd have to hack this given that Windows 10 Professional will now be a very common OS for Server 2012.  I can't even imagine what's that much difference between 7 / 8 / 8.1 and 10.0 to cause this issue.

    Thanks for your help - I'm hoping an update in October might fix this - it was referenced at the bottom of this TechNet Posting.

    Thanks anyway.


    Matt M

    Thursday, September 17, 2015 10:25 PM
  • You are getting the version mismatch because you manually applied the R2 connector.  The update in the fall will simply make R2 work instead of having to do the download.  It will not help you.

    Grey

    Thursday, September 17, 2015 10:33 PM
  • Ever since upgrading to windows 10 i haven´t been able to connect to my server running windows server 2012 (not r2). I hoped that the november update would fix the issue but instead my connector software was removed completely. I tried to use the https://MYSERVER/Connect but I am only given the options to download software for windows 7 or windows 8. I checked my server for updates but it is fully updated. What to do?
    Friday, November 27, 2015 8:24 AM
  • The connector at servername/connect also works for Win10

    Grey

    Friday, November 27, 2015 11:54 AM