locked
IMAP Network Problem RRS feed

  • Question

  • An XP Pro SP3 Lenovo Laptop with both Outlook 2007 and Thunderbird. Over the last 10 days neither can connect to G-Mails IMAP service. I can connect to the same account from O/L 2010 with Win7 on another box so I suspect that G-Mails IMAP service is working. Neither can I connect to a local IMAP server in the LAN here from the faulty PC.

    Using wireshark to capture packets on the wire I can see the beginning of the IMAP dialogue and the SSL exchange taking place and then the connection just stops talking to the IMAP server. I've reset the SSL state in Internet Options, but if it was that then T'bird would still work. Repaired / reinstalled Outlook.

    There's no nasty 3rd party firewall, just the Windows one. The AV on there is E-Set.

    I'm stumped. I feel a wipe/reinstall coming on....The machine isn't really up to Win 7 sadly...

    Any ideas before I go there

    Thanks

    Ken

    Tuesday, February 4, 2014 9:42 PM

Answers

  • Hi,

    On advice from E-Set support I upgraded the clients PC to V7 of E-Set and thus far the problem seems to have been cleared.

    Thanks

    Ken

    • Marked as answer by kens999 Tuesday, February 11, 2014 11:01 PM
    Tuesday, February 11, 2014 11:01 PM

All replies

  • I am having the same issue (or some variant). My Outlook 2010 on a Win7 Home Premium 64bit laptop was working no problem until 27 Jan 2014, and then three IMAP accounts (1 gmail, 1 gmail business, 1 unrelated personal domain) stopped receiving emails. Some interesting data points:

    1 - I can access all three of these accounts and receive/send email via the web so it doesn't appear that there is an issue with the accounts themselves
    2 - Outbound SMTP emails go out using Outlook without any issues
    3 - It appears that only IMAP connections inbound are impacted as I have a MAPI Hotmail account that receives/sends without issue
    4 - I have Outlook 2010 on another workstation (Win7 Ultimate 64bit)and it connects no problem to the email addresses in question, meaning that there is a problem with the laptop specifically and not a more general issue across multiple machines
    5 - I have installed Thunderbird on the laptop and cannot connect to the email accounts in question
    6 - I have disabled antivirus software (ESET) without any change

    I mainly get time out errors or 'cannot connect to server' errors

    The last bit leads me to believe that it is a program/Windows issue limited to the laptop. There were not any Windows Updates or program installs that I am aware of around that time. I used it in the morning, boarded a flight, got off the flight and it was no longer working.

    Any known issues with IMAP ports and Win7 or some strange variant...?


    Andrew.
    Thursday, February 6, 2014 1:55 AM
  • Hi Andrew,

    Your experience is almost identical. Except Win7&O/L2010. I can telnet from the faulty machine to the IMAP server on port 993 and it connects. Its not possible to test much further with Telnet as the link switches to SSL at that point. But at a TCP/IP level the connection is there. That does not discount some misbehaviour related to the SSL negotiation.

    Similarly the outgoing SMTP is still working

    Interestingly this laptop crossed the Atlantic in about the same timeframe. You also have E-Set. Although that is highly reputable I'll deinstall it as see what happens.

    Thanks

    Ken

    Thursday, February 6, 2014 3:35 PM
  • Ken -

    I will give ESET removal a shot; but I should note that the workstation that currently has no problems also has ESET installed....more soon.

    Andrew.

    Thursday, February 6, 2014 4:53 PM
  • I should make the following note:

    I can connect through IMAP to my server if it is *unencrypted* which means that there is either an SSL issue or a Port issue. More investigations to come....

    Andrew.

    Thursday, February 6, 2014 5:22 PM
  • Interesting. My thoughts were on the SSL area too. But if that was hosed in O/L it does not explain why Thunderbird also fails, as I believe it has its own certificate store and SSL processing. My thinking then turned to something that both T'bird and O/L depend on such as the TCP/IP stack and the possibility of E-Set getting in the way.

    Win 7 does not have Telnet by default but you can add it from "Turn Windows Features on & off" on the Programs part of Control Panel.

    Can you Telnet to imap.gmail.com on port 993? ( telnet imap.gmail.com 993)

    My client went away with the machine to get on with some other work, but I will get it back tomorrow, potentially for a wipe and reinstall.

    Thanks

    Ken

    Thursday, February 6, 2014 5:38 PM
  • I cannot Telnet into gmail on 993 or on any other port that I tried (23, 143, 993). 

    I was able to telnet into my private domain on 23 but not on 993. 

    Andrew.

    Thursday, February 6, 2014 9:14 PM
  • Hi Andrew,

    That's odd. You should be able to get to port 993 on imap.gmail.com, unless your ISP or something else is blocking it.

    I get this:-

    telnet imap.gmail.com 993
    Trying 173.194.66.108...
    Connected to imap.gmail.com.
    Escape character is '^]'.

    What does "nslookup imap.gmail.com" produce?

    :-) Ken

    Thursday, February 6, 2014 10:39 PM
  • And I should have mentioned. Take a look at this page

    https://accounts.google.com/UnlockCaptcha

    For some reason G-Mail blocks access sometimes.

    :-) Ken

    Thursday, February 6, 2014 10:42 PM
  • Ken -

    I have the application specific passwords setup, so I don't think it is that. And the fact that I cannot make an encrypted SSL connection to my non-google IMAP leads me to believe it is not a google issue.

    When I try to telnet in to imap.gmail.com 993 it just hangs/times out. I don't get any error message; it just never proceeds and I have left it for 10-15 mins without anything happening. 

    When I try to connect to the IP address directly I receive this error message:

    C:\Users\Rowat>telnet 173.194.66.108
    Connecting To 173.194.66.108...Could not open connection to the host, on port 23
    : Connect failed "

    When I do an nslookup I get this error:

    "

    C:\Users\Rowat>nslookup imap.gmail.com
    DNS request timed out.
        timeout was 2 seconds.
    Server:  UnKnown
    Address:  fe80::1

    DNS request timed out.
        timeout was 2 seconds.
    DNS request timed out.
        timeout was 2 seconds.
    DNS request timed out.
        timeout was 2 seconds.
    DNS request timed out.
        timeout was 2 seconds.
    *** Request to UnKnown timed-out

    C:\Users\Rowat>"

    Something DNS related perhaps...? All very strange.

    Andrew.

    Thursday, February 6, 2014 11:25 PM
  • Ken -

    I took your 'we both have ESET Nod32 anti-virus' program to heart and started sniffing around a bit - particularly on recent posts (I limited my google search to the last month) and I think I have found a solution to the issue. I went into the advanced settings in ESET (hit F5 in the open console window) and then I navigated a few subcategories: Web and Email > Email Client Protection > IMAP, IMAPS and I turned off 'Enable IMAP checking'. This seems to have solved the issue for me.

    I had initially discounted ESET as the problem because when I deactivated protection + turned off Windows firewall there was no change. So it appears that deactivating coverage with ESET does NOT in fact turn everything off. Frustrating (obviously) as part of the trouble-shooting process if one of the actions that you are taking doesn't actually do what it says that it does.

    Let me know if this works for you too.

    I suspect that the other commonality in our story (the plane trip) means that ESET did some sort of auto-update when we landed and proceeded to FUBAR everything.

    Andrew.

    Friday, February 7, 2014 3:49 PM
  • Hi Andrew,

    I've just had my client's PC in the office and the problem is E-Set. More details below.

    The NSLOOKUP failing needs to be fixed before you investigate your issue further. Check the network settings on your machine, especially the DNS server address. Compare it to your working Win 7 machine. It is most likely to be set to get the address from your DHCP server but you may have a specific DNS server in your network.

    In the office here we have a DHCP server that issues addresses to the network. It gives 172.16.0.1 as the default gateway and 172.16.0.2 as the DNS server on our office LAN. ipconfig /all should show you the address that your PC is using for DNS. You should be able to ping that address and this telnet command should connect

    telnet {address of DNS machine} 53

    (Don't forget the 53.)

    Once you have fixed that test it by looking up some addresses with nslookup. Such as

    nslookup www.microsoft.com

    nslookup www.google.com

    nslookup www.cnn.com

    They should all produce IP addresses in response and not time out.

    Then try nslookup imap.gmail.com

    That should work too.

    Then type

    telnet imap.gmail.com 993

    Don't forget the '993'. Telnet will use port 23 unless you tell it which port to use. GMail's IMAP service is on port 993

    The telnet to gmail should connect.

    If it gets this far then the next step is to tackle E-Set. Taking the hint from what you said above, I switched all of E-Set's integration with Outlook off and its scanning of IMAP messages. That fixed my clients PC.

    But that's a bug/anomaly in E-Set. We are an E-Set reseller and I will file a bug report with their team.

    Hope that helps

    Ken

    Friday, February 7, 2014 4:54 PM
  • Thanks for your attentiveness to this thread Ken - I will putter about and try to get everything back in working order, but for the moment I am simply happy that emails are flowing freely for the moment. Thanks again,

    Andrew.

    Sunday, February 9, 2014 7:57 PM
  • Hi,

    On advice from E-Set support I upgraded the clients PC to V7 of E-Set and thus far the problem seems to have been cleared.

    Thanks

    Ken

    • Marked as answer by kens999 Tuesday, February 11, 2014 11:01 PM
    Tuesday, February 11, 2014 11:01 PM