none
Error when migrating datasource that spans multiple disks using MigrateDatasourceDataFromDPM.ps1 RRS feed

  • Question

  • Hello

    We've added a newer/bigger array to our DPM pool with the plan to migrate all datasources from the old array onto the new array and decommission the old one.

    Prior to starting the migration, our old array was at capacity, and one of our protected group members had run out of space. Once we added the new array to the disk pool, we allocated more space to the protected group member to ensure backups would complete. This resulted in that particular member (datasource) being spanned on both the old disk and the new disk.

    Next, we started migrating all our datasources to the new disk in DPM, using this handy GUI script/tool that utilizes MigrateDatasourceDataFromDPM.ps1:
    https://gallery.technet.microsoft.com/scriptcenter/Migrate-DPM-Disk-or-dea8d4e9#content

    This worked great for all of our protected datasources until we got to the one that spanned both old and new disk. When we tried migrating that one, we got the below error:

    Set-ProtectionGroup : The operation failed due to a virtual disk service error (ID: 360)
    Retry the operation.
    At C:\Program Files\Microsoft System Center 2012 R2\DPM\DPM\bin\MigrateDatasourceDataFromDPM.ps1:129 char:4
    +             Set-ProtectionGroup $mpg
    +             ~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Set-DPMProtectionGroup], DlsException
        + FullyQualifiedErrorId : VdsError,Microsoft.Internal.EnterpriseStorage.Dls.UI.Cmdlet.ProtectionCmdLets.CommitProtectionGroup

    What would be our course of action now to migrate the spanned datasource completely off the old disk to the new disk? Would we need to disable protection and delete the data?

    Friday, August 11, 2017 6:00 PM