locked
Chinese appear as gibberish in programs... RRS feed

  • Question

  • Hi there,

    Before we get started, I would like to note the following. I have 4 different operating systems and they all behave differently. I have:

    Windows 2008 R2 x64
    Windows 7 Pro x64
    Windows Vista Business x86
    Windows XP x86

    All machines have their Region and Language, Language for non-Unicode programs set to Chinese (Simplified, PRC) as their system locale. Two of the operating systems are perfectly fine while the other two have gibberish as shown in the screenshot.

    Windows 2008 R2 and Windows XP are fine.
    Windows 7 and Vista are the trouble ones.

    Only the stuff from the drop down menu are appearing in gibberish when there is chinese. However, after selecting the item, all chinese appear to be fine once selected! It might not seem like a big issue but it makes choosing the item really hard when the employee cannot read english and they have to guess their way through an item list with 3000 items...

    I did some search but wasn't able to find the solution... Any help would be appreciated.
    Monday, August 30, 2010 6:19 PM

Answers

  • Hi Jimmy, please to reset the Region and Language to English first, and then set it to Chinese(Simplified, PRC) again. Include “Formats” “Location” “Keyboards and other input languages” and “Language for non-Unicode programs”.  After changing the non-Unicode setting, you needs to restart the machine to take effect.    

     

    If the same issue appears, please try to change the key of registry:

    HKEY_CURRENT_USER\Control Panel\International
    change the value data of "Locale"="00000409" to "Locale"="00000804"

     

    Note: You’d better backup the registry before you change it.

     

    Hope it helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Jimmy.Zi.Yang Wednesday, September 1, 2010 4:16 PM
    Wednesday, September 1, 2010 5:21 AM

All replies

  • Hi Jimmy, please to reset the Region and Language to English first, and then set it to Chinese(Simplified, PRC) again. Include “Formats” “Location” “Keyboards and other input languages” and “Language for non-Unicode programs”.  After changing the non-Unicode setting, you needs to restart the machine to take effect.    

     

    If the same issue appears, please try to change the key of registry:

    HKEY_CURRENT_USER\Control Panel\International
    change the value data of "Locale"="00000409" to "Locale"="00000804"

     

    Note: You’d better backup the registry before you change it.

     

    Hope it helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Jimmy.Zi.Yang Wednesday, September 1, 2010 4:16 PM
    Wednesday, September 1, 2010 5:21 AM
  • Hi Jimmy, please to reset the Region and Language to English first, and then set it to Chinese(Simplified, PRC) again. Include “Formats” “Location” “Keyboards and other input languages” and “Language for non-Unicode programs”.  After changing the non-Unicode setting, you needs to restart the machine to take effect.    

     

    If the same issue appears, please try to change the key of registry:

    HKEY_CURRENT_USER\Control Panel\International
    change the value data of "Locale"="00000409" to "Locale"="00000804"

     

    Note: You’d better backup the registry before you change it.

     

    Hope it helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thank you very much for your response. In the first suggestion, I have changed each setting one at a time see which one affects the program and have determined the "Formats" is the one that can solve the problem.

     

    I also went ahead and tried the second suggestion by changing the registry without touching other settings mentioned in suggestion one. The registry setting also worked but I am a little iffy on what things it changed to my system. Leo, could you explain by changing 409 to 804, what other changes are made to the system? I just wanted to learn more :D Thank you very much Leo for your solutions, both have worked!

     

    Jimmy

    Wednesday, September 1, 2010 4:20 PM