locked
Missing Web parts and Site definition in Migration of sharepoint from 2007 to 2010 RRS feed

  • Question

  • I have a project in which we are migrating a MOSS 2007 to MOSS 2010 solution from one physical location to another.  Normally, I would just use the source code and re-deploy using Visual Studio, but for lack of documentation and original source code, we've run into the question above.  I'm having a hard time finding information on something like this, so I'm starting to think it's not possible.  Your help would be greatly appreciated and thanks in advance.
    Sunday, April 22, 2012 5:40 PM

All replies

  • You can copy the assemblies from the GAC on the MOSS2007 to  the 2010 server

    EmpowerIT (Australia) for all your CRM/SharePoint needs. http://mscrmblog.net
    Microsoft Certified Business Management Solutions Specialist
    Microsoft Certified CRM Developer

    Sunday, April 22, 2012 10:05 PM
  • Hi,

    Thanks Ibrahim.

    Assemblies are missing in the GAC. I am getting Missing Web part error while using the below command

    Test-SPContentDatabase –Name Test -WebApplication 'URL of the site'

    And i have .webpart file only. please help me to solve this issue.


    Kousalyaa C

    Monday, April 23, 2012 4:32 AM
  • Hi,

    Have u got solution for this issue. I am getting few webpart missing, site definition missing, feature missing errors even deploying all wsp files. please let me know if you know the solution which will very useful for me..


    Regards Inthiyaz


    Wednesday, September 12, 2012 10:57 AM
  • Hi  Inthiyaz,

    You can refer the below link to remove the web parts.

    http://get-spscripts.com/2011/08/diagnose-missingwebpart-and.html

    Remove the feature refer the link

    http://get-spscripts.com/2011/06/removing-features-from-content-database.html

    To add missing webparts

    stsadm -o addsolution -filename "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LendingLibrary.wsp"

    stsadm -o deploysolution -name " LendingLibrary.wsp" -url http://abcd.com -allowgacdeployment  -allowcaspolicies -immediate –force

    To install missing feature

    stsadm -o installfeature -filename Publishing\feature.xml

    stsadm -o activatefeature -filename PublishingWeb\feature.xml -url http://abcd.com -force

    Thanks  & Regards,

    Kousalyaa c


    Smile Always

    Wednesday, September 12, 2012 11:05 AM