locked
Sharepoint 2007 Training - STK\ Accounts not being created. RRS feed

  • Question

  • The "setup" creates the database fine, but the STK\ Accounts (STK\SharePointService, STK\mossadmin, STK\SearchService, STK\SSPService) as shown in the setup guide available here are not created or do not appear in the Logins for the SQL as shown.

    Far as I can tell the "setup" within the Sharepoint Administrative page for the Sharepoint Training uses the NT AUTHORITY\NETWORK SERVICE for the setup, and this account has sysadmin access enabled.

    This post had a user with the same problem, but they disappeared after their initial post. To answer those queries though:

    1. Possibly, this issue is permission related. Please check the related application pool permission in IIS, or create a new web application (in new application pool) and apply STK again.

    How do I do this? This is an SBS 2008 with a single Sharepoint (the built in one). I don't know a thing about Web Applications or IIS.

    2. If this is not the cause of the issue. Please download “Office SharePoint Server 2007 Training Farm Install Guide” article from the following link:

    Working from the guides already, though not the Farm Install guide as this isn't a Farm I'm installing on.

    Then, carefully review the section called “Configure Office SharePoint Training” and check if there is anything wrong during your configuration of STK. Please pay more attention on:

    a. You must select the specific Site Collection to which you will be installing the Microsoft Office SharePoint Server 2007 Training. (Page 8)

    This is SBS, there's no other location available, I select the "Change Site Collection" and there are no other sites than the built in Companyweb. (domainname:987).

    b. In the Configure Office SharePoint Training steps above, if you created a new database you will need to grant access to the database.  (Page 10)

    The text below this then goes onto the process of giving the appropriate permissions to the STK Accounts, but as if they were already created or existed. This is the problem, at this step the accounts do no exist under the SQL, Security, Logins to give the permissions to. The installed obviously has permissions as it setup a new Database! So why are these accounts not there?!?! If the "installer" cannot set them up, why does the guide assume they exist or are created???

    c. You can create an Office SharePoint Server 2007 Training for any site collection that has the Office SharePoint Server 2007 Training configured. (Page 13)

    This is the next section that should be completed AFTER the database is setup. If I follow with these steps I get "The language is not supported on the server". Again someone has posted on the Sharepoint Blog here with the same problem but with no response. If it helps I'm in Australia, so the language throughout the OS should be English (Australia).

     

    Interestingly above the text quoted in part c is this:

    Note: If the application pool account is a db-owner, you will not be able to add roles to the database. In this case, you need to change the application pool account for the site collection to a non-db-owner account.

    Seems to be the issue - But I have no idea what to do or where to go from here with this. Also the language issue seems to be something seperate, and a wall I will hit anyway, so what do I do about this issue?

     

    Tuesday, November 1, 2011 10:15 PM

All replies

  • Tried the steps here to change the owner of the DB from "NT AUTHORITY\NETWORK SERVICE" to my own account "DOMAINNAME\SAMURAI". Seemed to work, the owner says it's now the Samurai account, but gave the following error:

    Msg 15063, Level 16, State 1, Line 1
    The login already has an account under a different user name.
    Msg 15410, Level 11, State 1, Procedure sp_addrolemember, Line 75
    User or role 'DOMAINNAME\SAMURAI' does not exist in this database.

    At that point trying to log into the Operations or Application Management on the Central Administration page fails for the Samurai Account, so can't go and test if the "installer" can create those STK accounts it requires.

    So run that command again in the above link, substituting the account with "NT AUTHORITY\NETWORK SERVICE" gives the same error, except the last line is that username. Still cannot access the Central Administration Operations or Application Management now.

    Seriously how far do I have to go with this... Can I just get some support from Microsoft and get this working, I was meant to have it going tomorrow, that's long gone. We have like 15 customers with SBS servers who'd love to have some inbuilt training to be able to use this great product.

     


    Wednesday, November 2, 2011 6:57 AM