locked
batch file for mapping network computer error RRS feed

  • Question

  • there is a current batch file that i need to edit to map to another computer. the current batch file maps to one computer fine. i edited the batch file added the second computer there. but now i get a error for non local admin user "Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item" when i run the .bat file it works under my login becuase i have admin right. the orginal batch file worked fine for non admin user. I think the problem is the setting on the second computer i'm trying to map to. one more thing the orginal batch file that mapped to the first computer didn't have to enter user and password in the batch. but when i tried it with the new computer i had to put a user and password. not sure how the first computer is setup.

    Wednesday, February 20, 2013 7:02 PM

Answers

  • Try this.  Create a local computer account on the new computer to match your network ID.  For example if your network ID is abc123 then create a local user account on the new computer called abc123.  Then add that user to the local admin group on the new computer.  Try connecting now.

    Monday, March 4, 2013 5:02 PM

All replies

  • Looks to me like it is a permissions problem with the share you are tring to map. Check the SHARE permissions & NTFS permisisons on the shared folder to ensure that the user has the access rights to map and view the folder.


    8B17

    Thursday, February 21, 2013 10:25 AM
  • i think i got the SHARE permissions. how to do find the NTFS Permissions
    Thursday, February 21, 2013 2:59 PM
  • The NTFS permissions are in the folder options under a tab call security.

    It is normally best practice to give the "Everyone" group Full Access at the share level and then to use groups at the NTFS level to controll folder access.


    8B17

    Thursday, February 21, 2013 3:36 PM
  • i'll try that is there a way to make it so i don't have to enter user/password in the batch file. thats how the other computer is setup. thanks.
    Thursday, February 21, 2013 8:21 PM
  • The everyone group will allow anyone to connect to the share if it is a domain then only domain users can access but if it is a workgroup any networked computer will have access.


    8B17

    Friday, February 22, 2013 9:15 AM
  • Try this.  Create a local computer account on the new computer to match your network ID.  For example if your network ID is abc123 then create a local user account on the new computer called abc123.  Then add that user to the local admin group on the new computer.  Try connecting now.

    Monday, March 4, 2013 5:02 PM