none
DPM2019 RU1 - VHD could not be mounted error (ID40002) trying to apply MS fixes from Mike Jacquet post RRS feed

  • Question

  • From the post https://feedback.azure.com/forums/914488-system-center-data-protection-manager/suggestions/37713133-dpm-2019-error-40002-the-vhd-containing-the-rep?page=1&per_page=20

    and below I can't seem to do this part..

    c. Click Open Instance. Specify “__ProviderHostQuotaConfiguration=@”

    I get a Error box with

    Number 0x8004103a

    Facility: WMI

    Description: Invalid object path

    Any ideas ?

    Cheers,

    LM

    Mike Jacquet commented  ·  <time datetime="2020-04-21" pubdate="">April 21, 2020 20:13</time>  ·  Flag as inappropriate

    The error 4002 is caused by something outside of DPM control – DPM issues a mount command to windows to mount the replica .vhdx file then we register with WMI and wait for the volume to arrive, if it does not arrive after querying WMI 10 times then we fail with that error.

    Below are the steps we take with customers to help resolve the issue.

    1) We have seen WMI run out of memory if you have a lot of mount dismounts occurring at the same time. Increase the WMI MemoryPerHost setting by performing the below steps.

    a. Start “wbemtest” as administrator.
    b. Connect to the “root” namespace (not “root\default”, just “root”)
    c. Click Open Instance. Specify “__ProviderHostQuotaConfiguration=@”
    d. Select Local Only for easier readability. You will see the threshold values.
    e. Increase the MemoryPerHost 1073741824
    f. Save Property
    g. Save Object
    h. Click Exit.
    i. Reboot the DPM / MABS Server.

    2) If you are running DPM 2019 on Windows 2019 – install the latest Windows fix that contains additional ReFs file system fixes.

    3) Add these registry settings. Copy / paste into notepad and save as ReFs.reg (no .txt extension) - then right-click the ReFs.reg and click merge.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
    "RefsEnableLargeWorkingSetTrim"=dword:00000001
    "RefsNumberOfChunksToTrim"=dword:00000020
    "RefsDisableCachedPins"=dword:00000001
    "RefsProcessedDeleteQueueEntryCountThreshold"=dword:00000800
    "RefsEnableInlineTrim"=dword:00000001
    "RefsDisableLastAccessUpdate"=dword:00000001
    "RefsDisableAsyncDelete"=dword:00000000
    "RefsDisableDeleteNotification"=dword:00000001

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Disk]
    "TimeOutValue"=dword:00000078

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Configuration\DiskStorage]
    "DuplicateExtentBatchSizeinMB"=dword:000003e8

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Wbem\CIMOM]
    "High Threshold On Client Objects (B)"="60000000"
    "High Threshold On Events (B)"="60000000"

    4) If you are using mount points instead drive letters for the REFS volume make sure the mount points are on another volume other than C: volume, or better yet, use drive letters.

    5) Reduce the number of parallel mounts that DPM issue by adding the below registry – the default is 5, so try reducing it to 3 and see if that helps.

    Copy / paste below into notepad and save as ParallelMount.reg (no .txt extension) - then right-click the ParallelMount.reg and click merge.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Configuration\ParallelMountDismountSettings]
    "ParallelMountDismountOperationLimit"=dword:00000003


    • Edited by Lord Melch Tuesday, May 19, 2020 2:57 PM
    Tuesday, May 19, 2020 2:56 PM

All replies