none
IE9: Internet explorer has blocked this website from displaying content with security certificate errors RRS feed

  • Question

  • Every computer in our company is getting "Internet explorer has blocked this website from displaying content with security certificate errors" on almost every website we visit.  As previosuly suggested: I have tried running IE in safe mode and reset security settings; my clock is in sync with the PDC which is in turn with time.windows.com.

    Please advise as to why this error comes up when visiting almost every web site (for example, every article on Infoworld.com) on every computer in the domain?  We are running Win7 with SP1 / IE 9.08112.16421 with update version 9.0.27 (KB2953522).

    Monday, June 2, 2014 5:09 PM

All replies

  • Hi,

    Tools>Tracking Protection (turn it on)

    Tools>Internet Options>Security tab,

    click "Reset all zones to default"

    Trusted Sites icon>'Sites' button, remove the InfoWorld.com domain from your trusted sites list (or remove it from your GPO templates)

    (File>Properties to determine which Security zone you are mapping the domain to)... it should map to the Internet zone, you may also be mapping some social sites like FB to a zone... remove them from your trusted or intranet sites lists.

    test page http://www.infoworld.com/d/security/beware-the-next-circle-of-hell-unpatchable-systems-243397


    Rob^_^

    Monday, June 2, 2014 9:26 PM
  • Thanks Rob,

    I already tried what you suggested, and it was not successful.  Also, it is mapping to the Internet zone.  Keep in mind this is nearly every site I visit.  And not just my computer, it is every computer at our company.  We do not have a proxy server or any crazy filtering system.

    What could cause this to happen on every site?  I have seen other users complaining about this in the forums but no one at Microsoft has been able to offer a solution that works. 

    Please advise.

    Thanks

    Matt

    Tuesday, June 3, 2014 12:44 PM