locked
Column descriptions not being displayed in NewPost.aspx RRS feed

  • Question

  • Hi there,

    I have a sharepoint list that contains posts. I added some descriptions to some of the columns under Settings > List Settings.

    When I go to New > New Item I notice that the descriptions are not being displayed in the form. Any idea how I can get them to display? (I think we are using MOSS 2007?).

    Thanks.

    Tuesday, April 10, 2012 3:52 PM

Answers

  • Hi Amalaraja,

    Please go to C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\CONTROLTEMPLATES, Look at the file DefaultTemplates.ascx. See if the surrounding files all have the same timestamp. Check and see if the tag <SharePoint:FieldDescription runat="server"/> is in the file.

    The following code is about the description ,please check the code ,and ensure these in the file DefaultTemplates.ascx.

    <SharePoint:RenderingTemplate ID="CompositeField" runat="server">
    	<Template>
    		<TD nowrap="true" valign="top" width="190px" class="ms-formlabel"><H3 class="ms-standardheader"><SharePoint:FieldLabel runat="server"/></H3></TD>
    		<TD valign="top" class="ms-formbody" width="400px">
    		<!-- FieldName="<SharePoint:FieldProperty PropertyName="Title" runat="server"/>"
    			 FieldInternalName="<SharePoint:FieldProperty PropertyName="InternalName" runat="server"/>"
    			 FieldType="SPField<SharePoint:FieldProperty PropertyName="Type" runat="server"/>"
    		  -->
    			<SharePoint:FormField runat="server"/>
    			<SharePoint:FieldDescription runat="server"/>
    			<SharePoint:AppendOnlyHistory runat="server"/>
    		</TD>
    	</Template>
    </SharePoint:RenderingTemplate>

     

    Thanks,

    Jack

    Thursday, April 12, 2012 6:51 AM
    Moderator

All replies

  • Are you editing a content type?  If so, you may need to edit site columns rather than the entities under the List Options.

    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/

    Tuesday, April 10, 2012 4:33 PM
    Answerer
  • Sorry I am not sure what you mean with "content type"?

    I have a list that contains post entries, under Settings > List Settings and then under section Columns, I added text into the "Description" box for each column.

    But these descriptions are not showing up in the form that is used to create new posts in my list of posts.

    Wednesday, April 11, 2012 7:40 AM
  • Hi Amalaraja,

    Please go to C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\CONTROLTEMPLATES, Look at the file DefaultTemplates.ascx. See if the surrounding files all have the same timestamp. Check and see if the tag <SharePoint:FieldDescription runat="server"/> is in the file.

    The following code is about the description ,please check the code ,and ensure these in the file DefaultTemplates.ascx.

    <SharePoint:RenderingTemplate ID="CompositeField" runat="server">
    	<Template>
    		<TD nowrap="true" valign="top" width="190px" class="ms-formlabel"><H3 class="ms-standardheader"><SharePoint:FieldLabel runat="server"/></H3></TD>
    		<TD valign="top" class="ms-formbody" width="400px">
    		<!-- FieldName="<SharePoint:FieldProperty PropertyName="Title" runat="server"/>"
    			 FieldInternalName="<SharePoint:FieldProperty PropertyName="InternalName" runat="server"/>"
    			 FieldType="SPField<SharePoint:FieldProperty PropertyName="Type" runat="server"/>"
    		  -->
    			<SharePoint:FormField runat="server"/>
    			<SharePoint:FieldDescription runat="server"/>
    			<SharePoint:AppendOnlyHistory runat="server"/>
    		</TD>
    	</Template>
    </SharePoint:RenderingTemplate>

     

    Thanks,

    Jack

    Thursday, April 12, 2012 6:51 AM
    Moderator