locked
C++ 2012 package (11.0.50727) & error message during installation printer software RRS feed

  • Question

  • Hello to you all,

    I've recently bought a new laptop for my daughter (a HP Pavilion Touch Smart 11).

    When I try to install the software needed for installation for the printer (HP J6410) I get the following error.

    C:\Users\<username>\AppData\Local-\Temp\7zS46SD\Setup\de..

    Now, I've already tried pretty much about everything. Even a full factory recovery, installing all of the needed updates, after that upgrading to windows 8.1, installing of the updates for that OS version too, and then trying to install the software again.

    No succes, but the more I try, the more I'm convinced the problem might lay in the C++ 2012 redistributable package (version 11.0.50727). This is why.

    I've got more laptops here at home. The one I have for my own is a HP 15 Notebook and has Windows 8.1 installed on it as well. Now here's the funny thing.

    I managed to install the software on my own laptop (the HP 15, with an Intel processor) but no succes on the laptop for my daughter (the HP 11 TS, with an AMD processor).

    When I looked at the installed C++ packages I noticed that the laptop for my daugther has the C++ 2012 package installed, and my own doesn't. So that's why I think the problem must lay there. Also because on this page (http://www.freewarefiles.com/Microsoft-Visual-C-2012-Redistributable-x64_program_78882.html) it is said that it supports Windows 8 (which was pre-installed on the laptop for my daughter), but Windows 8.1 isn't mentioned.

    I would be very thankfull if someone could help me resolving this issue.

    (Note: I've tried to get help on the support forum of HP.  More information on how I resolved the issue, in May 2014, on my own laptop, and how it is related to C++, can be found here: http://h30434.www3.hp.com/t5/Printer-All-in-One-Install-Setup/Officet-J6410-won-t-install-under-Windows-8-1-64-bit/m-p/3935396#M142540 More information on what I've done so far on the laptop of my daughter this month, September 2014, can be found here: http://h30434.www3.hp.com/t5/Printer-All-in-One-Install-Setup/HP-OfficeJet-J6410-won-t-install-under-Windows-8-amp-Windows/m-p/4526450#M161696. Please do read them. I've already tried so many things, and I can't get the issue resolved. Even though I'm pretty sure I must be so close to resolving this issue.)

    I most thankfully await your response(s).

    Update (30-9-2014, 23:14):

    I've written above that I tried to re-install the printer. With the original CD, and also the software one can download on the HP site (OJ_AIO_J6400_Full_Win_WW_140_408-4.exe). Now, it seemed a good idea do uninstall the software.

    Yep, you guess it .. I made my problem worse.

    When I tried to uninstall it with the C:\Users\<username>\AppData\Local\Temp\7zS6A01\util\ccc\uninstall.exe I got the following message at reboot. It says you have to click OK to terminate the program, but it doesn't await your response. It's there, for a glimpse of a moment, and disappears. It said (in Dutch):

    'De instructie op .....xe01 verwijst naar geheugen op 0x00000000. Een lees- of schrijfbewerking op het geheugen is mislukt. read

    Klik op OK als u het programma wilt beëindigen'.

    It looks very similar to the error message here: http://fud.community.services.support.microsoft.com/Fud/FileDownloadHandler.ashx?fid=8d18c288-aeb4-41c0-983f-6798cfa178a0 that I found in this topic: http://answers.microsoft.com/nl-nl/windows/forum/windows8_1-windows_install/windows-81-afsluitfout-explorerexe-0xe06640b9/0c64290f-2e0b-47fc-a38a-adb9ceb5a5ac

    Now, after this (that is: the uninstalling op the printer software) I returned to a system recovery point I made before the installation of the HP printer software. So that can not be the problem anymore. However, the error message kept returning.

    So I'm pretty much convinced it must have something to do with explorer.exe, the msi-program, compatability-issues and the C++ packages. How to proceed now from here?

    Should I uninstall the C++ 2012 package?If so, can I do that safely? Do I need a newer version of the C++ packages? Where can I find it?

    Please, help me out? I most thankfully await your answer(s).

    • Edited by IRNL Tuesday, September 30, 2014 9:29 PM
    Tuesday, September 30, 2014 12:14 PM