locked
Terminal Server 2003 won't start remote program. RRS feed

  • Question

  • I've got a problem where if I specify a program to run under the programs tab, all that happens is the desktop comes up. Just like a normal session. I have verified domain policies aren't preventing this, from what I can tell. I do have "classic login" "don't save credentials" "don't save username" set though but I don't see how those would be a problem.

    I've tried with notepad.exe to make sure it wasn't just a problem with my app I'm trying to run.

    Any ideas? I searched the forums but everyone else seems to at least get an error about not finding the program or some such so I think this is a bit different.

    Thanks! 
    Monday, December 29, 2008 7:56 PM

All replies

  • What about disabling login scripts, gpo's, etc to make sure nothing is starting that relies on explorer.exe to run.  typically these problems are due to an app or some command running that has a dependency on explorer.exe and obviously, it's not running when you run something from th programs tab.  The first instance of explorer.exe is the desktop.
    Monday, December 29, 2008 8:55 PM
  • Is there a way to log what is processed at startup in that kind of detail so I can see if there is a GPO I'm not aware of doing something? I've got a script but all it does is map a couple drives via net use.
    Tuesday, December 30, 2008 1:54 AM
  • If you think it's GPO, you can run gpresult or a RSOP through the group policy management console.
    Tuesday, December 30, 2008 2:40 PM