locked
Possible malware infection...or other issue? RRS feed

  • Question

  • Recently one of my PCs was infected by the sirefef virus, and I backed up my school documents before performing a complete reformat and reinstall of Windows. However, I find that my PC is still having problems (freezing, many different event viewer issues, etc.) and I'm convinced that I am still infected with the rootkit, and that I re infected myself by copying over those backed up files. I will be doing another clean reinstall without those files, and that should hopefully fix my problem.

    However, here is the real issue. The major problem is that when I backed up my files onto two USBs, i wanted to make sure that they were free of viruses. So, like an idiot, I plugged the USBs into both my other home computers and scanned them for viruses. The report came up clean, and I disconnected the USBs.
    Here's where the problem comes in. Now, on one of the PCs, whenever I try and run anything as administrator on a non-admin account, everything freezes up and multiple instances of consent.exe are shown in the task manager for every time that I run something as admin (i.e. if i try and run 3 programs as admin, nothing will pop up and 3 instances of consent.exe will appear). I looked it up and people said that this is possibly caused by a corrupt catroot2 database...so I tried the instructions posted here :http://www.wincert.net/tips/microsoft-windows/2522-consetexe-hangs-when-trying-to-use-run-as-administrator

    However, whenever I try to run any of those esentutl commands, I always get 'access denied'. I tried using the take control command, changing the permissions, booting in safemode, renaming the folder (problem still persists), always gives me access denied. I can rename the folder regularly through windows explorer, but that does not solve the consent freezing problem.

    I decided to check my other computer to see if the problem is on that computer too. There is no freezing...but the esentutl commands all still give me access denied whenever I try to access system32. Same with the infected PC. 

    Now I'm afraid that I've managed to infect ALL THREE of these PCs through the USB sticks...as far as I'm aware these issues were not present prior to the USBs being plugged in....all virus scans come up negative on both PCs, however on the first PC (the one with the consent.exe error) i recently removed Win32/FakeRean that MSE had detected. 

    I don't know what to do...now I feel as if every computer in my household is infected...I don't know where to go with this. Again, i am denied from using the esentutl command on anything in the system32 folder on ALL THREE PCs...would a repair install of Windows fix this issue? All three PCs are running Windows 7, the one with the consent freezing has 32 bit and the others are 64bit 



    Thursday, August 9, 2012 10:34 PM

Answers

All replies