locked
Remote Desktop (RDP) - connects via IP, but not name? RRS feed

  • Question

  • Hi

    I've got 2 PC's, one running W8.1 Ent, and the other running 8.1 Pro (named "HUB").  I recently rebuilt the Hub PC as it was running slow, so it's a clean install.  When I try to RDP to it, it's fine via the IP address, but when I connect via the name, it reports that my 'Credentials did not work'.  I'm using the only account on the Hub PC to connect, and it has admin rights (and works when connecting via IP)

    If I ping HUB, it returns the Ping perfectly.  Obviously, RDP sessions are allowed, and the firewall is open for RDP.

    This was working prior to the rebuild, and I'd rather not fix the IP on this particular PC, so does anybody have any ideas?

    Thanks, Pete 

    Friday, March 14, 2014 5:02 PM

All replies

  • You can ping computer by name and IP address or by IP only?

    Looks like you are working with cached values. Search/google key words:

    RDP cache "Windows 8"

    ... and find topics that point to clearing cache

    Regards

    Milos

    

    Saturday, March 15, 2014 8:21 AM
  • Thanks.  I cleared my complete RDP cache, but still no luck.  I can ping both by name and IP. 
    Sunday, March 16, 2014 1:37 AM
  • Hi,

    From the machine where you are remoting to YourPC, What does ping -a <IPofYourPC> give? Does it give a different computer name?

    If so then your DNS server is not updated with resource records of YourPC. From YourPC, try following commands:

    ipconfig /flushdns

    ipconfig /registerdns.

    It will take 15 mins or so to register that computers resource records with DNS.


    Kate Li
    TechNet Community Support

    Monday, March 17, 2014 8:14 AM
  • Thanks. It's not an DNS issue, since I can RDP to the remote PC via IP or Name, the problem is that it rejects my creds when I connect via name.
    Monday, March 17, 2014 1:04 PM
  • This is really just a stab in the dark, but how are you supplying your credentials, user, or pc\user?
    Monday, March 17, 2014 1:35 PM
  • The remote PC just has one account on it -  my outlook.com acccount since that syncs the desktop and other content with my other PCs.  so the user name is xxxxx@outlook.com.  I did try using microsoftuser\xxxxxxx@outlook.com, but that didn't make any difference.  Both PC's are joined to a local workgroup.  When connected via IP, I just use the xxxxxx@outlook.com without any issues.
    Monday, March 17, 2014 4:04 PM
  • Hi,

    you need to use your remote machine name along with the remote user name, i.e. your remote user name is "Eddy", then you need to connect to "HUB" server with the name "HUB\Eddy", you will be notified with a certificate warning, that's OK you are accessing within your LAN I understand, just say yes and tick the box "don't warn again", then you will be asked the credential and Bod's your uncle ;-)

    Hope this helps

    Eddy

    Friday, June 13, 2014 9:20 AM
  • Thanks.  It still generates a 'remote connection failed' message.  No issues connecting via IP address though.

    Pete

    Saturday, June 14, 2014 1:13 PM
  • DNS Issue,

    Fix is on your Server, go to DNS Manager, click on forward lookup zones, delete the A record for the pcname you have issues with, reboot the pc you are trying to connect to and then you can rdp to the computer name.

    Ta

    Wednesday, January 17, 2018 3:18 PM
  • THANK YOU.  This worked great the first time, where nothing else did.

    Monday, October 8, 2018 9:46 PM
  • Oh... I had this problem for hours and hours! I could finally solve it like this:

    0- I tried all the methods which ppl had suggested on internet and none of them worked!

    1- I pinged my remote computer by its name from the host via its name. It was pinged successfully and returned to me the IP of the remote.

    2- I compared the IP which I got from pinging with the IP number which I already had from the remote computer. THEY were different!

    3- I noticed that the host computer is searching the name of the remote computer on the wrong network (and of course it inquires the wrong DNS server!)

    4- So I typed "ipconfig /all" on console of the host to see which network is the preferred network... DAMN IT! the network which is created by Oracle Virtual Box is the preferred network. The pinging packet is sent to this network, for some nonesense reason it gives a reply so the pinging LOOKS successful, although it is indeed unsuccessful.

    5- I changed the preferred network on the host computer (you can google it how), the pinging was successful and the real remote computer was pinged. But for some reason the RDC (Remote Desktop Connection) still did not work. I even deleted its cache, yet no result! Finally I uninstalled Virtual Box completely, and dada... RDC worked fine!

    That worked for me. I hope it helps others.






    • Edited by S.Hossein Friday, November 23, 2018 10:56 AM
    Friday, November 23, 2018 10:52 AM
  • Tried all the above but could not connect. I ended up as a last resort rejoining the domain and was then able to connect with PC name. Hope it helps.
    Wednesday, December 12, 2018 10:05 PM
  • I try the below workaround it's fixed my problem.

    1. Control Panel\All Control Panel Items\Network and Sharing Center

    2.Click on Local Area Network Connection (under Access Type)

    3. Under Local Area Connection > Click on Properties 

    4. Select TCP/IPv4 or TCP/IPv6 > Click on Properties 

    5. Under General TAB > Click on Advanced >

    6 . Under DNS tab >  Select Append these DNS suffixes (in order)

    7 . Click add > add those domain's in your company network 

    8.  tick the Checkbox register this connection's addresses in DNS > click OK to apply the changes. 

    9. Restart your PC and try again the remote desktop. 

    Friday, August 28, 2020 2:18 AM