locked
Unable to load rules for Office 365 MP RRS feed

  • Question

  • Hi

    I am getting the following errors in the event log for each rule for the office 365 MP.

    I have added the subscription and configured the proxy account. The connection to the API has shown healthy for over 24 hours. But my issue is that the dashboads for Service Status, Alerts Resolved, Message Centre etc. Are not generating.

    The Error is

    Rule/Monitor "Microsoft.SystemCenter.O365.Discovery.Service" running for instance "0365ZZZ" with id:"{E5600A40-D025-CA8D-FAD2-D360C4247}" cannot be initialized and will not be loaded. Management group "ZZZ"

    I am not able to create the account in 365. But I am ensured that the account has Global Admin rights.

    But I have also tried to connect direct to the message centre using IE and the account created. And get the error: access denied

    Tuesday, October 7, 2014 2:49 PM

Answers

All replies


  • But I have also tried to connect direct to the message centre using IE and the account created. And get the error: access denied

    This Last bit really makes me think that the permissions have not been setup right. If the account cant read that page, then it wont generate alerts correctly. If your company uses ADFS then it will need to be created in Active Directory and the correct Email / Attributes will need to be assigned. If not then you can do it from the admin section of the office 365 site. This might be one of those circumstances where you get whoever is managing it to show you that it is setup properly. 
    Tuesday, October 7, 2014 3:09 PM
  • Thanks for the reply. That certainly was the case for account access

    I have now had the account set to a Global Admin and created a second account with Global Admin rights

    I get the same error for the first subscription created. I know configured the 2nd account and now get the same errors. The accounts def have Global Admin rights and there no other errors apart from the 4 rule/monitor will not be loaded events.

    The Subcrition Health is showing healthy for both subscriptions. I have also looked at the following link

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/73388dff-39b5-4d2e-951e-5f0601cbbbd8/office-365-monitoring-using-scom-2012-r2?forum=operationsmanagergeneral

    Should I be able to see the subscription account running a monitoringhost.exe under task manager?

    Tuesday, October 7, 2014 4:34 PM
  • I want to say no that you wont see a process running ( at least all the time) as I dont see one myself for our setup. Are you behind a proxy? What type of account are you using for both of the run as profiles? Example... We use ADFS to authenticate within the network. So for the main runas account I used the email as the log in account (scommonitor@contoso.com format). For the proxy account I used an Active Directory account (since it was adfs i used the same account, but i took off the @contoso.com). I cant say that im 100% correct about this since the documentation and existing knowledge is light at this time, but our stuff seems to be up and running. Hope this helped some, and let us know if this was the same for you.
    Tuesday, October 7, 2014 6:21 PM
  • I have set the same way lstarcher .

    Also I now have a 2nd MG up and running to test this and I'm not getting the unloaded rules error. But I'm getting to the same state. The connection is healthy. But yet none of the other widgets in the dashboard are displaying. No errors in the eventlog or SCOM itself.

    Is there a way of testing the API to O365 is working correctly?


    • Edited by CCBOYNO Wednesday, October 8, 2014 9:18 AM
    Wednesday, October 8, 2014 8:59 AM
  • For configure Office 365 Management Pack, You can check below link

    http://www.microsoft.com/en-us/download/details.aspx?id=43708


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question, please click "Mark As Answer" Mai Ali | My blog: Technical | Twitter: Mai Ali

    • Proposed as answer by Yan Li_ Monday, October 20, 2014 6:07 AM
    • Marked as answer by Yan Li_ Thursday, October 23, 2014 3:14 AM
    Wednesday, October 8, 2014 3:00 PM
  • This sounds really dumb, but I had this problem and it fixed itself when I closed and re-opened the Console. Other than that I think I would need information about your setup that would be TMI possibly. 

    and.... are there bots that post on these forums canned responses?? haha

    Thursday, October 9, 2014 1:24 PM
  • Hi,

    I would like to suggest you go through the management pack guide in the link Mai provided, and we may follow the guide to configure the management pack.

    Regards,

    Yan Li


    Regards, Yan Li

    Monday, October 20, 2014 6:09 AM