none
How to work out why a drive is included in system state RRS feed

  • Question

  • HI, I have a problem with one of our file servers, the system state backup is huge.

    I've run a test backup via wbadmin to a file share and at the moment the system state backups up C: and G:, where G is a LUN with over 500Gb of data on it.  

    What I'd like to know is why is G being included in the system state, as far as I can tell it only has user files on it, there are no system files that I am aware of on it.  

    Ideally I'm looking to find away to exclude G: from my backups returning them to under 30Gb.

    Any help would be appreciated. 

    Cheers,

    Stephen.
    Saturday, January 12, 2013 6:32 PM

Answers

  • Hi Stephen,

    On your protected server, open command prompt with administratives rights and type:

    Diskshadow

    then

    List writers

    Find string * WRITER "System Writer" then - Paths affected by this component:

    Verify which file are part of system state.

    Otherwise you may try to use -Exclude parameter : 

    Wbadmin start backup
    [-backupTarget:{<BackupTargetLocation> | <TargetNetworkShare>}]
    [-include:<ItemsToInclude>]
    [-nonRecurseInclude:<ItemsToInclude>]
    [-exclude:<ItemsToExclude>]
    [-nonRecurseExclude:<ItemsToExclude>]
    [-allCritical]
    [-systemState]
    [-noVerify]
    [-user:<UserName>]
    [-password:<Password>]
    [-noInheritAcl]
    [-vssFull | -vssCopy]
    [-quiet]

    http://technet.microsoft.com/fr-fr/library/cc742083(v=ws.10).aspx

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog


    Saturday, January 12, 2013 8:02 PM
  • Looks like it is WDS that's sucking in the drive, I've uninstalled it and the system state is reduced to just C:

    I'll add WDS back onto the server on it's own much smaller drive, as we only use it for boot images for MDT, having it included in the System State isn't an issue.

    Thanks for your help,

    Stephen.

    Saturday, January 12, 2013 9:03 PM

All replies

  • Hi Stephen,

    On your protected server, open command prompt with administratives rights and type:

    Diskshadow

    then

    List writers

    Find string * WRITER "System Writer" then - Paths affected by this component:

    Verify which file are part of system state.

    Otherwise you may try to use -Exclude parameter : 

    Wbadmin start backup
    [-backupTarget:{<BackupTargetLocation> | <TargetNetworkShare>}]
    [-include:<ItemsToInclude>]
    [-nonRecurseInclude:<ItemsToInclude>]
    [-exclude:<ItemsToExclude>]
    [-nonRecurseExclude:<ItemsToExclude>]
    [-allCritical]
    [-systemState]
    [-noVerify]
    [-user:<UserName>]
    [-password:<Password>]
    [-noInheritAcl]
    [-vssFull | -vssCopy]
    [-quiet]

    http://technet.microsoft.com/fr-fr/library/cc742083(v=ws.10).aspx

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog


    Saturday, January 12, 2013 8:02 PM
  • Hi, I checked what you suggested and only files listed are on c:\

    I do see references to G under the WRITER "WDS VSS Writer"

    I was under the impression that I could not use -exclude when using -allcritical.

    Cheers,

    Stephen. 

    Saturday, January 12, 2013 8:42 PM
  • Looks like it is WDS that's sucking in the drive, I've uninstalled it and the system state is reduced to just C:

    I'll add WDS back onto the server on it's own much smaller drive, as we only use it for boot images for MDT, having it included in the System State isn't an issue.

    Thanks for your help,

    Stephen.

    Saturday, January 12, 2013 9:03 PM