none
SetDpmServer failed with errorcode =0x80072141, error says: The specified group type is invalid RRS feed

  • Question

  • Hi all,

    We are running Data Protection Manager 2010.

    I have installed a protection agent manually on a Windows 2003 Server (32bit)

    I am struggling to configure a DPM Protection Agent using the 'SetDpmServer' command. The error I get when trying to do so reads like this:

    "SetDpmServer failed with errorcode =0x80072141, error says: The specified group type is invalid."

    Can anyone please help me at all?

    Thank you

    Monday, January 14, 2013 10:01 AM

All replies

  • Hi Steven,

    First could you verify that you meets Windows 2003 prerequisites ?

    http://technet.microsoft.com/en-us/library/ff399140.aspx

    Windows Server 2003 Service Pack 2 (SP2), Core, Standard, Enterprise, and Datacenter Editions
    - Before you can protect a file server running Windows Server 2003 SP2, you must apply the following updates:
    Knowledge Base article 940349: Update for Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=186465).
    - The hotfix described in Knowledge Base article 975759: An application or service that uses a file system filter driver may experience function failure on a computer that is running Windows Vista, Windows Server 2003, or Windows Server 2008 (http://go.microsoft.com/fwlink/?LinkId=185943).

    Then from your protected W2003 server open command prompt with administratives privilege and type:
    cd /d "C:\Program Files\Microsoft Data Protection Manager\DPM\bin"
    SetDpmServer -DpmServerName <YourDPMServerName>

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog

    Monday, January 14, 2013 2:13 PM
  • I had this problem on a 2003 domain controller (in a child domain) running SP2 with all prerequisites (including domain trust) and followed this process.

    Added the DPM server to the DPMRADCOMTrustedMacines$DomainController and DPMRADOMTrustedMachines$DomainController groups on the child domain controller

    Set up DCOM permissions on the child DC for the DPMRA DCOM object (cannot find original document) but in the dcomcnfg section here http://blogs.technet.com/b/dpmsupport/archive/2009/05/19/troubleshooting-agent-deployment-in-data-protection-manager-2007-dcom.aspx

    Enabled DTC access on the child DC as indicated here http://support.microsoft.com/kb/817064/en-au (Source document for troubleshooting here http://support.microsoft.com/default.aspx?scid=kb;EN-US;978900)

    Made the domain controller a GC (not sure if this is relevant)

    In the system event log I started seeing: The Machine-default permissions settings do not grant remote activation permissions for the COM server application with CLSID .......

    I then launched dcomcnfg on the child DC and browsed to component services, computer, my computer and on the properties of my computer under COM Security, Launch and Activate permissions - edited limits and added the DPM server providing local/remote launch and local/remote activation.

    When I next ran the setdpmserver.exe -dpmservername fqdpnofDPMServer I successfully completed the command and no longer received the error.

    Hope this helps anyone else with this issue.

    Thursday, August 1, 2013 2:04 AM