locked
Exchange DAG - Losless move - Client impact RRS feed

  • Question

  • Hello all,

    we encounter some problems if i do a losless move of a DB from one node to another. The client is asked to reauthentictae. Unfortunately the prompt window prefills the DAG-DNS Name as domain and not the domain. So the user will see DAG-Name\Username instead of Domainname\Username. A authentication against the DAG-Name will be ofcause not working. Any ideas why we have such behaviour ?

    Exchange environment: CAS - NLB (2 Nodes) - DAG (3 nodes) - All nodes in same subnet.

    Regards Timo

     


    MCSE / MCSA on Windwos 2000 / 2003
    Wednesday, February 16, 2011 10:00 AM

All replies

  • Do you have a CAS array in place? You shouldn't get any authentication prompts.
    Furthermore in Exchange 2010 the clients don't connect to the mailbox server directly, they connect to the CAS server.

    Something isn't correct with the configuration here - the DAG-Name shouldn't even be seen by the users. Have you used the same IP address for the DAG as the CAS array or something?

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    Wednesday, February 16, 2011 1:56 PM
  • Agree sounds like it. Check that your DB is set to the FQDN of your CAS array.

    Get-MailboxDatabase <DB name> | fl RpcClientAccessserver


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Wednesday, February 16, 2011 2:57 PM
  • CAS-Array configured as written: "CAS - NLB (2 Nodes)"

    I know the clients do not connect to MBX server when working on Mapi since Ex2010.

    And i must say SORRY: So the user will see DAG-Name\Username instead of Domainname\Username is WRONG.

    Authenticationpromt is "CAS-Array-Name\Username" instead of "Domainname\Username".

    Checked all MBX-Databases, alle point to CAS-Array.

    Regards Timo


    MCSE / MCSA on Windwos 2000 / 2003
    Friday, February 18, 2011 12:44 PM
  • Does the same behavior occur if you connect via Outlook Anywhere? Does it default to casarrayname\username?


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Friday, February 18, 2011 6:57 PM
  • No Outlook Anywhere configured..

    Regards Timo


    MCSE / MCSA on Windwos 2000 / 2003
    Monday, February 21, 2011 2:04 PM
  • I havent seen the DAG Name in the auth box, but I have noticed that since SP1, the switchovers are not as clean as in the RTM days and Outlook sometimes goes offline and back online again once the stores are mounted.

     

    Monday, February 21, 2011 2:09 PM
  • SP1 not installed yet.

    Needed to wait for thirdparty SW to get work with SP1

    Regards Timo

     

     


    MCSE / MCSA on Windwos 2000 / 2003
    Tuesday, February 22, 2011 9:45 AM
  •  @ AndyD

    Read above, it was a mistake from me Auth box shows: CAS_NLB-Name\username.

    Regards Timo



    MCSE / MCSA on Windwos 2000 / 2003
    Tuesday, March 1, 2011 5:44 PM