locked
Pasted hyperlinks aren't immediately underlined in Word 2010 ... RRS feed

  • Question

  • Hello,

    When I paste a link into a document in Word 2010, it is not immediately underlined/recognized.

    I need to either press space or return or click in the hyperlink for it to become underlined.

    Is there a way to make Word 2010 recognise hyperlinks as soon as they are pasted?

    This behavior carries through to Outlook 2010, which uses Word as editor.

    Thanks,

    - Alan.


    Friday, February 22, 2013 2:03 PM

Answers

All replies

  • No.  You must either press the space bar or return.

    Note, Outlook 2010 does not actually use Word as its editor.  It has it's own "Word-like" editor.


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org

    Sunday, February 24, 2013 10:04 AM
  • Thanks Doug. What's annoying is that in Outlook 2003 pasted hyperlinks are immediately recognised. We're upgrading users who are used to pressing Ctrl-v and immediately pressing Send. When they do that now, the recipient gets a broken link. It's a hard habit to break.
    Sunday, February 24, 2013 1:15 PM
  • Thanks Doug. What's annoying is that in Outlook 2003 pasted hyperlinks are immediately recognised. We're upgrading users who are used to pressing Ctrl-v and immediately pressing Send. When they do that now, the recipient gets a broken link. It's a hard habit to break.
            
             
    Are you pasting an actual hyperlink (in HTML) or just a hyperlink address? Also, the result depends on whether you paste into an HTML/RTF message or into a plain text message.

    Stefan Blom, Microsoft Word MVP

    Sunday, February 24, 2013 1:54 PM
  • It's a full http link copied from the address field in Internet Explorer, so starts with http. The message text in Oultook is HTML format. Same behaviour in Ms Word 2010 as in Outlook. Probably the same with file: links too. Thanks.
    Sunday, February 24, 2013 2:03 PM
  • It's a full http link copied from the address field in Internet Explorer, so starts with http. The message text in Oultook is HTML format. Same behaviour in Ms Word 2010 as in Outlook. Probably the same with file: links too. Thanks.
     
     
    OK. When you paste something from the address field in IE (or in any browser), it's the same as pasting a typed (plain text) hyperlink address. I just tested this, and I have to press the space bar to trigger the AutoFormat As You Type option to replace "Internet and network paths with hyperlinks."

    Stefan Blom, Microsoft Word MVP
    Sunday, February 24, 2013 2:47 PM
  • Ok thanks for your time. My point is that the behaviour has changed compared to previous versions.
    Sunday, February 24, 2013 2:49 PM
  • Ok thanks for your time. My point is that the behaviour has changed compared to previous versions.
            
          
    Maybe it changed in Outlook (never used Outlook 2003), but it's the same in Word 2003 and 2007.

    Stefan Blom, Microsoft Word MVP

    • Edited by Stefan BlomMVP Sunday, February 24, 2013 3:10 PM
    • Marked as answer by AMGT Sunday, February 24, 2013 3:10 PM
    Sunday, February 24, 2013 3:01 PM