none
Project Server 2007 - Force check-in enterprise objects RRS feed

  • Question

  • When we click on "Force check-ion enterprise objects" we are receiving the following error message.

    System.Web.Services.Protocols.SoapException: ProjectServerError(s) LastError=GeneralUnhandledException Instructions: Pass this into PSClientError constructor to access all error information
    at Microsoft.Office.Project.Server.WebService.PWA.AdminReadCheckedOutEnterpriseProjects()

    What is happening here?

    • Edited by Sanjeev S K Monday, September 13, 2010 9:19 PM spelling correction
    Monday, September 13, 2010 9:06 PM

Answers

  • Hi Sanjeev,

    This can be caused by other Enterprise Objects (like custom fields) being stuck in a checked-out state.
    Can you try the following:

    • Login to PWA with administrator permissions
    • Server Settings -> Force Check In Enterprise Objects
    • In the selection box select Enterprise Fields
    • If fields show up in the grid, and no-one is currently editing the field: select the field and click the Check-In button

    You should be able now to check-in your project.

    If not, go back to the Force Check In Enterprise Objects page anv verify that the Enterprise Global is not 'stuck' in a checked-out state. If it is, Check-In the enterprise global.

    I hope this helps,
    Hans


    My EPM blog: Projectopolis

    Thank you. When I select Server Settings -> Force Check In Enterprise Objects, it throws the error message and I don't get to select anything.

    We created a new SSP and provisioned a new site. Now we are not getting error message.
    • Marked as answer by Sanjeev S K Tuesday, September 21, 2010 11:00 PM
    Tuesday, September 21, 2010 11:00 PM

All replies

  • Hello Sanjeev,

    My first thoughs are to reboot Project server and the SQL Server and see if the error goes away.

    It sometimes weird data or control characters get inserted in data and it can have strange behaviors. 

    If the reboot doesn't fix the problem, I would open the project schedule and save it locally to the disk drive and then delete the project.  Once deleted, I would create new project from project schedule.

    Cheers!

    Michael Wharton, MBA, PMP, MCT


    Sincerely, Michael Wharton, MBA, PMP, MCT, MCSD, MCSE+I, MCDBA www.WhartonComputer.com
    Thursday, September 16, 2010 2:51 PM
    Moderator
  • Hi Sanjeev,

    This can be caused by other Enterprise Objects (like custom fields) being stuck in a checked-out state.
    Can you try the following:

    • Login to PWA with administrator permissions
    • Server Settings -> Force Check In Enterprise Objects
    • In the selection box select Enterprise Fields
    • If fields show up in the grid, and no-one is currently editing the field: select the field and click the Check-In button

    You should be able now to check-in your project.

    If not, go back to the Force Check In Enterprise Objects page anv verify that the Enterprise Global is not 'stuck' in a checked-out state. If it is, Check-In the enterprise global.

    I hope this helps,
    Hans


    My EPM blog: Projectopolis
    Thursday, September 16, 2010 3:18 PM
    Moderator
  • Hi Sanjeev,

    This can be caused by other Enterprise Objects (like custom fields) being stuck in a checked-out state.
    Can you try the following:

    • Login to PWA with administrator permissions
    • Server Settings -> Force Check In Enterprise Objects
    • In the selection box select Enterprise Fields
    • If fields show up in the grid, and no-one is currently editing the field: select the field and click the Check-In button

    You should be able now to check-in your project.

    If not, go back to the Force Check In Enterprise Objects page anv verify that the Enterprise Global is not 'stuck' in a checked-out state. If it is, Check-In the enterprise global.

    I hope this helps,
    Hans


    My EPM blog: Projectopolis

    Thank you. When I select Server Settings -> Force Check In Enterprise Objects, it throws the error message and I don't get to select anything.
    • Edited by Sanjeev S K Thursday, September 16, 2010 4:11 PM ...
    Thursday, September 16, 2010 4:10 PM
  • Hello Sanjeev,

    Run "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\bin\psconfig -cmd upgrade -inplace b2b -wait -force"

    Fix the wizard in case of any failure. Later try to check-in the projects.

     


    Cheers. Happy troubleshooting !!! Sriram E - MSFT Enterprise Project Management
    Friday, September 17, 2010 2:33 AM
    Moderator
  • Hi Sanjeev,

    This can be caused by other Enterprise Objects (like custom fields) being stuck in a checked-out state.
    Can you try the following:

    • Login to PWA with administrator permissions
    • Server Settings -> Force Check In Enterprise Objects
    • In the selection box select Enterprise Fields
    • If fields show up in the grid, and no-one is currently editing the field: select the field and click the Check-In button

    You should be able now to check-in your project.

    If not, go back to the Force Check In Enterprise Objects page anv verify that the Enterprise Global is not 'stuck' in a checked-out state. If it is, Check-In the enterprise global.

    I hope this helps,
    Hans


    My EPM blog: Projectopolis

    Thank you. When I select Server Settings -> Force Check In Enterprise Objects, it throws the error message and I don't get to select anything.

    We created a new SSP and provisioned a new site. Now we are not getting error message.
    • Marked as answer by Sanjeev S K Tuesday, September 21, 2010 11:00 PM
    Tuesday, September 21, 2010 11:00 PM