locked
Cannot delete Distributed application RRS feed

  • Question

  • Hi i'm trying to delete a distributed application from operations manager 2007. the application is empty and has no other objects within it. but when i try and delete the DA i get the following error. can somone please explain how i can delete the DA i think i need to delete the references in the management pack lan but really dont want to break the management pack. thanks ------------------------------------------------------------------------------ Note: The following information was gathered when the operation was attempted. The information may appear cryptic but provides context for the error. The application will continue to run. : Verification failed with [1] errors: ------------------------------------------------------- Error 1: : Failed to verify View with ID: View_b99fb1ce1c874b61b6dc14ba171798ac Target property :ManagementPackElement=Service_476271aab3eb4230b2a9556b7ffc4174 in ManagementPack:[Name=Lan, KeyToken=, Version=1.0.0.0] for this View is incorrect.Cannot find ManagementPackElement [Type=ManagementPackClass, ID=Service_476271aab3eb4230b2a9556b7ffc4174] in ManagementPack [ManagementPack:[Name=Lan, KeyToken=, Version=1.0.0.0]] ------------------------------------------------------- Failed to verify View with ID: View_b99fb1ce1c874b61b6dc14ba171798acTarget property :ManagementPackElement=Service_476271aab3eb4230b2a9556b7ffc4174 in ManagementPack:[Name=Lan, KeyToken=, Version=1.0.0.0] for this View is incorrect.Cannot find ManagementPackElement [Type=ManagementPackClass, ID=Service_476271aab3eb4230b2a9556b7ffc4174] in ManagementPack [ManagementPack:[Name=Lan, KeyToken=, Version=1.0.0.0]] : Failed to verify View with ID: View_b99fb1ce1c874b61b6dc14ba171798ac Target property :ManagementPackElement=Service_476271aab3eb4230b2a9556b7ffc4174 in ManagementPack:[Name=Lan, KeyToken=, Version=1.0.0.0] for this View is incorrect.Cannot find ManagementPackElement [Type=ManagementPackClass, ID=Service_476271aab3eb4230b2a9556b7ffc4174] in ManagementPack [ManagementPack:[Name=Lan, KeyToken=, Version=1.0.0.0]] : Target property :ManagementPackElement=Service_476271aab3eb4230b2a9556b7ffc4174 in ManagementPack:[Name=Lan, KeyToken=, Version=1.0.0.0] for this View is incorrect. Cannot find ManagementPackElement [Type=ManagementPackClass, ID=Service_476271aab3eb4230b2a9556b7ffc4174] in ManagementPack [ManagementPack:[Name=Lan, KeyToken=, Version=1.0.0.0]] : Cannot find ManagementPackElement [Type=ManagementPackClass, ID=Service_476271aab3eb4230b2a9556b7ffc4174] in ManagementPack [ManagementPack:[Name=Lan, KeyToken=, Version=1.0.0.0]]
    Monday, December 7, 2009 3:43 PM

Answers

  • It looks like View with ID View_b99fb1ce1c874b61b6dc14ba171798ac in management pack Lan 1.0.0.0 targets a class that does not exist (Service_476271aab3eb4230b2a9556b7ffc4174).

    One way of doing this would be to identify the view that targets (most likely) your distributed app and remove it in the ops console. Then, try removing your distributed app.

    If that doesn't work, try the following:
    - Export the Lan MP from the Administration tab to an XML file.
    - Open it in an XML editor and find the <View> tag that has an ID attribute equal to View_b99fb1ce1c874b61b6dc14ba171798ac.
    - Delete the entire <View> tag and save the MP. (Make sure you delete the closing </View> tag if it exists for that view.)
    - Import the modified MP into your management group and try deleting the distributed application again.
    This posting is provided "AS IS" with no warranties, and confers no rights. Use of included script samples are subject to the terms specified at http://www.microsoft.com/info/cpyright.htm
    • Marked as answer by jasonjscott Tuesday, December 8, 2009 9:32 AM
    Monday, December 7, 2009 10:07 PM

All replies

  • It looks like View with ID View_b99fb1ce1c874b61b6dc14ba171798ac in management pack Lan 1.0.0.0 targets a class that does not exist (Service_476271aab3eb4230b2a9556b7ffc4174).

    One way of doing this would be to identify the view that targets (most likely) your distributed app and remove it in the ops console. Then, try removing your distributed app.

    If that doesn't work, try the following:
    - Export the Lan MP from the Administration tab to an XML file.
    - Open it in an XML editor and find the <View> tag that has an ID attribute equal to View_b99fb1ce1c874b61b6dc14ba171798ac.
    - Delete the entire <View> tag and save the MP. (Make sure you delete the closing </View> tag if it exists for that view.)
    - Import the modified MP into your management group and try deleting the distributed application again.
    This posting is provided "AS IS" with no warranties, and confers no rights. Use of included script samples are subject to the terms specified at http://www.microsoft.com/info/cpyright.htm
    • Marked as answer by jasonjscott Tuesday, December 8, 2009 9:32 AM
    Monday, December 7, 2009 10:07 PM
  • It might also be a view from the monitoring section of the console that is associated with your application.
    This posting is provided "AS IS" with no warranties, and confers no rights. Use of included script samples are subject to the terms specified at http://www.microsoft.com/info/cpyright.htm
    Tuesday, December 8, 2009 1:39 AM
  • thanks that worked removing that was created in another area of monitoring
    Tuesday, December 8, 2009 9:33 AM
  • Your method worked fine.  I deleted two out of five that way.  The next day I was looking at the Authoring pane and remember the Service level tracking I installed/configured.  I had the same issue, but forgot I had created Service Level Tracking items.  I deleted the SLA items and then I could delete the Distributed Application.
    • Proposed as answer by Yan Li_ Wednesday, February 18, 2015 6:55 AM
    Friday, January 22, 2010 2:31 PM