locked
Dell D630 Blue screens Only after rebooting vista RRS feed

  • Question

  • Have a weird problem I can not seem to fix.

    Have a D630 with windows vista enterprise. Boots into vista. Vista runs great. Go to start --> restart, computer restarts, shows vista boot up bar. Goes around 1 1/2 times, then Blues screens for 1 second and screen then goes black. After 10 seconds computer reboots and comes up with a windows error recovery. If i choose start windows normally, it will blue screen again. Only way to stop it is to fully turn off the laptop then it will boot fine into vista.
    I have updated all drivers, did windows update. Updated the bios, removed the dvd r drive and still does a blue screen on restart.

    Any ideas?

    Thursday, July 26, 2007 8:06 PM

All replies

  • Update:

    The blue screen error is a Stop error

    Heres the code

    stop: 0x0000007b (0x80403ba0, 0xc0000034, 0x00000000 0x00000000)


    Made an image of the machine and imaged up another d630 with that image, same error.

    Friday, July 27, 2007 2:14 PM
  • I had the same issue building on either a D620 or a 745 workstation.

     

    You need to update your drivers.  If you're using BDD, then just add them to the Out-of-Box Drivers folder.  If you're doing a "super-Sysprep" image, make sure to add the Chipset and SATA drivers.

     

    That should get you by the BSoD.

     

    Good luck!

    Thursday, August 2, 2007 8:24 PM
  • I have the same error exactly;

    I have a fujitju siemans amilo pro 3405 laptop, the problem occured right after I updated the B.I.O.S the flash had reset the whole partition I used the vista dvd for repairs and it returned the error that vista could not repair.

     

     

    stop: 0x0000007b (0x80403ba0, 0xc0000034, 0x00000000 0x00000000)

    so I have been scrooling the knowledge base and have been working all options bcdedit command that let vista see the hard drive. next I worked on the diskpart command to even get the vista utilities to work . now I will attempt to  get into the system registy to edit out the bios up date.

     

    Do you have any suggestions????

     

     

    Friday, August 10, 2007 12:43 AM
  •  

    Same problem here. HP dv6000z. It occurred after I did a chkdsk /f.
    Friday, August 31, 2007 9:03 AM
  • Make sure you have the latest version of the Intel Matrix Storage Manager driver (available from the Intel website) on your machine as there have been issues with the iastor.sys on Dell machines running Vista.

     

    Wednesday, September 26, 2007 11:14 AM
  • Matt's got it right.  The issue at hand is the version of msahci.sys that shipped with Vista has a bug in it (evidently).  The problem we had was a D630 from Dell would work fine, but loading a MSDN copy of Vista Ultimate would BSOD.  I tracked it down to the AHCI system driver located at c:\windows\system32\drivers\msahci.sys.  On the Dell-supplied Vista disk the version of that file is 6.0.6000.16391.  On the MSDN media it's 6.0.6000.16386.  A quick search for that file on TechNet shows that vile is now up to 6.0.6000.20544 as of KB933578.

     

    There are 4 options that I can see that you can take to resolve the problem:

    1. Change the SATA controller from AHCI mode to ATA mode in BIOS.  You'll get a warning that you may need to reinstall the OS but I didn't.  Try this at your own risk.  My gut tells me that even if you did get a BSOD on boot from doing this that you could just change back - no harm no foul.  The problem is that this setting disables the use of the Intel Turbo Cache card, if you choose to use one.
    2. Get version .16391 or better of msahci.sys.  I copied the newer file from another machine that had Dell's Vista Business image on it.  You can also get it by downloading a KB patch from Microsoft that has the fix, like KB933578.  Search TechNet on the file name for your options on patches.  My guess is that this driver will be reved with SP1 for Vista as well.  You simply copy the newer file ontop of the old one and reboot.
    3. Install the Intel Matrix Storage driver, which bypasses the Microsoft-supplied driver for AHCI connectivity.  I'm sure you can find a version on Intel's site, or you can get it from Dell's.  The version I used is v7.0.0.1020, A02.  The download from Dell is R154200.exe.  It will extract itself to a local directory and then you'll need to use Device Manager to update the SATA AHCI controller (manually specify the driver location).
    4. This is really 3a - put the drivers from step 3 on a USB stick of floppy and install Vista from scratch.  When you get to the disk setup screen click the new driver link and point to where the driver is supplied.  Vista will then use the Intel driver instead of the Microsoft driver and you'll have a 100% clean install.

    Hope this helps someone!  I know this has frustrated me for a LONG time!

     

     

     

    Thursday, September 27, 2007 7:48 PM
  • Thanks for the help nathan. 1 question though where do I find msahci from Dell's Vista Home Premium Image. I am having problems with AHCI once I boot into windows vista ultimate.


    Friday, October 26, 2007 12:57 PM
  • The driver is at C:\Windows\System32\drivers.

    Wednesday, October 31, 2007 3:59 PM
  • Hi!

     

    I found this method to work (on a Dell Precision M4300):

     

    1. Install vista WITHOUT the AHCI enabled in BIOS.

    2. After installation, download the Intel Matrix Storage driver but do not install it.

    3. Enable the ACHI service as described here: http://support.microsoft.com/kb/922976

    4. Reboot the machine.

    5. Enter BIOS and enable ACHI

    6. Boot and start Vista

    7. Install the Intel Matrix Storage driver that will bypass the MS-supplied ones...

     

    After step 5 the  computer "blue screen":ed once, but once I did a complete power of and got it to boot again and then installed the Intel drivers it has worked flawlessly...

     

     

    Friday, November 16, 2007 6:21 AM
  • I found a slightly easier solution: Install the Intel Application Turbo Memory under the SATA Drives category on Dell's site for D630 updates.  This fixed it for me!!!

    Thursday, November 22, 2007 5:25 AM
  • I recently purchased an XPS 1330 with vista home and needed to upgrade to vista ultimate cos I want to use visualisation features etc. However after the upgrade, I continually had the BOSD which was becoming very annoying -  was ready to throw in the towel and run xp until I found this post - so THANKS!

     

    btw - I also installed the Intel Turbo Drivers from the supplied DELL DRIVERS CD after the upgrade and it fixed the problems with the SATA driver as well.

     

    Seriously thou i was considering canning vista - seems to be an PIG with lipstick (i.e. revamped user interface with many underlying issues?)

    Tuesday, November 27, 2007 2:38 AM
  • Thank you so much I hava a D630 with the same problem it has been driving me nuts  downloaded the driver from Dell now all is well

     

    Thursday, February 21, 2008 2:52 PM
  •  

    Install the Intel Application Turbo Memory under the SATA Drives category on Dell's site for D630 updates. 

    This fixed the problem !!!!!!!!!!

     

    Here is the link to download - http://support.us.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R167146&formatcnt=1&libid=0&fileid=226136

    Thursday, February 28, 2008 12:13 AM
  • I am getting the same message, but with Windows XP pro! I am using a bart PE disk to boot from! Any ideas?

     

    This an HP media center PC! The HD has been removed from the system!

    Sunday, May 18, 2008 12:36 AM
  • I followed the suggestion of a post to change from AHCI to ATA in the SATA section of the BIOS but got the BSOD when I attempted installation using the drivers from the Dell site.

     

    Using the drivers from the supplied Dell Windows XP CD, that means not slecting F6 to install third party drivers, caused the installation to succeed.

     

    Hope this helps.

    Friday, May 30, 2008 5:04 PM
  •  David Wasserman wrote:

    I found a slightly easier solution: Install the Intel Application Turbo Memory under the SATA Drives category on Dell's site for D630 updates.  This fixed it for me!!!

     

    David's solution also worked for me on my Dell Latitude D630.  However, I just wish I had found this answer before going through all the steps below first and resolving the issue on my own.

     

    I first updated the BIOS to the latest version.  That didn't stop the BSOD issue, but many of my devices that weren't showing up before became available.  Then, one by one, I installed the drivers from the Dell Drivers Disk that shipped with the laptop and restarted between each driver install.  Not until I finally got down to the Serial ATA Drivers and installed the Intel Turbo Memory driver did I stop getting the BSOD on restart. 

     

    Here is the order that I installed the drivers:

     

    BIOS Rev: A10

    nVidia Quadro NVS 135M Rev: A02

    Broadcom 57XX Gigabit Integrated Controller Rev: A00

    Intel Mobile Chipset Rev: A02

    Intel (R) Wireless WiFi Link 4965AGN Rev: A05

    SIGMATEL STAC 92XX C-Major HD Audio Rev: A09

    O2Micro OZ77CXX USB SmartCard Controller Rev: A03

    UPEK Touchstrip Reader Rev: A02

    Conexant D330,HDA,MDC,v.92,modem Rev: A01

    Intel Turbo Memory Rev: A01

     

    NOTE: I did not install the Intel Matrix Storage Manager Driver, because when I went through the device manger to update the Intel(R) 82801HEM/HBM SATA AHCI Controller, it came back indicating that "Windows has determined the driver software for your device is up to date".

     

    Hope this helps others as well.

     

    ~Alex

    Friday, June 6, 2008 6:18 PM
  • i was having this problem on my dell m1330 after a re-install of vista premium when it was doing windows update.
    i had installed all the supplied drivers from the dell drivers page for the m1330 but this problem still happened.

    after installing the above suggested driver and it was fine after that. 

    Here is the link to download - http://support.us.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R167146&formatcnt=1&libid=0&fileid=226136


    thanks guys!
    Saturday, December 5, 2009 3:37 PM
  • I have a customer's Dell Inspiron 1720. I'm a tech & believe you me...I looked EVERYWHERE online & until I discovered this thread on the subject...I was clueless. Just the sheer magnitude of all the possible things that could have caused the problem had me running around like a chicken with my head cut off & pulling out my hair. I've been sick for 4 days with the flu too, so that didn't help matters much..lol. It was a complete waste of my time compared to what I will get paid to have figured it out for him, but that's my job....to learn & I'm grateful & will never forget this problem fix on future machines. I just went to the dell site & downloaded the Intel Application Turbo Memory under the SATA Drives category like a few people here suggested. All I did was install it & reboot....problem solved....GOD BLESS THIS SITE!!!...lol~: )
    Monday, January 31, 2011 6:28 AM
  • I wanted to add some details to my earlier post. I 1st thought that it was a problem with the hard-drive, so we tried the easy fix by just reloading it. The hard-Drive refused to fully complete the install about 3/4ths of the way through, so at this point I was thinking corrupt HD cus I know my disk is good. I didn't want to blindly charge him for a new HD so at this point I sent him home to allow me time to troubleshoot. I uninstalled a stick of ram & rebooted it & it completed the install, so like a dummy...I called him up saying problem solved. I tried to reboot it after the updates & it did it again, so I turned off the machine & took out the battery & used just the power supply to power it on....worked great. Then I tried to reboot it & it did it again! Basically I was eliminating possible causes to help him save money. I went into the computer & got it to the point I could read the blue screen message & copied it down & started a massive online research for a solution to the problem. There was soooo much BS about the subject that I couldn't figure it out. Tonight I enter the symptom along with the error code...the fact that it only did it on a reboot & still took me 2 hours to weed through all the BS until I finally found this thread with people that looked like they knew what they were talking about & had others saying it worked. What threw me off was the problem's intermittent failure. So I wasted allot of time going through the ABC's of trouble shooting & unless you've actually experienced this issue before....it can really mess with your head...lol! I don't think people realize how difficult it can be for us & how much online research we sometimes have to do for them, but when I do run across a new challenge like this...I chalk it up to a learning experience & never charge them any extra cus that's my job & I love it.
    Monday, January 31, 2011 7:38 AM
  • ***UPDATE***Could the whole cause of this problem in the 1st place be the fact that the dell driver R167146.EXE has a broken digital signature??? AVG just hit on it & wanted to quarantine the setup files in "My Documents", so I added it to the exceptions. Now I'm running a whole system scan to see if it will do the same to the actual installed driver....***UPDATE#2*** Ok...nothing was found on the 2nd AVG scan....all looks good now~: ) (pats self on back)
    Monday, January 31, 2011 8:21 AM
  • I found a slightly easier solution: Install the Intel Application Turbo Memory under the SATA Drives category on Dell's site for D630 updates.  This fixed it for me!!!

    BINGO!

     

    I did a fresh installed of Vista Ultimate on an inspiron 1420. I got BSOD on boot unless I switched SATA mode to ATA in BIOS. This annoyed me though because I wanted to enable ACHI instead of ATA. So I switched back to ACHI mode and restarted the computer over and over again until finally it booted. I was then able to go to Dell website and install the Turbo Memory driver. Running perfectly now.

    SO I guess the issue is that driver, the problem is you cant install that driver when your computer is in ATA mode, but if you put your computer in ACHI mode you get BSOD on boot. So it kind of leaves you stuck. Luckily after multiple retries my comp eventually started in ACHI mode so I could install the update. 

    Tuesday, February 1, 2011 12:22 AM