locked
SCCM 2012 Installation Error RRS feed

  • Question

  • Hello,

    Can you please help? SCCM stops installing with the following:

    error 14: SQL Error Message Failed to generate documents:A .NET Framework error occurred during execution of user-defined routine or aggregate "fnGenerateLanternDocumentsTable": ~~System.Data.SqlClient.SqlException: The locale identifier (LCID) 2072 is not supported by SQL Server.~~System.Data.SqlClient.SqlException: ~~   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)~~   at System.Data.SqlClient.SqlDataReaderSmi.InternalNextResult(Boolean ignoreNonFatalMessages)~~   at System.Data.SqlClient.SqlDataReaderSmi.NextResult()~~   at System.Data.SqlClient.SqlCommand.RunExecuteReaderSmi(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream)~~   at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, TaskCompletionSource`1 completion, Int32 timeout, Task& task, Boolean asyncWrite)~~   at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method)~~   at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method)~~   at System.Data.SqlClient.SqlCommand.ExecuteReader()~~   at Microsoft.SystemsManagementServer.SQLCLR.Utilities.IsDesktopConfigurationItem(String ciAuthoringScopeId, String ciLogicalName, Int32 ciVersion)~~   at Microsoft.SystemsManagementServer.SQLCLR.LanternDocumentsGenerator.GenerateLanternDocuments(String digest, Boolean shouldGenerateLanternDocuments)~~., Digest:<DesiredConfigurationDigest xmlns="http://schemas.microsoft.com/SystemsCenterConfigurationManager/2009/07/10/DesiredConfiguration" xmlns:r="http://schemas.microsoft.com/SystemsCenterConfigurationManager/2009/06/14/Rules"><!--Authored against the following schema version: 5--><GlobalSettings AuthoringScopeId="GLOBAL" LogicalName="OperatingSystem" Version="2"><r:Annotation><r:DisplayName Text="Operating system" ResourceId="OperatingSystemGlobalCondition"/><r:Description Text="Determines the operating system used by a Windows device" ResourceId="OperatingSystemGlobalConditionDesc"/></r:Annotation></GlobalSettings></DesiredConfigurationDigest>~  $$<Configuration Manager Setup><11-13-2014 02:29:03.871-120><thread=4108 (0x100C)>
    ERROR: Failed to execute SQL Server command; CCISource::InsertObject returned 14  $$<Configuration Manager Setup><11-13-2014 02:29:03.871-120><thread=4108 (0x100C)>
    ERROR: Failed to install default configuration items (FinalSqlOperations).  $$<Configuration Manager Setup><11-13-2014 02:29:03.886-120><thread=4108 (0x100C)>
    ~~===================== Completed Configuration Manager 2012 Server Setup =====================  $$<Configuration Manager Setup><11-13-2014 02:29:03.902-120><thread=4108 (0x100C)>

    Thanks!

    Later update:

    I checked the locale in Sql and everything is set to english and the recommended Latin package is applied. Is there a possibility that the sql data from the <appdata>> folder under Users is keeping some incorrect locale settings? That seems to have not been deleted after previous uninstall. 

    As well, the A: NET Framework line indicates that maybe the .NET was applied with the incorrect locale settings, since it was installed while the system was set to Romanian?

    Please advise, much appreciated :)

    • Edited by adysanro Friday, November 14, 2014 9:59 AM later updates
    Thursday, November 13, 2014 12:34 AM

Answers

All replies

  • what SQL version you are using ? its look SQL compatibility issue

    moutaz ibrahim

    Thursday, November 13, 2014 9:07 AM
  • To be more specific, it's a SQL configuration issue. This is your error The locale identifier (LCID) 2072 is not supported by SQL Server.

    Have a look here for the requirements: http://technet.microsoft.com/en-us/library/gg682077.aspx#BKMK_SupConfigSQLSrvReq


    My Blog: http://www.petervanderwoude.nl/
    Follow me on twitter: pvanderwoude

    • Marked as answer by adysanro Saturday, November 15, 2014 12:20 PM
    Thursday, November 13, 2014 9:47 AM
  • are you using different language

    moutaz ibrahim



    Thursday, November 13, 2014 9:54 AM
  • Agree with Peter. This is a configuration issue. 

    Take a look at my ConfigMgr install guide alongside the SQL pre-reqs link that Peter suggest. Should get you up and running.

    http://sccmentor.wordpress.com/2014/01/08/sccm-2012-r2-step-by-step-installation-guide/


    Cheers

    Paul | sccmentor.wordpress.com

    Thursday, November 13, 2014 9:56 AM
  • what SQL version you are using ? 

     did you add another language   (Romanian -Moldava) ?


    moutaz ibrahim

    Thursday, November 13, 2014 10:04 AM
  • I'm using SCCM 2012 SP1 and SQL Sever 2012 Standard to which SP1 was applied. Yes indeed, the locale was Romanian - Moldova but that was changed to English US.

    Thursday, November 13, 2014 5:17 PM
  • Did the sql installed on the same server ? If yes did you change the local language after installing sql ?

    moutaz ibrahim

    Thursday, November 13, 2014 5:39 PM
  • Yes, I changed the language after doing the install. It seems that I also missed a dependency and didn't apply the schema correctly. Following the guide that Paul provided and will post back .
    Thursday, November 13, 2014 6:46 PM
  • I recommend to install from scratch better

    moutaz ibrahim

    Thursday, November 13, 2014 6:55 PM
  • Reinstalled SQL and SCCM from scrath and it didn't work. Even removed the sql registries after uninstall. The log still show the same locale problem although everything is set to english now. Under Region settings it does say that the locale is English. I've reinstalled sql from scratch too many times for this problem.

    Wouldn't there be another solution? I don't think it's would be reasonable to reinstall windows server only for this.. or each dependency and sql every time I try.

    Thank you.

    Thursday, November 13, 2014 8:29 PM
  • Now, this is hilarious. I found what the problem was. The locale was indeed set to Romanian but only partially.
    Under "Region and Language" in control panel, "Administrative" tab/"Copy settings" the language, format and location were set to Romania/Romanian for Welcome screen and New User accounts only. Current user was set with English; see here: http://www.tiikoni.com/tis/view/?id=beb049a

    It's just funny how much time I had to spend on this, looking on other forums and nobody knowing what's really happening.
    After researching it seems that a lot are affected by this, hopefully it will help someone.

    Thank you for the support!
    Saturday, November 15, 2014 12:20 PM