locked
Change in column settings not working RRS feed

  • Question

  • I have a column that I created for a library, which I made a site column before adding it to the library page. When I created the column I made it a required column to ensure the column had a value in it. I now would like to change this column to no longer be required and am having some trouble. I have changed the column settings from the library settings page (clicking library settings then selecting the appropriate column) and also the settings of the site column (selecting site settings, then site columns and then the appropriate column, but when I create a new document the document will not save without entering a value in the column that I have now made a not required column.

    Any suggestions?

    Thanks Kate.

    Tuesday, October 8, 2013 9:07 AM

Answers

  • Hello kate,

    I just tested in my machine and working fine. Infect i only made non mandatory from list settings-->column setting. (No need to change in site column settings).

    Are you using content type? to verify this go to doc lib settings-->advanced settings-->Allow management of content types? . If it is no then your settings should work but if it is Yes then go to doc lib setting page again-->go to "Content Types" and click on your content type-->click on column-->change the column settings to Optional if it is Required.

    Let us know your result


    Hemendra:Yesterday is just a memory,Tomorrow we may never see
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Proposed as answer by croute1 Tuesday, October 8, 2013 12:36 PM
    • Marked as answer by macdonald_kate Tuesday, October 8, 2013 12:44 PM
    Tuesday, October 8, 2013 9:20 AM

All replies

  • Hello kate,

    I just tested in my machine and working fine. Infect i only made non mandatory from list settings-->column setting. (No need to change in site column settings).

    Are you using content type? to verify this go to doc lib settings-->advanced settings-->Allow management of content types? . If it is no then your settings should work but if it is Yes then go to doc lib setting page again-->go to "Content Types" and click on your content type-->click on column-->change the column settings to Optional if it is Required.

    Let us know your result


    Hemendra:Yesterday is just a memory,Tomorrow we may never see
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Proposed as answer by croute1 Tuesday, October 8, 2013 12:36 PM
    • Marked as answer by macdonald_kate Tuesday, October 8, 2013 12:44 PM
    Tuesday, October 8, 2013 9:20 AM
  • I did not have management of content types ticked, but after selecting this I was able to change the column in the way you suggested, and it is now fixed!!

    Thank you so much!!!!!!!

    Tuesday, October 8, 2013 9:35 AM