none
Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface. hr = 0x80070005, Access is denied.

    Question

  • Hi all,

    I got me an Acer Iconica w3..... New little 8 inch tablet.

    Setup like any other machine.  Connected to my Windows home server or Windows Server 2012 essentials.  Tried to run a backup using the server connector.  Backup failed with the subject VSS error in the application logs.  I also tried the built in backup Windows 8 backup under control panel labeled Windows 7 File history system image.  No dice with either. 

    Investigating the error, I found some tests to confirm permission - all passed.  Trusting the error message to be accurate (permissions problem) I see direction to make sure the VSS service is started (I started and changed to automatic) and to grant explicit access in the registry. I also see suggestions to grant the Network Service explicit rights to the computer using dcomcnfg.   No dice.

    I've flattened and re-loaded.  Actually on a second machine with a newer image from Acer (first machine had a bad microSD socket that would not eject).  2nd machine exhibits the same symptoms - failing to backup

    Compared settings to another Windows 8 machine - VSS service by default is manual and no explicit permission grants were in place.  e.g. changes above were unnecessary but made just the same as part of trouble-shooting

    Clearly there is something more fundamental that I'm missing?  All other machines are running Windows 8 Pro or Enterprise.  This machine is running Windows 8 basic hence the built in backup can't image to a network but should be able to image to an external drive and/or the server connector should still be able to backup - correct???

    Suggestions as to next steps?

    Wednesday, July 3, 2013 2:56 AM

All replies

  • Hi,

    You may have to make some changes in the registry.

    Note: You’d better backup the registry before change it.

    1. The following example grants access to the "MyDomain\MyUser" account:

    2. Click on Start, typeregedit in the search box.

    3. On the Registry Editor window, navigate to the below location:

    HKEY_LOCAL_MACHINE>SYSTEM>CurrentControlSet>Services>VSS>VssAccessControl <--- ADD KEY

    MyDomain\MyUser = 1 <- ADD VALUE

    If you still come across the issue, to troubleshoot the error condition, you first need to determine what caused it by using the VssAdmin command line tool. After determining the cause of the error condition, follow the steps indicated for each possible cause.

    Access the below link to know about Volume Shadow Copy Service Operations:

    http://technet.microsoft.com/en-us/library/cc734235(WS.10).aspx

    Hope this helps.


    Leo Huang
    TechNet Community Support

    Thursday, July 4, 2013 7:57 AM
    Moderator
  • Hi Leo,

    Thanks for the reply.

    Correct those are the steps I followed per my original note.  Sorry I wasn't 100% clear in outlining the steps.  Either way they don't solve the problem.

    To be clearer, below are the steps I've followed so far.

    1)  Granted explicit permissions in the registry via the VssAccessControl Key.  Note:  the instructions do not explicitly say what type of KeyWord to add???  I added as a DWORD....(based on an example I was able to find) and used a (32-Bit) Value...  Set values to 1 as indicated.  I also tried adding as a string just in case.  Neither alternative worked. 

    VSS Keys look like the following

    VSS

       - Diag......

       - Providers.....

       - Settings......

       - VssAccessControl

             - (Default)      REG_SZ    (value not set)

             - ComputerName\UserName (machine is question is not domain joined - local account - role is admin)

    #2:  vssadmin list writers reports no errors

    #3:  I also confirmed the VSS service was started, and set to manual startup all per the Tech Net article.

    Lastly I tried another alternative for #3 above which suggested the use an internal service account vs. user account.  I tried that both in the reg value and as part of the service configuration - login.

    So short and sweet.... The usual steps to diagnose and repair don't work.  Still have the same problem.  Again only with the new little Acer running Basic Windows 8 or 8.1..... All other machines on the network work great - all are running Windows 8 Pro or Enterprise.

    Thursday, July 4, 2013 5:56 PM
  • Did you ever get this sorted out, Pete?  I've run into the same thing, same scenario.
    Monday, March 3, 2014 5:50 PM
  • Just purchased an Asus T100 'transformerbook' with Windows 8.1 32 bits - same problem here. I'm using Windows Home Server 2011 to perform automatic daily backups, but all I get is this error.....
    Monday, April 7, 2014 7:05 PM
  • Did anyone ever figure out how to solve this problem? I am getting the same error when I try to back up a recently-acquired Windows 10 (upgraded from Windows 7 when that was free) on a Dell Inspiron 3000 laptop.

    I found this thread: https://social.microsoft.com/Forums/en-US/ffca3cdd-9519-4ab8-b92f-c5cdfc59e0c3/whs-2011-backup-vss-8194-issue which indicates it is because WHS 2011 does not back up GPT drives. Holy crap, is that true?! GTP has been an available drive format since Win2000 I think. 

    Log Name:      Application
    Source:        VSS
    Date:          8/24/2018 10:20:12 PM
    Event ID:      8194
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      DELL5RYR4C2
    Description:
    Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface.  hr = 0x80070005, Access is denied.
    . This is often caused by incorrect security settings in either the writer or requestor process.
    Operation:
       Gathering Writer Data
    Context:
       Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220}
       Writer Name: System Writer
       Writer Instance ID: {2f43c0ff-28d9-43ce-b0c0-e129161cf20e}

    Saturday, August 25, 2018 4:40 PM
  • Found this:   hotfix is available to add backup support for UEFI-based computers to back up to servers that are running Windows Home Server 2011 

    https://support.microsoft.com/en-us/help/2781272/a-hotfix-is-available-to-add-backup-support-for-uefi-based-computers-t

    I will install it and let you know if it solves the problem. (This is what I get for updating 6-year-old support threads).


    Saturday, August 25, 2018 6:47 PM