locked
SuppressNameChecks not working in Office Outlook 2019 RRS feed

  • Question

  • Is it not possible to suppress Certificate Name mismatch warnings in Outlook 2019?

    I have tried adding SuppressNameChecks to HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\Security and HKCU\software\policies\microsoft\office\16.0\outlook\security

    I've also tried SupressNameChecks as I've seen many posts saying the spelling is wrong (Supress vs Suppress)

    I have also tried HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover Value: ShowCertErrors Default: 0

     None of the above seem to work. Has the capability been removed or has the registry key changed?

    • Moved by Perry-Pan Tuesday, September 24, 2019 3:18 AM
    Monday, September 23, 2019 9:25 PM

All replies

  • Hi Bobin,

    According to the official article, SuppressNameChecks registry is not applied to Outlook 2019. 

    ShowCertErrors Key is used to control how Outlook handles certificate errors and warnings that are received when it performs http tasks.

    Do you use a certificate that does not match your e-mail address?

    I've also seen similar issue that when using one certificate with multiple accounts in Outlook client, users will also receive Certificate Name mismatch warnings. If this is the case for you, please check this thread. Some add-ins could help solve this.

    Besides, please click No in the bottom of this article and submit your feedback to Microsoft.

    Hope the information is helpful to you.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Edited by Perry-Pan Tuesday, September 24, 2019 4:34 AM
    • Proposed as answer by Perry-Pan Wednesday, September 25, 2019 7:59 AM
    Tuesday, September 24, 2019 3:18 AM
  • Hi Perry.

    Why Microsoft should remove this functionality is difficult to understand.

    Yes the problem is that I (and a number of my clients) use a hosted mail service where the server certificate is that of the hosting company rather than a certificate for the domain of the e-mail address. We cannot change that.

    As soon as we turn on SSL we now get the certificate warning every time outlook is started :-(

    Previous versions of Outlook allowed the warning to be supressed but by "upgrading" to Outlook 2019 we now have a problem.

    Regards,

    Ray.

    Tuesday, September 24, 2019 9:08 AM
  • Hi Bobin,

    I can understand your feelings. This registry has been not working from Outlook 2016. May be the recommended way is to use a certificate that matches your e-mail address.

    We can also post your feedback to Outlook UserVoice.

    It is a place for customers to provide feedback about Outlook. What’s more, if an idea is highly voted there by other customers, Microsoft Product Team will take it into consideration when designing the next version in the future.

    Thank you for your understanding and support!

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Edited by Perry-Pan Wednesday, September 25, 2019 1:35 AM
    • Proposed as answer by AnnieDs Friday, September 27, 2019 2:20 AM
    Tuesday, September 24, 2019 9:42 AM